Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: How to Alt-Tab in Warcraft III using Wine

  1. #1
    Join Date
    Jun 2008
    Beans
    10

    How to Alt-Tab in Warcraft III using Wine

    I created an account with Ubuntu forums JUST to post this message because this seriously was the only thing that kept me from using Linux full time. I had a lot of problems with this and couldn't find a solution anywhere (including on these forums) and I can't register with the Wine application database right now due to some scripting error on their site, so I thought I would start by posting it here.

    First off, let me just explain that the only thing I figured out was Alt-Tabbing. The movies still don't work, but that was not an issue for me.

    To be able to alt-tab out you run warcraft with the opengl and window flag:

    wine /path/to/war3.exe -opengl -window

    ...and then when the window shows up, you just maximize it.

    That's it! You can pan the view using the screen edges just like in full-screen mode, but it still is a (big) window that you can minimize and tab through just like other windows. I actually consider this setup superior to the one I had in Windows XP because I can browse the web and chat in the foreground while still being able to view Warcraft in the background, whereas in windows I had to have Banlist open to be able to monitor Warcraft while I was tabbed out (which I was usually doing while waiting for games to fill up or waiting on clanmates in our clan channel).

    The only flaw is that Warcraft appears choppy only while it is in the background, but foreground applications are still fine. My computer has a good graphics card, but other people may get poor performance results even if it is in the foreground because it is being windowed after all.

    It took me so long to figure the maximize part out. So here are a few things I had tried out before that did not work out or I considered inferior solutions:

    wine /path/to/war3.exe

    Warcraft works (besides the known wine problems with videos), but I can't alt-tab out. If you try it just takes you back to the Warcraft window.

    wine /path/to/war3.exe -opengl

    I can alt-tab out under an older version of wine (0.9.x, something like that) and only if Warcraft is the same resolution as my desktop. I was not happy with this solution because my preferred desktop resolution (1680x1050) was not the same as my preferred Warcraft resolution (1400x1050). That and it required an old version of wine.

    wine /path/to/war3.exe -window [-opengl] without maximizing

    This seemed to be the most promising solution until I found out I couldn't scroll using the screen edges because it was in a window. Using winecfg's directx option to lock the cursor to the window did absolutely nothing. Same for using an emulated desktop with or without window: absolutely nothing.

    wine /path/to/war3.exe -window with maximizing

    DirectX couldn't handle it. It works fine until you tab out and tab back in, upon which it messes up.

    wine /path/to/war3.exe -opengl on a different workspace and switch between workspaces

    It opens correctly, but when you switch to another workspace and back it just disappears completely. You can only close it from system monitor.


    I hope that helps and did not duplicate something somebody else already posted, but I seriously had a hard time finding this solution anywhere.

  2. #2
    Join Date
    Mar 2006
    Beans
    73
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How to Alt-Tab in Warcraft III using Wine

    the crashing on different workspaces is fixed in the latest wine I beleive

  3. #3
    Join Date
    Aug 2008
    Beans
    100

    Re: How to Alt-Tab in Warcraft III using Wine

    Quote Originally Posted by Tekmo View Post
    I created an account with Ubuntu forums JUST to post this message because this seriously was the only thing that kept me from using Linux full time. I had a lot of problems with this and couldn't find a solution anywhere (including on these forums) and I can't register with the Wine application database right now due to some scripting error on their site, so I thought I would start by posting it here.

    First off, let me just explain that the only thing I figured out was Alt-Tabbing. The movies still don't work, but that was not an issue for me.

    To be able to alt-tab out you run warcraft with the opengl and window flag:

    wine /path/to/war3.exe -opengl -window

    ...and then when the window shows up, you just maximize it.

    That's it! You can pan the view using the screen edges just like in full-screen mode, but it still is a (big) window that you can minimize and tab through just like other windows. I actually consider this setup superior to the one I had in Windows XP because I can browse the web and chat in the foreground while still being able to view Warcraft in the background, whereas in windows I had to have Banlist open to be able to monitor Warcraft while I was tabbed out (which I was usually doing while waiting for games to fill up or waiting on clanmates in our clan channel).

    The only flaw is that Warcraft appears choppy only while it is in the background, but foreground applications are still fine. My computer has a good graphics card, but other people may get poor performance results even if it is in the foreground because it is being windowed after all.

    It took me so long to figure the maximize part out. So here are a few things I had tried out before that did not work out or I considered inferior solutions:

    wine /path/to/war3.exe

    Warcraft works (besides the known wine problems with videos), but I can't alt-tab out. If you try it just takes you back to the Warcraft window.

    wine /path/to/war3.exe -opengl

    I can alt-tab out under an older version of wine (0.9.x, something like that) and only if Warcraft is the same resolution as my desktop. I was not happy with this solution because my preferred desktop resolution (1680x1050) was not the same as my preferred Warcraft resolution (1400x1050). That and it required an old version of wine.

    wine /path/to/war3.exe -window [-opengl] without maximizing

    This seemed to be the most promising solution until I found out I couldn't scroll using the screen edges because it was in a window. Using winecfg's directx option to lock the cursor to the window did absolutely nothing. Same for using an emulated desktop with or without window: absolutely nothing.

    wine /path/to/war3.exe -window with maximizing

    DirectX couldn't handle it. It works fine until you tab out and tab back in, upon which it messes up.

    wine /path/to/war3.exe -opengl on a different workspace and switch between workspaces

    It opens correctly, but when you switch to another workspace and back it just disappears completely. You can only close it from system monitor.


    I hope that helps and did not duplicate something somebody else already posted, but I seriously had a hard time finding this solution anywhere.
    When i open Warcraft 3 in full screen mode and i switch workstation with compiz..you know switching cubes..i can't get back into Warcraft III?

  4. #4
    Join Date
    Aug 2008
    Beans
    8

    Re: How to Alt-Tab in Warcraft III using Wine

    Thanks! This was really helpful, but I have a way to take it one step further.

    If you don't emulate a virtual desktop, you can use Compiz to force the game to run full screen. This gets rid of the window borders and menu bars, which means it's a lot easier to scroll in the game.

    Go to System->Preferences->Advanced Desktop Effects Settings enable Window Rules, and put class=Wine in the fullscreen bar.

    UPDATE: Use this instead of class=Wine:
    title=^Warcraft III$
    And it will only fullscreen War3 and not all wine apps.
    Last edited by Ecna; September 3rd, 2008 at 12:37 AM.

  5. #5
    Join Date
    Jun 2007
    Beans
    379

    Re: How to Alt-Tab in Warcraft III using Wine

    Hey, thanks so much for the useful research. Used some of what's here together with my own trial-and-error to write this guide, if anyone wants a complete solution, with proper scrolling and all.

  6. #6
    Join Date
    Apr 2008
    Beans
    68

    Re: How to Alt-Tab in Warcraft III using Wine

    Quote Originally Posted by Ecna View Post
    Thanks! This was really helpful, but I have a way to take it one step further.

    If you don't emulate a virtual desktop, you can use Compiz to force the game to run full screen. This gets rid of the window borders and menu bars, which means it's a lot easier to scroll in the game.

    Go to System->Preferences->Advanced Desktop Effects Settings enable Window Rules, and put class=Wine in the fullscreen bar.

    UPDATE: Use this instead of class=Wine:

    And it will only fullscreen War3 and not all wine apps.
    This FINALLY fixed my problem and had it working just like I wanted.

    Can I buy you a cookie?

  7. #7
    Join Date
    Sep 2006
    Beans
    6

    Re: How to Alt-Tab in Warcraft III using Wine

    I works much better but with one last issue, i use kde4 and i can scroll all sides except the down side, there is a "line" there which you have to keep your mouse cursor or else it won't sroll.
    EDIT:
    After reading the linked post, it seems enabling virtual desktop in winecfg and running WC3 without -window fixes it
    Last edited by eagzor; October 24th, 2008 at 11:50 PM.

  8. #8
    Join Date
    Dec 2008
    Location
    chennai
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to Alt-Tab in Warcraft III using Wine

    Thanks! This was really helpful, but I have a way to take it one step further.

    If you don't emulate a virtual desktop, you can use Compiz to force the game to run full screen. This gets rid of the window borders and menu bars, which means it's a lot easier to scroll in the game.

    Go to System->Preferences->Advanced Desktop Effects Settings enable Window Rules, and put class=Wine in the fullscreen bar.

    UPDATE: Use this instead of class=Wine:
    Quote:
    title=^Warcraft III$
    And it will only fullscreen War3 and not all wine apps.

    Hey thanks a lot ECNA , yu saved my day , damn happy )

  9. #9
    Join Date
    Sep 2007
    Location
    Warsaw, Poland
    Beans
    629
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: How to Alt-Tab in Warcraft III using Wine

    Quote Originally Posted by raajheshkannaa View Post
    Thanks! This was really helpful, but I have a way to take it one step further.

    If you don't emulate a virtual desktop, you can use Compiz to force the game to run full screen. This gets rid of the window borders and menu bars, which means it's a lot easier to scroll in the game.

    Go to System->Preferences->Advanced Desktop Effects Settings enable Window Rules, and put class=Wine in the fullscreen bar.

    UPDATE: Use this instead of class=Wine:
    Quote:
    title=^Warcraft III$
    And it will only fullscreen War3 and not all wine apps.

    Hey thanks a lot ECNA , yu saved my day , damn happy )
    Thanks for the tip! You wouldn't know how to make it fully maximize at the bottom, would you:


    Last edited by hotweiss; January 7th, 2009 at 08:59 AM.

  10. #10
    Join Date
    Sep 2007
    Location
    Warsaw, Poland
    Beans
    629
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: How to Alt-Tab in Warcraft III using Wine

    Quote Originally Posted by hotweiss View Post
    Thanks for the tip! You wouldn't know how to make it fully maximize at the bottom, would you:


    Problem fixed. I enabled virtual desktop and disabled all of the desktop integration features; plus I removed the -window extension.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •