Results 1 to 3 of 3

Thread: scripting help - mediatomb

Hybrid View

  1. #1
    Join Date
    May 2006
    Beans
    23

    scripting help - mediatomb

    hi,
    can someone help me with this script. i cannot get it to work and it keeps on saying "line 14 no such file or directory"


    #!/bin/bash

    INPUT="$1"
    OUTPUT="$2"
    VIDEO_CODEC="mpeg2video"
    VIDEO_BITRATE="4096k"
    VIDEO_FRAMERATE="25"
    AUDIO_CODEC="mp2"
    AUDIO_BITRATE="192k"
    AUDIO_SAMPLERATE="44100"
    AUDIO_CHANNELS="2"
    FORMAT="dvd"

    exec /usr/bin/ffmpeg -i "${INPUT}" -vcodec ${VIDEO_CODEC} -b ${VIDEO_BITRATE} \
    -r ${VIDEO_FRAMERATE} -acodec ${AUDIO_CODEC} -ab ${AUDIO_BITRATE} -ar ${AUDIO_SAMPLERATE} \
    -ac ${AUDIO_CHANNELS} -f ${FORMAT} - > "${OUTPUT}" 2>/dev/null

  2. #2
    Join Date
    Jun 2008
    Beans
    5
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: scripting help - mediatomb

    I see that you script is the standard say from:
    http://gentoo-wiki.com/HOWTO_MediaTomb

    Are you sure that your ffmpeg is located in /usr/bin?

    If it is in the right location try run it by hand, does it work?

  3. #3
    Join Date
    May 2006
    Beans
    23

    Re: scripting help - mediatomb

    excuse my stupidity, but i found the answer. i forgot to add the output file to the end of the command line. thanks anyway

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •