Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ATI hardware acceleration

  1. #1
    Join Date
    Jan 2008
    Beans
    84

    ATI hardware acceleration

    When I activate the ATI hardware acceleration, and I restart the computer, i get a black screen, instead of the login.

    Im using Hardy. this is my lspci

    00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
    00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
    00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
    00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
    00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
    00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
    00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
    00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
    00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
    01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
    02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    02:07.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
    02:09.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
    02:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 18)
    02:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller
    02:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 09)
    02:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 04)

  2. #2
    Join Date
    Sep 2006
    Location
    Idaho
    Beans
    253
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ATI hardware acceleration

    I am not familiar with your particular ATI card, but on my Radion 9500 Pro the default open source drivers work fine for Compiz and the 3D games in the repositories. You may want to try them out before going to the restricted drivers.
    Being old doesn't mean you are wise and have all the answers, it just means you have already heard all the questions...

  3. #3
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: ATI hardware acceleration

    You can reconfigure X by rebooting into the recovery mode kernel (second option and grub) and running
    Code:
    dpkg-reconfigure xserver-xorg -phigh
    reboot
    Let the computer restart normally, then post for us your video card:
    Code:
    lscpi | grep VGA
    Older ATI cards (9500 or so and older) don't use restricted/proprietary fglrx drivers.

  4. #4
    Join Date
    Jan 2008
    Beans
    84

    Re: ATI hardware acceleration

    I've been reading around and it seems like it's something to do with the MESA drivers, dont letting the ATI drivers to take control, but I still cant get it to run!

    ugger@dbugger-laptop:~$ lspci | grep VGA
    01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
    dbugger@dbugger-laptop:~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)

  5. #5
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: ATI hardware acceleration

    I don't think that video card is compatible with the fgrlx restricted drivers, so you should uninstall them:
    Code:
    sudo apt-get remove --purge xorg-driver-fglrx
    Then reconfigure X with
    Code:
    sudo dpkg-reconfigure xserver-xorg -phigh
    Now restart X with CTRL+ALT+BACKSPACE
    You can follow this guide to allow compiz to work - http://ubuntuforums.org/showthread.php?t=764633

  6. #6
    Join Date
    Jan 2008
    Beans
    84

    Re: ATI hardware acceleration

    But it worked fine with gutsy....the problem started when i moved to hardy...

  7. #7
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: ATI hardware acceleration

    I understand, but Hardy is using a new version of X which has some differences from the previous version - specifically, it relies more on autodetection than xorg.conf. Did following the advice in my last post help?

  8. #8
    Join Date
    Jan 2008
    Beans
    84

    Re: ATI hardware acceleration

    Quote Originally Posted by Rocket2DMn View Post
    I understand, but Hardy is using a new version of X which has some differences from the previous version - specifically, it relies more on autodetection than xorg.conf. Did following the advice in my last post help?
    I did what you said, and... well, everything looks pretty much the same.

    In "System -> Administration -> Hardware Drivers" the "ATI hardware accelerated" says "not enabled". And of course compiz doesnt work. It gives me a white screen of death for 30 seconds.

  9. #9
    Join Date
    May 2007
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: ATI hardware acceleration

    Can you please post the output of
    Code:
    compiz --replace

  10. #10
    Join Date
    Jan 2008
    Beans
    84

    Re: ATI hardware acceleration

    Quote Originally Posted by Rocket2DMn View Post
    Can you please post the output of
    Code:
    compiz --replace
    Here it is:

    dbugger@dbugger-laptop:~$ compiz --replace
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
    Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
    Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
    this gave me a white screen so I had to leave with CTRL+C

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •