Results 1 to 6 of 6

Thread: Google Earth flickers gray

  1. #1
    Join Date
    Jun 2008
    Beans
    7

    Google Earth flickers gray

    I installed the linux version of Google Earth on my Ubuntu 8.04 but the screen with the earth on it continuously flickers gray blocks. My graphics card is Radeon 400x I think and under hardware drivers its says that the ATI graphics driver is running.

    so whats up?

  2. #2
    Join Date
    May 2008
    Beans
    30

    Re: Google Earth flickers gray

    i have the same problem. using ATI X1400.

  3. #3
    Join Date
    Jan 2007
    Beans
    196

    Re: Google Earth flickers gray

    did you have compiz on?
    if so, you may need to turn compiz (desktop-effect) off.

    also,you may want to try install google-earth 4.2 (instead fo the beta 4.3), 4.2 dun have the new feature but it render much better on the average graphic card

  4. #4
    Join Date
    Nov 2007
    Location
    United Kingdom
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Smile Re: Google Earth flickers gray

    Thanks for the advice. I had the same problem and it was compiz. When I disabled the desktop effects all was OK.

    daveR

  5. #5
    Join Date
    Aug 2008
    Beans
    4

    Re: Google Earth flickers gray

    I have finally signed up because I think I may have something to add here.

    I have found that switching back and forth between metacity and compiz to correct Google Earth causes errors and instability. Also when returning to compiz, conky only displays on 1 desktop on my desktop cube.
    Below is the error compiz returns when reopening from metacity. Apparently this error is a fairly decent issue all its own.
    Code:
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.
    Also I believe this issue is related to the problems with compiz and Opengl viewports. I don't know if anyone is making these connections, I'm just trying to brainstorm. I think that this is a localized issue.

    I think compiz.real is the file that controls transparency or at least has something to do with it, correct me if I'm wrong. Perhaps there is some sort of error with it, or an error with the files that point to it.

    I have a temporary fix that may work better than what I've seen suggested, which was:

    Code:
     you@yourhouse:~$ metacity --replace
    MY FIX:
    I left compiz on, went to System>Preferences>Advanced Desktop Effects Settings, Then Desktop>Desktop Cube>Transparent Cube Tab and adjusted the transparency to 100%. Where Google Earth before was completely unusable, I now only get a few tics and tweaks.

    Does anyone else run a transparent cube desktop? If so, this might work for you.

  6. #6
    Join Date
    Nov 2008
    Location
    Copenhagen, Denmark
    Beans
    29
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Google Earth flickers gray

    Quote Originally Posted by imon9 View Post
    did you have compiz on?
    if so, you may need to turn compiz (desktop-effect) off.

    also,you may want to try install google-earth 4.2 (instead fo the beta 4.3), 4.2 dun have the new feature but it render much better on the average graphic card
    I experience the same,
    I am new to ubuntu (just installed 8.10), could you please tell me how to disable compiz.

    Jarl

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •