Results 1 to 4 of 4

Thread: Fluxbox: Background of a theme/style.

  1. #1
    Join Date
    Mar 2008
    Location
    New Jersey, USA
    Beans
    95
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Fluxbox: Background of a theme/style.

    After I install a new theme/style on Fluxbox, the background does not change. I cannot manually change the background either. Any help?

  2. #2
    Join Date
    Oct 2006
    Location
    Kansas City
    Beans
    1,509
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fluxbox: Background of a theme/style.

    fbsetbg /path/to/background/image.whatever work at all???

  3. #3
    Join Date
    Aug 2006
    Location
    Somewhere but Not Here
    Beans
    965
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Fluxbox: Background of a theme/style.

    There are two ways. As Nythain mentioned you can add that command to your ~/.fluxbox/startup like this:

    Code:
    fbsetbg /path/to/file/filename.extension &
    or if you also use Gnome, you can change the wallpaper from gnome-appearance-properties and you can add it to startup:

    Code:
    gnome-settings-daemon &
    Don't forget to add the ampersand (&) at the end.
    My blog | Ubuntu Hardware List | Wine Application Database | Jamendo
    (Don't "sudo rm -rf" anything. See this page)
    It's all about fixing BUG #1!

  4. #4
    Join Date
    Nov 2005
    Location
    Manchester, UK
    Beans
    50

    Re: Fluxbox: Background of a theme/style.

    There are two ways to set the background in Fluxbox: globally and for a specific style. The global background will be used with any style that doesn't set its own background, but the style background will override the global background.

    There are different ways of setting the global background, but the easiest I've found is to use gsetroot. It's in the repos and it's a little GUI frontend to esetroot, which you'll already have if you installed the latest Fluxbox from the repos.

    To set a specific background for a specific style you need to edit the style's file in ~/.flubox/styles using background. Using background is explained here:

    http://fluxbox-wiki.org/index.php/Background

    As it says in the wiki, background has replaced rootCommand, but I've found that a lot of styles that specify their backgrounds still use rootCommand. Assuming you're using the current Fluxbox, you need to edit the style to use background to get it to work.

    The wiki also covers alternative ways to set the global background, if you don't want to use gsetroot.

    (Another thing I found when trying to get styles to work properly is that the specified fonts don't always work without some tinkering. This applies to a couple of the artwiz fonts, and may apply to others. For example, one style specified the mints-strong font, but it wasn't working. Everything looked ok because the name of the font's .pcf file was as it was specified in the style file - with the hyphen. But when I looked at its properties, the font's 'real' name is mintsstrong. I changed it to that in the style file and it worked.)
    Last edited by HandyAndy; June 11th, 2008 at 09:26 AM. Reason: minor correction

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •