Just installed Ubuntu 8.0.4 and noticed my Logitech Z-10 usb speakers didn't work, as alsa by default does not allow snd-usb-audio to occupy slot 0. Very quick fix.

Code:
sudo gedit /etc/modprobe.d/alsa-base
Scroll down through the code and comment out:

Code:
 #options snd-usb-audio index=-2
Save and exit.

System -> Preferences -> Sound

Set all drop-downs to "ALSA -.."
Set "Default Mixer Tracks" to "Z-10 USB Speaker"

Restart.