Results 1 to 2 of 2

Thread: Alt-Shift layout switch and hot heys

  1. #1
    Join Date
    Nov 2007
    Beans
    2

    Alt-Shift layout switch and hot heys

    Hi folks.

    Recently i discovered that my favourite layout switch combination (alt-shift) is breaking hotkeys in other programmes.
    I.e. it will switch layout if I want to format code in NetBeans (alt-shift-F).

    I tried to change myself to accept other combinations like "alt-capslock" or even "right winkey" (sic!) but it is not a good option and it not worked for me.

    At last I found an almost suitable workaround

    1) choose "alt-shift" as "Layout switching" option
    2) choose "Shift cancels Capslock" in "Micellaneous comptibility options"

    (these are in System -> Preferences -> Keyboard -> Layouts -> Layout option)

    As result "shift-alt" will switch layout and "alt-shift" will head to to hot keys. Weird but works for me.

    Do you guys know better solution?
    May be you know how to make gnome switch layouts by "alt-space" or "winkey-space"

    Please share your knowledge.

    Thanks in advance, Lauri.

    P.s. I'm running ubuntu with gnome

  2. #2
    Join Date
    Dec 2007
    Beans
    1

    Re: Alt-Shift layout switch and hot heys

    I have the same problem. Your solution is better than nothing but not ideal.
    (Thanks anyway).
    The ideal would be if the keyboard was changed after the key-up event not key down. It always annoyed me.. i already wrote a stupid script which which tried to solve this.. but it was not stable and I lost it in a course of time. May be its time to investigate again.
    Hopefully one day Linux will evolve to that (if 15 years is not long enough) (sigh)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •