Results 1 to 6 of 6

Thread: How do I get Tomboy to stop starting up every time I log in?

  1. #1
    Join Date
    May 2006
    Beans
    252

    How do I get Tomboy to stop starting up every time I log in? [SOLVED]

    Now how do I remove this infernal thing from my startup?

    No, it's not under System > Preferences > Sessions > Startup Programs.

    Yes, it is under System > Preferences > Sessions > Current Session (just like every other open program) but has the "Reset" style. But every time I remove it, or set it to "Trash", or set it to "Normal", and click apply, it starts up on login and it's there in the list again set to restart!

    No, I don't have "Automatically remember currently running applications when I log out" checked under System > Preferences > Sessions > Session Options.

    No, Tomboy doesn't have any options in its preferences dialog with regards to automatic startup.

    No, I'm not uninstalling it. I love this app and have many notes in it.

    There has to be SOME way of figuring out what is starting this thing!
    Last edited by Schalken; June 7th, 2008 at 02:13 AM.

  2. #2
    Join Date
    Feb 2008
    Beans
    73
    Distro
    Ubuntu

    Re: How do I get Tomboy to stop starting up every time I log in?

    i have this problem too

  3. #3
    Join Date
    Aug 2005
    Beans
    380

    Re: How do I get Tomboy to stop starting up every time I log in?

    This may be nothing to do with Tomboy per se. There is a bug with the session-saving stuff that means that, if you ever just once turn on auto_save_session, then you are doomed to have the same apps get launched at login, even after you have turned off the auto_save_session option. The bug is described here.

  4. #4
    Join Date
    Jul 2005
    Beans
    740
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How do I get Tomboy to stop starting up every time I log in?

    You are not using the Tomboy panel applet?

  5. #5
    Join Date
    May 2006
    Beans
    252

    Re: How do I get Tomboy to stop starting up every time I log in?

    Aha! AHHHAHAHAHAHAHAAA!!!

    I woke up this morning and asked myself "What could possibly depend on Tomboy running?"

    Deskbar!

    The plugin for Deskbar that lets you search your Tomboy notes needs Tomboy running (because it searches your notes via D-Bus), and starts it if it's not.

    So disable the plugin and everything is rosy again.

  6. #6
    Join Date
    Apr 2007
    Beans
    17
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How do I get Tomboy to stop starting up every time I log in?

    Quote Originally Posted by mannheim View Post
    This may be nothing to do with Tomboy per se. There is a bug with the session-saving stuff that means that, if you ever just once turn on auto_save_session, then you are doomed to have the same apps get launched at login, even after you have turned off the auto_save_session option. The bug is described here.
    The fix in the bug report on launchpad worked for me- delete ~/.gnome2/session.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •