Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Strange JAVA_HOME Problem

  1. #11
    Join Date
    Oct 2005

    Re: Strange JAVA_HOME Problem

    Quote Originally Posted by tberman333 View Post
    After it is shutdown, I still can't restart as I get the same error message as in my previous post.

    At this point, since I can shut it down, I am able to make the changes I needed to (to the web ap I am running), and then I just log off and back on the machine to restart it, but it still seems like some kind of bug that it can't be restarted from terminal (when it could in 7.10)
    Perplexing and interesting at the same time.

    To start with, since you installed by downloading from apache instead of the ubuntu repository then I'm inclined to think that any differences between 7.10 and 8.04 are symptoms, rather than a primary issue.

    I installed tomcat on my 8.04 machine this afternoon and played with the scripts (but didn't actually run tomcat yet.) and both call Also, if you add a script called in the same directory then you can define whatever variables you want to - the main one to consider is probably JAVA_HOME. That lets you set it so the tomcat scripts can read the value, but the rest of the system doesn't have to be bloated with the JAVA_HOME setting for tomcat.

    I'm confused why tomcat only starts for you when you log off and back on. You're running in both cases, right?

    At any rate, I think adding the following line to a new file named in your /usr/local/tomcat/bin/ directory will go a long way for you.

  2. #12
    Join Date
    Oct 2007

    Re: Strange JAVA_HOME Problem

    That did it! Thank you very much for your help!

  3. #13
    Join Date
    Jul 2007

    Re: Strange JAVA_HOME Problem

    Thank you this also solved my problem when trying to get openlaszlo to work. I am adding this post for search purposes.

  4. #14
    Join Date
    Jul 2007

    Re: Strange JAVA_HOME Problem

    bump =D

    just want to say, this solution fixed my issue also... the same issue as everybody else had.

    My issue came about the other day after upgrading to Hardy... This is the second time i've upgraded distro's and had java die on me :s possible problem?

    anyway, Im just happy it works, so thank you to jamesstansell for the nice solution

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts