Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 67

Thread: Nvidia Restricted drivers PROBLEM!!!!

  1. #11
    Join Date
    Feb 2007
    Location
    U.S.A.
    Beans
    1,835
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nvidia Restricted drivers PROBLEM!!!!

    @dansued

    Code:
    4) gksudo gedit /etc/modules
    	4.a) Add "nvidia" without quotes to the list.
    	4.b) Save and Exit
    That should fix you up.

  2. #12
    Join Date
    Feb 2007
    Location
    U.S.A.
    Beans
    1,835
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nvidia Restricted drivers PROBLEM!!!!

    ack nm browser freaked out for some reason
    Last edited by starcannon; June 1st, 2008 at 12:59 AM. Reason: double posted by mistake

  3. #13
    Join Date
    Feb 2007
    Location
    U.S.A.
    Beans
    1,835
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Quote Originally Posted by kemkokems View Post
    Well now I am really pissed of!!!I tried all of these steps above and none of them works and now I totally crushed x-server and it can not find any backup!!!And now I am going to DELETE UBUNTU!!!!!!!!!!!
    ****,its driving me crazy.
    THANX ANYWAY!!!!
    guess you missed at least step
    Code:
    6) sudo cp /etc/X11/xorg.conf ./xorg.conf.backup
    If however you did do step 6 then all you would have to do to get back to where you started would be
    Code:
    sudo cp ./xorg.conf.backup /etc/X11/xorg.conf
    sudo reboot
    GL and relax before you do anymore, you sound a bit manic, computers don't respond well to that.

  4. #14
    Join Date
    Jun 2007
    Beans
    39
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Quote Originally Posted by starcannon View Post
    @dansued

    Code:
    4) gksudo gedit /etc/modules
    	4.a) Add "nvidia" without quotes to the list.
    	4.b) Save and Exit
    That should fix you up.
    nvidia was already in /etc/modules

    any other solutions?

    Thanks in advance!

  5. #15
    Join Date
    Jun 2007
    Beans
    39
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nvidia Restricted drivers PROBLEM!!!!

    so nvidia is in /etc/modules and it still doesn't load after a reboot, however I managed to get a log

    Code:
    /etc/gdm/failsafeXserver: line 47: [: too many arguments
    Warning: Failsafe mode was already attempted within 30 seconds
    Warning: Falling back to gdm to report the issue.
    btw, when I run nvidia*.run, it reports that the drivers are already installed, but I reinstall it anyway which makes it work. I always let the program reconfigure the X config. I think the drivers are fine maybe just some file needs to be updated.

  6. #16
    Join Date
    Feb 2007
    Location
    U.S.A.
    Beans
    1,835
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nvidia Restricted drivers PROBLEM!!!!

    I'm stumped for the moment, putting nvidia in that modules list is supposed to cure your particular problem...

    I've got to run out and setup a lan and wireless printer here in a few minutes, when I get back home I will look into this some more with you if you like.

    If you could post the output of

    Code:
    cat /etc/X11/xorg.conf
    cat /etc/modules
    cat /etc/default/linux-restricted-modules-common
    here in the thread perhaps that will help shed some light on this.

  7. #17
    Join Date
    Jun 2008
    Beans
    3

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Thanks Starcannon for your detailed post. I've been through many others with bits and pieces of this over the past couple days and your post is the most complete and makes sense. Unfortunately, it didn't work so I am still trying to figure this out. I am new convert but trying to come up to speed so I appreciate the detail.

    Here is the present situation:
    -8.04 kernel 2.6.24.18 after recent update.
    -I have presently tried loading Nvidia 173.14.05 by your procedure
    -Video Card is NV40 (Gforce 6800) AGP
    -Motherboard is P4 based 2.4 GHz Intel ASUS P4PE
    -Monitor is Samsung SyncMaster 204B connected Via DVI
    (also attempted archived video driver revisions previously, but I think by your cleanup I should be good. Nothing has made any difference in behavior so far on any attempt)

    What happens is that on gdm start the screen will blink 3 times as if attempting to detect monitor and then drop back to the "low resolution" dialog allowing only 800x600. I never get the Nvidia logo.

    If I use the Xorg autoreconfigure sudo dpkg-reconfigure -phigh xserver-xorg command, it does work and I can get up to 1280x1024 with no hardware acceleration. Also note same exact hardware under XP (dual booted from Grub startup menu) loads the latest Nvidia drivers for windows and resolution at 1600x1200 (60 Hz) no problem.

    Here is the file info requested. Note I added some extra info into the monitor and display section from an earlier Xorg config file that should be valid as an attempted fix because default nvidia-xconfig generated file did not work either.

    I am pretty much at a dead end at this point, so hoping some new ideas come forward or perhaps some tests I can run to try to help track this down. Everything else I have found via search of other threads comes up with a part or subset of what you have already posted.

    Thanks

    Code:
    ~$ cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon May 19 00:33:37 PDT 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/X11R6/lib/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
     	Vendorname	"Samsung"
    	Modelname	"Samsung SyncMaster 204T/204Ts/214T,SyncMaster Magic CX201Ts(Digital)"
    	Horizsync	30-81
    	Vertrefresh	56-75
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
     SubSection "Display"
    		Depth	24
    		Virtual	1600	1200
    		Modes		"1600x1200@60"	"1024x768@70"	"800x600@60"	"1024x768@60"	"1152x864@75"	"1280x1024@75"	"1280x960@60"	"1280x1024@60"	"1280x960@75"	"1400x1050@60"	"1600x1200@65"	"1600x1200@60"
    	EndSubSection
    EndSection
    
    ~$ cat /etc/modules
    # {Standard comment lines removed for this post}
    
    fuse
    lp
    nvidia
    
    ~$ cat /etc/default/linux-restricted-modules-common
    # {Standard comment lines removed for this post}
    
    DISABLED_MODULES="nv"

  8. #18
    Join Date
    Jun 2008
    Beans
    3

    Re: Nvidia Restricted drivers PROBLEM!!!!

    A little more research, hoping this thread is not dead. I looked at the Nvidia driver readme file, Chapter 5 which is the same for both the recommended archived version (by some 173.08) and latest version 173.14.05
    http://us.download.nvidia.com/XFree8...hapter-05.html

    and noticed that although my install by Starcannons procedure seemed to go fine none of the files get written to the directories noted in the list of installed components. The above chapter says for example that the X driver should be at
    An X driver (/usr/X11R6/lib/modules/drivers/nvidia_drv.so)
    but on my system the X11R6 directory is empty and the nvidia installer loaded the driver to to
    usr/lib/xorg/modules/drivers
    . I note that many of the other files appear to have gone to
    XORG
    instead of
    X11R6
    Could this be why my X log says
    (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found
    Is there a way in Linux to grab a whole folder, copy it, and move it to another directory? If so, maybe I could test taking the entire "modules" directory including subs from "lib/xorg" and copying it to "X11R6/lib" I could try and see if this will fix the issue. There is little risk I think because X11R6 is presently empty so it will either find the drivers there after I copy them or keep doing whatever it has been anyway which is no loss. Trouble is being green I don't know how to grab a whole folder and cut and paste in gnome when root privileges are required and I can't seem to login as "root" with the same password I use for sudo in the terminal.

  9. #19
    Join Date
    Jun 2008
    Beans
    3

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Having an interesting coversation with myself but just in case anyone else stumbles on this, I am happy to report this is fixed, although ugily.

    Here's what I did... I decided to flush the whole thing and start over with a brand new install. My drive is just used for Ubuntu system (all data is on shared NTFS drives) so I reloaded the whole ubunt-chilada from scratch (Live CD, full partition, blowing away previous hosed install). Upon first load from the hard drive, the kernel is 2.6.24-16 and I got the notification that restricted drivers and 129 updates were available. I went ahead and let the hardware drivers manager load the restricted drivers but deferred the updates and was able to enable desktop effects. I then yielded to update manager that wanted to install the 129 updates. In spite of a few error messages that some packages did not load (I could not find details in the log on this), I rebooted and new build is 2.6.24-18 (but not the same 2.6.24-18 I had a couple days ago I think it was appended with 18.23 or 18.32 in the terminal window description). Good news is that it appears everything is working now so on to reload all the programs I want (wine, samba, etc.)

    So good news is that as of today a user that does a clean install from the CD image should not have the problems I had with the GForce 6800 (NV40) card. No real way to know if this was an updater issue or something I did in the past couple days changing hardware and hosing my system.

    Attached are the config files just for reference:
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"nvidia"
    	Option		"NoLogo"	"True"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	Defaultdepth	24
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    EndSection
    Section "Module"
    	Load		"glx"
    EndSection
    Code:
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    fuse
    lp
    sbp2
    /etc/default/linux-restricted-modules-common (i.e. nothing blacklisted)
    Code:
    DISABLED_MODULES=""
    So I would say now the nvidia driver issue appears resolved for me. On to running some benchmarks on the games I like (under Windows and Wine) with the same hardware.

  10. #20
    Join Date
    Jan 2007
    Beans
    25

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Quote Originally Posted by PacketRatket View Post
    I went ahead and let the hardware drivers manager load the restricted drivers but deferred the updates and was able to enable desktop effects
    Please make it clear whether you rebooted or not after installing the restricted drivers and before installing the updates?

Page 2 of 7 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •