Results 1 to 7 of 7

Thread: Ugly text in Firefox, slow feeling ubuntu

  1. #1
    Join Date
    May 2006
    Beans
    23

    Ugly text in Firefox, slow feeling ubuntu

    Hey there,

    I'm new to ubuntu and would like to know:

    (1) what font I shoud use/install to get rid of the ugly font in firefox?
    I find the text unbarable in ubuntu. In XP, using firefox, the text is clean and readable. With ubuntu i find the text on the net to be very bad. It is OK on the desktop.

    (2) I find ubuntu 8.04 (I have used no other version) somewhat slow compared to XP. XP is extremely fast. Ubuntu feels slow and heavy.
    Are there tweaks to speed up ubuntu?

    I have a core2duo t7500 and NVIDIA 8600.
    Nvidia driver via envy.
    Newest kernel...

    Why is this and how can I fix it?

  2. #2
    Join Date
    Aug 2007
    Beans
    700
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Ugly text in Firefox, slow feeling ubuntu

    Go to the terminal

    Applications > Accessories > Terminal

    and enter this

    Code:
    sudo apt-get install msttcorefonts
    should solve your font problem.
    I would rather die of thirst than drink from the cup of mediocrity.

    Get better forum search results!

  3. #3
    Join Date
    May 2008
    Beans
    2

    Re: Ugly text in Firefox, slow feeling ubuntu

    Even after this my firefox fonts still baaad. so I picked settings from my xp box. no luck. what am I doing wrong.

    Quote Originally Posted by Bakon Jarser View Post
    Go to the terminal

    Applications > Accessories > Terminal

    and enter this

    Code:
    sudo apt-get install msttcorefonts
    should solve your font problem.

  4. #4
    Join Date
    Mar 2005
    Location
    Des Moines, IA
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ugly text in Firefox, slow feeling ubuntu

    What kind of display do you have? If it's an LCD, you'll want to make sure that subpixel rendering is turned on, if you haven't already done so.

  5. #5
    Join Date
    May 2008
    Beans
    3

    Re: Ugly text in Firefox, slow feeling ubuntu

    Quote Originally Posted by jejones3141 View Post
    What kind of display do you have? If it's an LCD, you'll want to make sure that subpixel rendering is turned on, if you haven't already done so.
    How do you switch on subpixle rendering?

  6. #6
    Join Date
    Dec 2006
    Beans
    1,089

    Re: Ugly text in Firefox, slow feeling ubuntu

    Main Menu > System > Preferneces > Appearance.
    In the window, choose the 'Fonts' tab and click the 'details' button.

  7. #7
    Join Date
    May 2006
    Beans
    23

    Re: Ugly text in Firefox, slow feeling ubuntu

    thanks, seems to have installed some fonts. Now, i'll have to match up the fonts selected in both firefoxes.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •