Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Fresh Heron install, but no wireless

  1. #11
    Join Date
    Jan 2007
    Location
    London, UK
    Beans
    3,527
    Distro
    Ubuntu Development Release

    Re: Fresh Heron install, but no wireless

    Quote Originally Posted by TalioGladius View Post
    yes. -17 didn't work and caused me issues with every application working for about 3 seconds and freezing for 10-15 seconds. Booting to -16 resolves that issue. All other updates are installed.

    I hate to try and reimage....especially if it doesn't help it.
    Ok can you do this :

    Code:
    sudo echo iwl3945 >> /etc/modules
    and reboot and let see if this fixes it for you.

    i have done this in gutsy to use iwl3945 instead of ipw
    You came empty handed, that is how you shall leave. Whatever you claim as yours today, belonged to someone else yesterday, will be someone else's tomorrow.

  2. #12
    Join Date
    Sep 2007
    Beans
    109

    Re: Fresh Heron install, but no wireless

    Quote Originally Posted by ukripper View Post
    Ok can you do this :

    Code:
    sudo echo iwl3945 >> /etc/modules
    and reboot and let see if this fixes it for you.

    i have done this in gutsy to use iwl3945 instead of ipw
    sudo echo iwl3945 >> /etc/modules
    bash: /etc/modules: Permission denied

  3. #13
    Join Date
    Sep 2007
    Beans
    109

    Re: Fresh Heron install, but no wireless

    I had to use gedit to add it, echo was denied. Anyhow, no dice. Nothing has changed, it didn't help a thing...
    Last edited by TalioGladius; May 30th, 2008 at 06:17 PM.

  4. #14
    Join Date
    Sep 2007
    Beans
    109

    Re: Fresh Heron install, but no wireless

    I also booted to the cd to see if I could get wireless off of that, and no dice.


    Apparently 8.04 isn't going to work for this laptop currently if I want wireless. I do have a nintendo wifi usb connector....any ideas on how I could set this thing up?

  5. #15
    Join Date
    Sep 2007
    Beans
    109

    Re: Fresh Heron install, but no wireless

    Looks like nvidia driver for fedora 9 was released. Maybe I should go that route instead.

  6. #16
    Join Date
    Jan 2007
    Location
    London, UK
    Beans
    3,527
    Distro
    Ubuntu Development Release

    Re: Fresh Heron install, but no wireless

    Give 7.10 a go instead of Hardy. 7.10 is supported till April 2009 and is very stable. I have only one machine running hardy and rest others are all 7.10
    You came empty handed, that is how you shall leave. Whatever you claim as yours today, belonged to someone else yesterday, will be someone else's tomorrow.

  7. #17
    Join Date
    May 2008
    Location
    Beverley, UK
    Beans
    733
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Fresh Heron install, but no wireless

    You could try installing ndiswrapper and using the Windows driver.

  8. #18
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Fresh Heron install, but no wireless

    TalioGladius, I recognize what you're describing all too well.

    With the -16 kernel, I got mine to work by adding a file to /etc/modprobe.d/ to disable HW scanning. This made it work, out of the (repainted) box.

    With the -17 kernel, I got the delays at which all programs stop and everything just chugs along. It happens everytime it scans for available networks, quite reproducible. At each time it spammed "Microcode SW error"-like messages in dmesg; there are numerous launchpad and intellinuxwireless.org bugtracker bugs regarding this. One off the top of my head: http://www.intellinuxwireless.org/bu...ug.cgi?id=1650.

    My solution that seems to work on both kernels (haven't tried the -18 one yet, laptop hasn't returned from Acer repair center in Germany), is to find and compile a driver manually. This needs to be done after a kernel upgrade, of course. See http://linuxwireless.org/en/users/Download for links and installation how-tos.

    Some snapshots plain didn't compile for me, but the golden one I found was the one released at 2008-05-07. Later snapshots may, of course, compile for you.

    The disable_hw_scan method:
    Code:
    $ sudo su
    # rmmod iwl3945
    # echo alias wlan0 iwl3945 >> iwl3945 && echo options iwl3945 disable_hw_scan=1 hwcrypto=1 >> iwl3945
    # mv iwl3945 /etc/modprobe.d/
    # modprobe iwl3945
    # iwlist scan
    It still takes 10 seconds to complete a scan, but it works. Give it a shot.
    ...

  9. #19
    Join Date
    Oct 2007
    Location
    Chile
    Beans
    303
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Fresh Heron install, but no wireless

    Young Austin! Before you can make pie, you must learn to make pie. And to learn to make pie, I must teach you to make pie. Do you understand?
    - Tyrone

  10. #20
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Fresh Heron install, but no wireless

    Backports did nothing for me, not the -16 nor the -17 ones, though I imagine it may solve others' issues.
    ...

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •