Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Why so verbose?

  1. #1
    Join Date
    Aug 2006
    Beans
    99

    Why so verbose?

    I notice that, from the terminal where I launch a kde app, like kdiff3, spills an endless stream of information related to kdiff3 running. That's all nice but quite a lot of it is merely info or warnings, not worth looking at.

    How do I turn that noise off?

  2. #2
    Join Date
    Jun 2007
    Beans
    74

    Re: Why so verbose?

    Quote Originally Posted by figgles View Post
    I notice that, from the terminal where I launch a kde app, like kdiff3, spills an endless stream of information related to kdiff3 running. That's all nice but quite a lot of it is merely info or warnings, not worth looking at.

    How do I turn that noise off?
    I can think of a couple things to do.

    First is to send the output to /dev/null:
    Code:
    kdiff3 >/dev/null
    Second is to throw the ampersand after it, which will give you back your command line, too. However, don't close your terminal, because that will kill kdiff3:

    Code:
    kdiff3 &
    Now, there may be unintended consequences from doing either of these. I wouldn't know. I only know that these work for me.

    -Jon

  3. #3
    Join Date
    Aug 2006
    Beans
    99

    Re: Why so verbose?

    Quote Originally Posted by joninkrakow View Post
    I can think of a couple things to do.

    Code:
    kdiff3 >/dev/null
    Code:
    kdiff3 &
    -Jon
    Jon; much thanks. Neither do the trick. Frustrating with the ampersand, too, which is what I usually do anyhow. /dev/null; same problem. What's the command in zsh to pipe both standard out and sterr to /dev/null?

    But I'm wondering if this isn't a KDE setting I can change?

  4. #4
    Join Date
    Aug 2006
    Beans
    99

    Re: Why so verbose?

    Feh; kdiff3 2>&1 /dev/null doesn't stop it, either

  5. #5
    Join Date
    Jan 2007
    Location
    $here ? $here : $there
    Beans
    3,717
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Why so verbose?

    I don't know how to redirect STDOUT and STDERR to null with zsh but, in, bash, I believe it is:

    Code:
    some_program > /dev/null 2>&1
    Don't try to make something "fast" until you are able to quantify "slow".

  6. #6
    Join Date
    Aug 2006
    Beans
    99

    Re: Why so verbose?

    I just checked man zshall; zsh supports 2>&1 and a shorthand |& version. Neither helped stop the terminal logorrhea. Thanks, though!

  7. #7
    Join Date
    Jan 2007
    Location
    $here ? $here : $there
    Beans
    3,717
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Why so verbose?

    That's quite odd. Another thing you could try would be to start the process with nohup (and possibly redirect it to null).

    Code:
    nohup some_program > /dev/null
    I don't know if that will do you any better though. If you aren't already aware, it won't stop the process when the parent shell exits.
    Don't try to make something "fast" until you are able to quantify "slow".

  8. #8
    Join Date
    Aug 2006
    Beans
    99

    Re: Why so verbose?

    Fascinating -- you guys are good. nohup kdiff3 > /dev/null & works great. If I don't redirect, I'll get a nohup.out file in the current directory.

    So, I'm guessing that nohup 'pushes' the output to background; it's still being written, I just don't see it.

    Best regards and thanks!

  9. #9
    Join Date
    Jan 2007
    Location
    $here ? $here : $there
    Beans
    3,717
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Why so verbose?

    I'm glad that worked. My next recommendation was to do a:

    Code:
    echo "shutup" > /proc/kde
    Don't try to make something "fast" until you are able to quantify "slow".

  10. #10
    Join Date
    Jun 2007
    Beans
    74

    Re: Why so verbose?

    Quote Originally Posted by figgles View Post
    Jon; much thanks. Neither do the trick. Frustrating with the ampersand, too, which is what I usually do anyhow. /dev/null; same problem. What's the command in zsh to pipe both standard out and sterr to /dev/null?

    But I'm wondering if this isn't a KDE setting I can change?
    Weird... because I tried it on my own computer before I wrote my post. Are you in KDE? I'm using LXDE and bash in xterm, so maybe that makes a difference? Maybe bash alone?

    I know there is a way to reduce the verbosity of KDE, but I don't remember how to do it. I was kind of hoping my efforts would be a stop-gap measure until somebody who knows more than I came along to _really_ help.... Sorry!

    -Jon

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •