Results 1 to 3 of 3

Thread: Script in Autostarted Apps loading twice.

  1. #1
    Join Date
    Jan 2007
    Beans
    Hidden!

    Script in Autostarted Apps loading twice.

    Basically what I have here is a script that will load Mame when it starts, and once you quit Mame, it will shutdown the computer, and I'm trying to get it so that the script loads on startup, which works fine as of now. the only problem is that when the computer starts up, it loads two instances of Mame. The script looks like this:

    Code:
    #/bin/bash
    
    sdlmame
    echo mypassword | sudo -S shutdown now -P
    In Autostarted Apps, this is the only object I have to load on startup.

    Anyone know of a way to make it so that the script only loads once? Perhaps how to configure Autostarted Apps without the GUI (I've been using the GUI and maybe its just messing up) as well?

    If it matters, I'm running Xfce on Xubuntu 8.04.

    Thanks.

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Script in Autostarted Apps loading twice.

    Problem Fixed.

    What was happening was the computer was saving the applications loaded when it shutdown and someone shut it down once without exiting Mame, so 2 versions of the script popped up each time it loaded.

    Which brings me to my next question:

    I know I've seen it somewhere before but I can't remember where, how does one disable saving the programs loaded previously?

  3. #3
    Join Date
    Oct 2007
    Location
    Oregon
    Beans
    904

    Re: Script in Autostarted Apps loading twice.

    I don't have Xfce on this computer, but I've seen that option too, it should be somewhere in the Xfce control panel.
    Arch x86_64 User / Windows 7 x64 Dual Boot | Nvidia Geforce GT 430 | AMD Phenom II X4 925 (2.8 Ghz, Quad Core) | 6 GB DDR2 RAM | 500 GB HD

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •