Results 1 to 4 of 4

Thread: Latest Updates broke sound

  1. #1
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Latest Updates broke sound

    After applying the latest updates when prompted by the update manager it looks like it broke pulse audio. Everything worked previously, no changes to sound or sound players were made to the system--only the acceptance of updates from the Canonical servers. After a reboot no sound. If I switch to OSS sound is back. Pulse Audio doesn't work.

    Shameful, just shameful.

  2. #2
    Join Date
    Apr 2008
    Beans
    13

    Re: Latest Updates broke sound

    I also had this issue with PulseAudio after the new updates. I fixed it by editing /etc/modprobe.d/alsa-base and adding the old
    Code:
    options snd-hda-intel model=acer
    fix from Ubuntu 7.10 back in... But now my internal microphone has stopped working again.

    Oh well, **** happens.

  3. #3
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Latest Updates broke sound

    What also went wrong was:

    1) Even though I turned off power management the screen saver, etc, the system now turns my monitor off--even though I explicitely told it not to.

    2) The folder counts no longer work. I am used to seeing the number of items in a folder (displayed after the name).

    3) When I go to places and select a removable drive from the list it puts the drive's icon on the desktop. But if I hit the eject button for a music CD it will also unmount the drive I mounted using the places menu. As a consequence I will also loose the share name.

    4) When I boot into the OS from a cold start I get a black desktop background without icons. I have to alt+ctl+backspace and relog in to get my desktop background and icons.

    As far as the entry into that file goes, though I have not tried it, it is not supposed to happen. That's what makes it shameful. This OS is targetted at the human being and making the mistake is one thing but expecting the average user to add those lines to some config file is just unacceptable.

    Also, my board isn't based on the intel chipset and my computer isn't an acer, so I can't see how that will impact me. How do I find the old copy pre-update mod so I can compare the old and new to see what my settings actually should be?

    Also, as I said I can use the sound if I switch to the OSS sound system rather than pulse audio. So, the sound card works it just no longer works with pulse-audio. I check the users and groups and ensured that the username is still associated with pulse audio--it is nothing there was changed.
    Last edited by jimbo99; May 28th, 2008 at 07:24 PM.

  4. #4
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Latest Updates broke sound

    Hopefully OSS4 will soon work with PulseAudio. ALSA seems to grow increasingly sketchy. *hides*

    See this page if you have an Intel HDA card and you want to try the model= approach nomizz mentioned. It works with other cards too, of course, but the list I posted there only contains the snd-hda-intel chipset options. Refer to /usr/share/doc/alsa-base/ALSA-Configuration.txt.gz for option listings for other cards.
    ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •