Results 1 to 4 of 4

Thread: [SOLVED] XKB Configuration Error

  1. #1
    Join Date
    Jul 2007
    Location
    East Anglia, UK
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question [SOLVED] XKB Configuration Error

    I notice the GBP symbol (SHIFT+3) wasn't working on my keyboard, just producing a 3 instead, so I tried changing the keyboard to the HP one (I have an HP laptop) and now every time I login I get this:
    Code:
    Error activating XKB configuration.
    It can happen under various circumstances:
    - a bug in libxklavier library
    - a bug in X server (xkbcomp, xmodmap utilities)
    - X server with incompatible libxkbfile implementation
    
    X server version data:
    The X.Org Foundation
    10400090
    
    If you report this situation as a bug, please include:
    - The result of xprop -root | grep XKB
    - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    The result of xprop -root | grep XKB
    Code:
    _XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "uk", "", ""
    _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "uk", "", ""
    The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    Code:
     layouts = []
     model = hpzt11xx
     overrideSettings = true
     options = []
    I've tried switching to several different keyboard options but always get the same result. Please help.

  2. #2
    Join Date
    Jul 2007
    Location
    East Anglia, UK
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: XKB Configuration Error

    *bump* Please can someone help? This is driving me nuts.

  3. #3
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: XKB Configuration Error

    Quote Originally Posted by styphon View Post
    *bump* Please can someone help? This is driving me nuts.
    Have you tried reconfiguring your keyboard settings with
    Code:
    sudo dpkg-reconfigure xserver-xorg
    ?
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  4. #4
    Join Date
    Jul 2007
    Location
    East Anglia, UK
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: XKB Configuration Error

    I've managed to get the error away by setting it back to default and adding the £ symbol in by running a xmodmap command in the sessions manager.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •