Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] No num keyboard in 8.04

  1. #1
    Join Date
    Mar 2007
    Beans
    678

    [SOLVED] No num keyboard in 8.04

    Just discovered this morning that my numbers key pad is not functioning in Ubuntu. Why? How do I restore it? It works fine when I boot into XP, so the problem is not mechanical in nature.

    Assistance appreciated.

    Caruso

  2. #2
    Join Date
    Mar 2006
    Location
    Hershey, PA
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No num keyboard in 8.04

    Do you have numlockx enabled? If not go into synaptic and search for numlockx and mark it to load. Click apply. Close synaptic. Reboot.
    CyberPower Gamer Ultra 7209 | AMD Athlon II X2 240 | 6 GB RAM | 1000GB & 500GB SATA-II HD
    ATI Radeon HD4550 | HP 2430 Printer | Ubuntu 11.04 | Windows 7 | ViewSonic VA703b Monitor

  3. #3
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,058
    Distro
    Ubuntu Development Release

    Re: No num keyboard in 8.04

    Quote Originally Posted by carusoswi View Post
    Just discovered this morning that my numbers key pad is not functioning in Ubuntu. Why? How do I restore it? It works fine when I boot into XP, so the problem is not mechanical in nature.

    Assistance appreciated.

    Caruso
    Do you mean just num lock or all the numeric keys.

    If the later use System>Prefs>Keyboard and make sure you have the correct type selected. Hardy remembers your numlock state.

  4. #4
    Join Date
    Mar 2007
    Beans
    678

    Re: No num keyboard in 8.04

    Quote Originally Posted by philinux View Post
    Do you mean just num lock or all the numeric keys.

    If the later use System>Prefs>Keyboard and make sure you have the correct type selected. Hardy remembers your numlock state.
    The numlock indicator light indicates that numlock is enabled, but the keypad behaves as though it is disabled. Arrow keys (4-6, 2-8) will move the cursor around, but I cannot enter numeric values with the keypad. Pressing the numlock key to turn off the enabled indicator seems to disable the keypad completely.

    Caruso

  5. #5
    Join Date
    Mar 2007
    Beans
    678

    Re: No num keyboard in 8.04

    Quote Originally Posted by philinux View Post
    Do you mean just num lock or all the numeric keys.

    If the later use System>Prefs>Keyboard and make sure you have the correct type selected. Hardy remembers your numlock state.
    I have tried your suggestion. No apparent effect. I never touched keyboard preferences to make things work in previous versions. Don't quite know what to make of this. My keyboard (supplied with the system) is a Benq X120 Model A122 Extension U21 if that means anything. I've used it with this system for 4-years.

    Caruso

  6. #6
    Join Date
    Mar 2007
    Beans
    678

    Re: No num keyboard in 8.04

    Quote Originally Posted by alienexplorers View Post
    Do you have numlockx enabled? If not go into synaptic and search for numlockx and mark it to load. Click apply. Close synaptic. Reboot.
    I did not have numlockx marked for install. Went into synaptic and clicked it, installed it, no effect.

    Caruso

  7. #7
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,058
    Distro
    Ubuntu Development Release

    Re: No num keyboard in 8.04

    Have you access to another keyboard?

    My girlfriend picked one up recently for £2.

  8. #8
    Join Date
    Feb 2007
    Location
    Topeka, Kansas
    Beans
    2,317
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No num keyboard in 8.04

    You have mousekeys enabled. This problem drives me crazy because it seems a lot of people have it for no good reason.

    Solution:

    System>Preferences>Keyboard>Mouse Keys (tab)>Uncheck that crap.

    Dumbest problem I've encountered since upgrading to 8.04, I swear (besides Pulse Audio). Sorry you had to endure it too.

  9. #9
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,058
    Distro
    Ubuntu Development Release

  10. #10
    Join Date
    Feb 2007
    Location
    Topeka, Kansas
    Beans
    2,317
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No num keyboard in 8.04

    Quote Originally Posted by philinux View Post
    Mouse keys is off by default.
    Obviously it has a way of turning on and not notifying the user with a visual notification. It's happened to me more than once. So again, it's one of the dumbest problems I and many others have encountered.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •