Results 1 to 7 of 7

Thread: [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

  1. #1
    Join Date
    May 2008
    Beans
    7

    Question [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

    Hi everyone.

    I've installed VMware Server 2.0 ontop of Ubuntu Server 8.04, copied a preconfigured VM created earlier with VMware workstation. Guest system boots up and runs normally. Just one unsolved question: how can I autostart the guest machine after the host system boots?

    The web interface apparently does not provide an option for autostarting guest systems (or maybe I wa not able to find the exact place for it).

    I've tried manually adding autostart= "poweron" and autostart.order= "10" into the guest system's .vmx file. This did not help.

    Any suggestions?

    PS Running VMware Server 2.0 beta e.x.p build-84186 under UbuntuServer 8.04 (2.6.24-16-server).

    PPS Does anoyne know what that "e.x.p" means?

  2. #2
    Join Date
    May 2008
    Beans
    7

    Resolved partially. Further quiestions arise...

    Found where in the VMware Server web interface to set autostart options. It is not on the particular guest system's screen, but on the host's ("main") screen: select host in the "Inventory" panel (root node of the tree), to the right "Commands" panel should appear with "Edit Virtual Machine Startup/Shutdown Settings" link on it.

    Now I'm able to autostart the guest, but is there a way to correctly shutdown it when the host system goes down? VMware Server can nicely shut down any (haven't tried linux guests so far) guest interactively, but can it do the same when the host is going down?

  3. #3
    Join Date
    May 2005
    Location
    Melbourne, VIC, Australia
    Beans
    282
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Resolved partially. Further quiestions arise...

    Just thought I'd say thank you! I've been looking for that option for hours!


  4. #4
    Join Date
    Nov 2007
    Beans
    1

    Re: [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

    Awesome... I, too, was searching extensively for this info. Thanks for following up on your original question post!

  5. #5
    Join Date
    Jun 2007
    Beans
    Hidden!

    Re: [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

    Hello,

    You could the following:

    Write a wrapper script that does the following:

    1. Scans the VMware subnet for open ssh ports and connects to remote machines; this means you enable ssh to host and use one userid and password.
    2. Connects and then runs shutdown from the command line.
    3. After shutting down all virtual machines, closes the Server.
    4. Shuts down the hosts.

    Dedoimedo

  6. #6
    Join Date
    Feb 2008
    Beans
    1

    Smile Re: [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

    Thanks for the help! Just what I was looking for (and apparently missing)

    Chrelad

  7. #7
    Join Date
    Mar 2007
    Beans
    3

    Smile Re: [SOLVED] Unable to autostart VMs on VMware Server 2 under Ubuntu Server 8.04

    The kudos just keep on comin'... Thanks for following up uoirej, I was looking in the wrong part of the web interface

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •