Results 1 to 8 of 8

Thread: PulseAudio - Connection Failed: Connection Refused

  1. #1
    Join Date
    Jul 2006
    Location
    United States
    Beans
    190
    Distro
    Kubuntu

    [SOLVED] PulseAudio - Connection Failed: Connection Refused

    Hola, I've had this problem since I installed Hardy, and though I have googled and searched for days now, a solution still eludes me. When I run "PulseAudio Device Chooser" and go to "Volume Manger" where I should be able to toggle volume for individual streams, I get this frustrating message:
    Connection failed: Connection refused
    I had found some posts that looked like they might help but all they did was make it so that sometimes after I restart PulseAudio will connect, then randomly later on in the day, it will fail. (posts are here, and here for reference)
    When I try to restart PA this is what I get:
    Code:
    ~$ pulseaudio -D
    E: main.c: daemon startup failed.
    I'm almost 100% sure that I've installed every package for PA also. I'm rather tired of restarting my computer just to get PA working for a while Any and all help is really appreciated.

    [EDIT]]I've now been able to isolate and consistently reproduce the problem! After I restart the computer, if I don't first type in
    pulseaudio -D
    before playing any sound, then I cannot initialize the daemon the rest of the session, I have to restart the whole system, not just the GUI. So it seems like PA isn't being initialized on start up, if I can tell KDE or the kernel to fire it up, then I think the problem can be solved. How can I do this?

    [SOLVED]: I've solved the problem for me, including restarting the PA daemon and have outlined my steps in my blog:
    http://nexsjournal.blogspot.com/2008/05/pulseaudio.html
    Hope it helps someone.
    Last edited by Nexusx6; June 25th, 2008 at 08:15 PM. Reason: More info
    Always mark your solved problems with [SOLVED] in your subject line, and post your solution!

  2. #2
    Join Date
    Sep 2007
    Beans
    69

    Re: PulseAudio - Connection Failed: Connection Refused

    I'd like to know - getting the exact same problem on my brother's machine with Linux Mint (which is based on Hardy).

  3. #3
    Join Date
    Jul 2006
    Location
    United States
    Beans
    190
    Distro
    Kubuntu

    Re: PulseAudio - Connection Failed: Connection Refused

    I've solved the problem for me and outlined the steps I took in my blog, including restarting PA on start up:

    http://nexsjournal.blogspot.com/

    Hope it solves your problems, email or PM me if you have any questions.
    Always mark your solved problems with [SOLVED] in your subject line, and post your solution!

  4. #4
    Join Date
    Aug 2006
    Location
    India
    Beans
    688
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: PulseAudio - Connection Failed: Connection Refused

    I was able to solve my pulse audio connection refused by using the code to start the pulse audio. Thank you!!!!
    Powered by Ubuntu, Driven by Linux

  5. #5
    Join Date
    Feb 2006
    Location
    North Dakota
    Beans
    224
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PulseAudio - Connection Failed: Connection Refused

    I wonder why 'sudo /etc/init.d/pulseaudio restart' does not fix the problem. That should stop pulseaudio if it's still running, and then restart it on its own. I know it doesn't, because I've tried it.
    Search first, ask questions later!
    From Thread Tools, "Mark this thread as solved" if your problem's been solved.

  6. #6
    Join Date
    Jul 2006
    Location
    United States
    Beans
    190
    Distro
    Kubuntu

    Re: PulseAudio - Connection Failed: Connection Refused

    Quote Originally Posted by prince_niceguy View Post
    I was able to solve my pulse audio connection refused by using the code to start the pulse audio. Thank you!!!!
    Welcome I'm glad I could help someone out

    I wonder why 'sudo /etc/init.d/pulseaudio restart' does not fix the problem. That should stop pulseaudio if it's still running, and then restart it on its own. I know it doesn't, because I've tried it.
    Actually, thats a good question lol. I've found that when pulseaudio -D doesn't work on its own (sometimes it spits an error back out) killing the process and then issuing the restart brings the server back to normal working order

    Code:
    killall pulseaudio
    pulseaudio -D
    Always mark your solved problems with [SOLVED] in your subject line, and post your solution!

  7. #7
    Join Date
    Sep 2008
    Beans
    1

    Smile Re: [SOLVED] PulseAudio - Connection Failed: Connection Refused

    Thanks! I found this very helpful and got my sound to work!

  8. #8
    Join Date
    Apr 2006
    Beans
    80

    Re: PulseAudio - Connection Failed: Connection Refused

    Quote Originally Posted by bobpaul View Post
    I wonder why 'sudo /etc/init.d/pulseaudio restart' does not fix the problem. That should stop pulseaudio if it's still running, and then restart it on its own. I know it doesn't, because I've tried it.
    The /etc/init.d/pulseaudio script is configured to do nothing and silently exit by default. This is because PulseAudio is designed to run as a per-user daemon and not a system service. Use 'pulseaudio -D' to start the daemon instead.

    To enable the init.d script, edit /etc/default/pulseaudio to set PULSEAUDIO_SYSTEM_START=1

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •