Results 1 to 5 of 5

Thread: Howto: Get Your External Syquest Drive Working In Ubuntu

  1. #1
    Join Date
    Mar 2007
    Ubuntu 8.04 Hardy Heron

    Howto: Get Your External Syquest Drive Working In Ubuntu

    This is my first howto! Give me a round of applause =D>

    Before I go on, I'd just like to say that Google is really your friend, and there's two sources that I got information from. I will share them here:

    From these two sources and some tinkering, you should be able to get almost any external parallel drive working in Ubuntu!

    Also, this Howto is made for Ubuntu 8.04 Hardy Heron. So let's get started!

    ================================================== ========

    First, you need to write a script to get the parallel drivers loaded up. This should work with all Syquest drives.

    Open up gedit (either type in gedit in a terminal, or click Applications -> Accessories -> Text Editor)

    copy and paste the following into the text file:
    # Start here...
    # modprobe parport # Already maybe loaded
    # modprobe parport_pc # Already maybe loaded
    modprobe paride
    # The following 2 steps are not necessary on Breezy...
    # mkdir /lib/modules/$(LINUX_VERSION)/misc
    # cp /lib/modules/$(LINUX_VERSION)/kernel/drivers/block/paride/epat.o /lib/modules/2.4.20-20.8/misc/epat.o
    echo "Inserting the necessary modules..."
    modprobe epat # Sparq Protocol
    modprobe pd # Sparq Driver
    dmesg | grep paride
    # Look for: "paride: epat registered as protocol 0"
    # modprobe pd drive0=0x378,1 drive1=0x3bc,1 # Example syntax
    # To support such a wide range of devices PARIDE, the parallel port IDE subsystem, is actually structured in three parts.
    # There is a base paride module which provides a registry and some common methods for accessing the parallel ports. 
    # The second component is a set of high-level drivers for each of the different type of supported device:
    # pd IDE disk
    # pcd ATAPI CD-ROM
    # pf ATAPI disk
    # pt ATAPI tape
    # pg ATAPI generic devices
    # The pg driver exists mainly to support parallel port ATAPI CD-R and CD-RW devices. 
    # Run the commands below from a script 
    # ================================================== ==================
    echo "Running commandsmou..."
    test `whoami` = 'root' || echo "You must be root to execute the commands."
    cdrecord -scanbus > /dev/null
    if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
    echo "Neither kerneld nor kmod are running to automatically load modules".
    report_no_autoload() {
    echo "Ensure the module $1 is loaded automatically next time."
    if test ! -f "/proc/scsi/scsi"; then
    report_no_autoload scsi_mod && modprobe scsi_mod
    if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
    report_no_autoload sg && modprobe sg
    if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
    report_no_autoload sr_mod && modprobe sr_mod
    if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
    report_no_autoload loop && insmod loop
    if ! grep iso9660 /proc/filesystems > /dev/null; then
    report_no_autoload iso9660 && modprobe iso9660
    echo "The following is only needed for IDE/ATAPI CD-writers."
    if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
    report_no_autoload ide-scsi && modprobe ide-scsi
    # ================================================== ==============
    # Now check if it is recognized:
    # cdrecord -scanbus
    # Mount to an appropriate location after placing a CD in the drive
    mkdir /media/Sparq
    mount -t vfat /dev/pda1 /media/Sparq
    ls -al /media/Sparq # Works !
    Save it under a name you like. I personally chose the name "Paride" (which is the name of the parallel port IDE subsystem)

    Next, you need to make the file executable. Open up a terminal and type (or copy + paste) the following:

    chmod +x paride
    Now, you can run the script by typing in the following in a terminal

    sudo ./paride
    and you should see the directory of your Syquest drive!

    *Note: you only need to run the script once per session. You can alternately mount and unmount the drive my typing the following:

    sudo mount /dev/pda1
    sudo umount /dev/pda1

    If you see something in my Howto that could use improvement, please share!

    Good luck, and have fun with your Syquest drive!
    What do tone deaf singers, floppy drive music, and an old woman dreaming about mashed rodents have in common? They're all on my blog! CHECK IT OUT

  2. #2
    Join Date
    Dec 2006

    Re: Howto: Get Your External Syquest Drive Working In Ubuntu

    Hi, Thanks worked great, but I personally got a lot of error messages when the script ran, but the drive mounted and worked. - On a side note, in your orignal post you said it works under 8.04 - It also works under 8.10 - that is what I am running. Thanks again, LeRoy, KD8BXP

  3. #3
    Join Date
    Oct 2007

    Re: Howto: Get Your External Syquest Drive Working In Ubuntu

    This did not work for me.

    When I attempted to run the script sudo ./paride I got the message "Loading Modules". This message never changed and I my system froze causing me to use the reset button.

    I also noticed that there did not appear to be any Syquest directory and that there was no /pda1 in /dev


  4. #4
    Join Date
    Jul 2008
    Woodstock Cape Town RSA
    Ubuntu 11.10 Oneiric Ocelot

    Re: Howto: Get Your External Syquest Drive Working In Ubuntu

    FATAL: Module ide_scsi
    I am running 12.04, apparently ubuntu linux no longer has this module, any ideas?

  5. #5
    Join Date
    Apr 2013

    Re: Howto: Get Your External Syquest Drive Working In Ubuntu

    April 2013

    Since google "ubuntu syquest" gets you here, I thought I'd post what worked for me. Under Ubuntu 12.04 LTS my computer also locks up as described by others. Something goes very wrong when try to install kernel module pd.ko.

    The following is not a fix for Ubuntu. This is a work-around to get files off the parallel drive ezflyer disks and saved elsewhere.

    Computer: Dell Dimension 2400 w Intel Pentium 4 CPU 2.53GHz (32 bit)


    - Create a live CD of Ubuntu 8.04.4 (from 2008, the year of the above HOWTO). I used ubuntu-8.04.4-desktop-i386.iso.

    - Attach the ezflyer to the parallel port, power it up, and insert a disk.

    - Boot the Ubuntu live CD.

    - When Ubunbu has fully loaded open a Terminal window.

    - Become 'root' and create a mounting point for the ezflyer:
    > sudo su
    > mkdir /media/ez (<- any directory name will do)

    - Install the kernel modules necessary to handle the ezflyer:
    > modprobe paride
    > modprobe epat
    > modprobe pd

    - mount the ezflyer:
    > mount /dev/pda1 /media/ez

    - The ezflyer should now be 'good to go'. Verify with:
    > echo I am Here > /media/ez/test.txt; cat /media/ez/test.txt

    Note: This scheme occasionally freezes in the same way as under 12.04 LTS. In this case I suspect I have flaky drive since it doesn't always eject properly.

    Good luck!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts