I have the exact same problem, Garumar (aside from your issue with being unable to resolve your local hostname - I don't have any problems there). My nsswitch.conf file is identical to yours. I have tried entering all the combinations I can think of for my FQDN in the "Domain" box in the Likewise GUI, and none of them have worked. The domainjoin terminal command gives me the same error. This is the output of the error log when I try to connect using the Likewise GUI after entering my Active Directory username and password:



I have the DNS server address in my network configuration set to the address of my domain controller. I haven't been able to find any helpful info about configuring Likewise on Ubuntu, just the same stuff Lord_Dicranius found about using windbind and PAM. I have noticed that I can't ping my AD server by name, don't know if that make any difference or not. I haven't been able to find much info about setting a WINS server for Ubuntu, although I have played around with the WINS settings in smb.conf. Any help would be greatly appreciated, as I have no way of sharing files with my Windows 2003 machine until this is resolved.