Results 1 to 5 of 5

Thread: 'authentication failed' and 'unknown module' errors preventing logon

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Pompano Beach, FL, USA
    Ubuntu 13.10 Saucy Salamander

    Lightbulb 'authentication failed' and 'unknown module' errors preventing logon

    Effected Systems:
    I experienced this issue on Hardy but I found evidence of it occurring on earlier versions and on Debian.

    • You can't login using your normal credentials. Logging on in X (the graphical environment) raises an "authentication failed" error and the shell complains about an "unknown module".
    • You can access the system in recovery mode and you can confirm that the users and passwords are set correctly.
    • Attempting the su command from the shell raises "Unknown module: su" but you may be able to switch users (in single user mode)
    • You may also see "Segmentation fault" errors.
    • The system logs provide no help, there is no entry related to this failure.

    PAM (Pluggable Authentication Modules) is failing to authenticate you because it can't load its essential modules.

    **WARNING** Following these directions should be safe but you will run a potentially dangerous command. Take the proper precautions like backing up important data or the entire system. **

    If you haven't messed with PAM the easiest thing to do is to take it out and replace it with a working copy from the official repositories.

    Step 1: Start ubuntu using the recovery option (singe user mode)

    Step 2: Purge the pam runtime and modules packages and some related files (don't try using apt for this):
    dpkg --force-all --purge libpam-runtime
    dpkg --force-all --purge libpam-modules
    rm -rf /etc/pam.d
    rm -rf /lib/security
    Step 3: Reinstall those packages from the repositories:
    apt-get install libpam-runtime libpam-modules
    Step 4: Reboot. You should be able to login normally now:
    reboot now
    My main source for fixing my issue and deriving these instructions:

    The user in the following post had a similar issue but fixed it a different way, which did not work for me:
    Last edited by MikeEvans; May 21st, 2008 at 07:46 PM.

  2. #2
    Join Date
    Apr 2008
    Ubuntu 9.10 Karmic Koala

    Re: 'authentication failed' and 'unknown module' errors preventing logon

    That works and when it doesn't you can also do a few other easy things to remedy some specific missing parts.

    If you are unable to log in normally but can login with Gnome safe mode and:

    If your auth.log or some other log like syslog reports a missing pam_smbpass. You can install the missing libpam_smbpass with Synaptic and that may work. It worked for me in the 386i but not in the amd64. In the amd64 I then got this message:

    pam_smbpass(gdm:auth): unrecognized option [missingok]

    If you get this remove libpam_smbpass completely and that will fix that. Be sure and check the remove completely option in synaptic to remove all dependencies.

    In both instances you will probably then get another message like this:

    May 23 18:36:43 mark-desktop NetworkManager: <WARN> nm_spawn_process(): nm_spawn_process('/usr/sbin/nscd -i hosts'): could not spawn process. (Failed to execute child process "/usr/sbin/nscd" (No such file or directory))

    To get rid of this you can install nscd, then remove it completely and that should fox your login problem.

    There are more than a few reports of this problem in the forums. It seems to particularly effect a few AMD Athlon64 installs with both 386i and amd64 kernel builds.

    I ran into it installing both kernels. It seems both installs leaves a few unresolved dependencies in gdm.

    Autologin and login in Gnome safe mode works without this fix since they do not use gdm.
    Last edited by markbuntu; May 24th, 2008 at 12:21 AM.

  3. #3
    Join Date
    Aug 2006
    Lovely Wangen bei Olten
    Ubuntu 8.04 Hardy Heron

    Re: 'authentication failed' and 'unknown module' errors preventing logon

    Worked fine for me, thanks MikeEvans!
    --- borobudur ---

  4. #4
    lmn. is offline Just Give Me the Beans!
    Join Date
    May 2011

    Re: 'authentication failed' and 'unknown module' errors preventing logon

    absolute legend, many thanks mate

  5. #5
    Join Date
    Jan 2011

    Re: 'authentication failed' and 'unknown module' errors preventing logon

    Worked like a charm when I got hit with this problem on a fairly new upgrade to worked a few times then I got the "unknown module" error...


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts