Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 46

Thread: Firefox in Hardy defaults "Offline"

  1. #31
    Join Date
    Oct 2008
    Beans
    17

    Thumbs down Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by Nikitas350 View Post
    Open the terminal (Apllication-->accesories--->terminal) and type "gksudo gedit /etc/dbus-1/system.d/NetworkManager.conf". Then you replace the
    <allow send_interface="org.freedesktop.NetworkManager"/> with <deny send_interface="org.freedesktop.NetworkManager"/> (there are three it the text). Then save the changes and reboot. This will not permit firefox (or pidgin) to communicate with network manager and the state will be always online in firefox...
    SO Many Thanks for this post
    I thought I would go nutz - thinking there must be some way in the preferences of Firefox.

    Bob

  2. #32
    Join Date
    Oct 2008
    Beans
    1

    Re: Firefox in Hardy defaults "Offline"

    i just registered to thank you! A LOT!

  3. #33
    Join Date
    Sep 2006
    Beans
    152

    Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by rmrfstar View Post
    To follow up (although no one will likely read this), I believe the correct way to disable offline mode in Firefox is:

    1) Start Firefox
    2) In the address bar, type about:config
    3) Search for "offline"
    4) Toggle (double-click) browser.cache.offline.enable to "false"

    Yes, THIS is the correct mode! The other one imploded my network manager and I was not able to connect to any network anymore!

    THANK YOU!

  4. #34
    Join Date
    Sep 2005
    Beans
    424

    Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by Nikitas350 View Post
    Open the terminal (Apllication-->accesories--->terminal) and type "gksudo gedit /etc/dbus-1/system.d/NetworkManager.conf". Then you replace the
    <allow send_interface="org.freedesktop.NetworkManager"/> with <deny send_interface="org.freedesktop.NetworkManager"/> (there are three it the text). Then save the changes and reboot. This will not permit firefox (or pidgin) to communicate with network manager and the state will be always online in firefox...
    This hosed the rest of my network connections, when I'm home I want to be able to use my wireless connection.

    Changed toolkit.networkmanager.disable in Firefox to true and all is well.

  5. #35
    Join Date
    Dec 2007
    Beans
    2

    Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by Nikitas350 View Post
    Open the terminal (Apllication-->accesories--->terminal) and type "gksudo gedit /etc/dbus-1/system.d/NetworkManager.conf". Then you replace the
    <allow send_interface="org.freedesktop.NetworkManager"/> with <deny send_interface="org.freedesktop.NetworkManager"/> (there are three it the text). Then save the changes and reboot. This will not permit firefox (or pidgin) to communicate with network manager and the state will be always online in firefox...


    Thanks a lot Nikitas350 for the advice.

  6. #36
    Join Date
    Dec 2008
    Beans
    1

    Re: Firefox in Hardy defaults "Offline"

    Yeah, it works, Thank you very much.

  7. #37
    Join Date
    Jan 2009
    Location
    Italy
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by igray78756 View Post
    If you like how NetworkManager works, but you simply want to be able to use FireFox while not connected to a network (i.e. for web development, etc.), you can edit the following special configuration in FireFox (use about:config-- click on link for more info):

    toolkit.networkmanager.disable

    This will leave NetworkManager alone and let it do it's thing, but FireFox will still function in offline mode.
    thank igray
    that worked for me, i set the value to true, and firefox is no more offline by default, i have firefox 3.0.5 and ubu 8.10 .
    That doesn't not interfere with network manager so your wifi will keep working well.
    i use emesene that works anyway, so pidgin may still have problems

  8. #38
    Join Date
    Dec 2006
    Beans
    160

    Re: Firefox in Hardy defaults "Offline"

    I use kubuntu and this behaviour is bloody stupid.
    I don't understand the point of this, as clearly I don't want for browser to decide if I am connected or not.
    Every time I reboot, I "loose" connection.
    Is there a proper way to disable this stupidity in GTK apps, without affecting network manager operation?

  9. #39
    Join Date
    Oct 2008
    Location
    /etc/init.d/
    Beans
    37
    Distro
    Ubuntu 9.10 Karmic Koala

    Simplest solution might be.....

    open Firefox and type 'about:config' in the address bar, accept the promise, then find and set ....

    Code:
    toolkit.networkmanager.disable = true
    it worked for me.

  10. #40
    Join Date
    Nov 2005
    Beans
    1

    Re: Firefox in Hardy defaults "Offline"

    Quote Originally Posted by Nikitas350 View Post
    Open the terminal (Apllication-->accesories--->terminal) and type "gksudo gedit /etc/dbus-1/system.d/NetworkManager.conf". Then you replace the
    <allow send_interface="org.freedesktop.NetworkManager"/> with <deny send_interface="org.freedesktop.NetworkManager"/> (there are three it the text). Then save the changes and reboot. This will not permit firefox (or pidgin) to communicate with network manager and the state will be always online in firefox...
    I have four "allow send_interface=" in the sections:
    <policy user="root">,
    <policy user="haldaemon">,
    <policy at_console="true">,
    <policy context="default">

    Shall I change all four instances?

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •