Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 8.04. Problem with Realtek Ethernet card r8168.

  1. #1
    Join Date
    May 2008
    Beans
    12

    8.04. Problem with Realtek Ethernet card r8168.

    Hello,
    I've been struggling with this problem for 3 days now. I've done numerous searches and have tried everything that I've found to no avail. Here's the situation. I have a laptop with XP and Ubuntu 8.04 Amd 64. Ubuntu loaded with no problems, except that the ethernet card isn't working. By not working, I mean that it's not getting assigned an ip address by my DHCP server. When I load XP all is well, ie everything is working. Here's what I've tried:

    1. I read that there was a bug if you started Ubuntu with no network cable attached, but the cable has always been attached. Not the problem.

    2. I read a thread that said that you need to ENABLE the "Wake-On-Lan after shutdown" option. I did not have that option, so I found an updated driver and loaded it. The new driver supported this option. I enabled this option with no effect.

    3. I found that the module r8169 was loading and that some people have problems with that. I downloaded the latest linux driver from Realtek.com. I tried to create the latest driver with the makefile, but it wouldn't compile. After more research, I found a patch file. After loading the patch, the module compiled and loaded. I tried to blacklist the r8169 module, but it still loaded on startup. That's another problem.

    All in all, it's been pretty frustrating to a newbie. The good thing is I've gotten really intimate with the OS. I like it so far. It's really powerful, but you need a connection to the internet these days.

    All that being said, what do I need to post here to help diagnose the problem? If you give me the commands, I'll post the results.

    Thank you for your help in advance.

    Don

  2. #2
    Join Date
    May 2008
    Beans
    8

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    Please post results of these commands:
    Code:
    lspci -v | grep Gigabit
    sudo modprobe r8169
    sudo ethtool -i eth0
    sudo ethtool -k eth0
    assuming eth0 is the interface for your ethernet card. If not, change accordingly.

    Note: it won't solve anything yet...

  3. #3
    Join Date
    May 2008
    Beans
    12

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    Here you go...

    timeout@timeout-laptop:~$ lspci -v | grep Gigabit
    01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

    timeout@timeout-laptop:~$ sudo modprobe r8169

    timeout@timeout-laptop:~$ sudo ethtool -i eth0
    driver: r8169
    version: 2.2LK
    firmware-version:
    bus-info: 0000:01:00.0

    timeout@timeout-laptop:~$ sudo ethtool -k eth0
    Offload parameters for eth0:
    rx-checksumming: on
    tx-checksumming: off
    scatter-gather: off
    tcp segmentation offload: off
    udp fragmentation offload: off
    generic segmentation offload: off

    timeout@timeout-laptop:~$ ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:16:17:53:00:fb
    inet6 addr: fe80::216:17ff:fe53:fb/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:252 Base address:0xe000

    eth0:avahi Link encap:Ethernet HWaddr 00:16:17:53:00:fb
    inet addr:169.254.6.37 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:252 Base address:0xe000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:202 errors:0 dropped:0 overruns:0 frame:0
    TX packets:202 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:10292 (10.0 KB) TX bytes:10292 (10.0 KB)

    wlan0 Link encap:Ethernet HWaddr 00:16:e6:36:91:90
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    wmaster0 Link encap:UNSPEC HWaddr 00-16-E6-36-91-90-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    Let me know what else you'd like to see. I added the ifconfig -a because I'm not sure what the wmaster0 is and thought you may like to see that as well.

    Thanks for the response.

    Don

  4. #4
    Join Date
    May 2008
    Beans
    12

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    Oh, I forgot to tell you that the mac address is 00-16-17-53-00-FB.

    Thanks.

    Don

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,000
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    May 2008
    Beans
    12

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    I did find that post as well and tried everything it suggests. No luck.

    Thank you for the suggestion, though.

    Don

  7. #7
    Join Date
    May 2008
    Beans
    8

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    Ok, now try this:
    Code:
    sudo /etc/init.d/networking stop
    sudo ethtool -K eth0 tso on
    sudo /etc/init.d/networking start
    then try to ping your gateway, and numeric internet addresses.
    Is this getting ANY better? Do the diodes of your card blink?
    Please post any output you find relevant.

    Note: just trying to find a workaround involving no compiling here.

  8. #8
    Join Date
    May 2008
    Beans
    12

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    Here you go...

    timeout@timeout-laptop:~$ sudo /etc/init.d/networking stop
    [sudo] password for timeout:
    * Deconfiguring network interfaces... There is already a pid file /var/run/dhclient.eth0.pid with pid 6028
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/eth0/00:16:17:53:00:fb
    Sending on LPF/eth0/00:16:17:53:00:fb
    Sending on Socket/fallback
    grep: /etc/resolv.conf: No such file or directory
    [ OK ]
    timeout@timeout-laptop:~$ sudo ethtool -K tso on
    no offload settings changed
    timeout@timeout-laptop:~$ sudo /etc/init.d/networking start
    * Configuring network interfaces... There is already a pid file /var/run/dhclient.eth0.pid with pid 0
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/eth0/00:16:17:53:00:fb
    Sending on LPF/eth0/00:16:17:53:00:fb
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    grep: /etc/resolv.conf: No such file or directory

    timeout@timeout-laptop:~$ ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:16:17:53:00:fb
    inet6 addr: fe80::216:17ff:fe53:fb/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:32 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:252 Base address:0xc000

    eth0:avahi Link encap:Ethernet HWaddr 00:16:17:53:00:fb
    inet addr:169.254.6.37 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:252 Base address:0xc000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:168 errors:0 dropped:0 overruns:0 frame:0
    TX packets:168 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:8784 (8.5 KB) TX bytes:8784 (8.5 KB)

    wlan0 Link encap:Ethernet HWaddr 00:16:e6:36:91:90
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    wmaster0 Link encap:UNSPEC HWaddr 00-16-E6-36-91-90-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    There are no link lights, but there are no link lights in XP either. Here is some more data:

    timeout@timeout-laptop:~$ sudo ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Half
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    Link detected: yes

    If the cable is removed and the interface is brought down and back up, the link is no longer detected.

    timeout@timeout-laptop:~$ sudo ifconfig eth0 down
    timeout@timeout-laptop:~$ sudo ifconfig eth0 up
    timeout@timeout-laptop:~$ sudo ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: Unknown! (0)
    Duplex: Half
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    Link detected: no


    What's next?

    Thanks!

    Don

  9. #9
    Join Date
    May 2008
    Beans
    12

    Talking Re: 8.04. Problem with Realtek Ethernet card r8168.

    Hello everyone,
    First I want to thank everyone for their help. I got a private message from seriftr that read the following. I added the part between the "+++" because I didn't know how to do what he was asking....

    ***************
    absolute solution

    hi bud,i had the same problem with 8168 and only this solved it now all is ok...

    To compile the working r8168 driver you need to:

    sudo apt-get install patch (from cd after adding cd-rom in software sources)
    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++++++++
    This is how to add cd-rom...
    sudo apt-cdrom add
    sudo apt-get *package here*
    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++++++++

    sudo apt-get install build-essential

    wget ftp://66.104.77.130/cn/nic/r8168-8.006.00.tar.bz2

    tar -xjvf r8168-8.006.00.tar.bz2

    cd r8168-8.006.00/src

    http://www.jamesonwilliams.com/bin/r...s.tar.bz2(this link will provide u the necessary patch script - r8168-8.005.00.hardy.diff.txt-)Then copy the attached patch to the r8168-8.006.00/src directory

    patch < r8168-8.005.00.hardy.diff.txt

    cd ..

    make clean

    make modules

    sudo make install

    sudo depmod -a

    sudo mkinitramfs -o /boot/initrd.img-`uname -r` `uname -r`

    Then you need to black list the r8169 driver:

    sudo sh -c 'echo "blacklist r8169" >> /etc/modprobe.d/blacklist-network'

    gksu gedit /etc/modprobe.d/blacklist and add r8169 to end of d page,

    sudo update-initramfs -c -k all

    sudo reboot.

    ***************

    I did the above steps and now my nic is working correctly. I am currently writing this reply from Ubuntu.

    Thank you again everyone for your help, especially seriftr for the solution.

    Cheers!

    Don

  10. #10
    Join Date
    May 2008
    Beans
    1

    Re: 8.04. Problem with Realtek Ethernet card r8168.

    hi ADGON92..i am seriftr.this is my new account.because i couldnot reply posts with that seriftr.i dont know why.so i sent u pvt message for help u.

    cd-rom adding is very easy pen Software sources/third-party/add-cdrom(while 8.04 cd in cd-rom)

    seriftr is now out of use..thanks

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •