Page 21 of 81 FirstFirst ... 1119202122233171 ... LastLast
Results 201 to 210 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #201
    Join Date
    Sep 2006
    Beans
    Hidden!

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I just installed a new card (nvidia 280 gtx) and it broke my Ubuntu so I reinstalled. I've got most of it working ok now but I'm having some problems with the 3D acceleration. Basically, I have none. This is the output from compiz-check:

    Code:
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         nVidia Corporation Unknown device 05e1 (rev a1)
     Driver in use:         vesa
     Rendering method:      None
    
    Checking if it's possible to run Compiz on your system...  [SKIP]
    
    At least one check had to be skipped:
     Error: No rendering method in use (AIGLX, Xgl or Nvidia)
    And my xorg.conf:

    Code:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Boardname	"VESA driver (generic)"
    	Busid		"PCI:2:0:0"
    	Driver		"vesa"
    	Screen	0
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	Vendorname	"Generic LCD Display"
    	Modelname	"LCD Panel 1680x1050"
    	Horizsync	31.5-65.5
    	Vertrefresh	56.0 - 65.0
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
      modeline  "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
      modeline  "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
      modeline  "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
      modeline  "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
      modeline  "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1680	1050
    		Modes		"1680x1050@60"	"1600x1024@60"	"1440x900@60"	"1280x800@60"	"1280x720@60"	"1280x768@60"	"800x600@60"	"800x600@56"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"v4l"
    EndSection
    Section "ServerFlags"
    EndSection
    I'm not sure how the vesa driver got in there. Synaptic tells me I've installed the latest nvidia-glx drivers but they don't seem to be doing anything. I'm stuck.

  2. #202
    Join Date
    Jul 2008
    Beans
    112

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Hey, works great, thanks. (i'd give you a real thanks thing but i'm new and haven't figured that out yet) Anyway, compiz was working without the proprietary drivers, but it wasn't working right. I have 4 desktops, but only 3 show up in the bottom left corner. Also, everything I have in the task bar shows up on all of them, instead of only on the one i was using. If i click a new workspace (one of my three choices, instead of using the cube) the screen only shows my wallpaper. I installed the proprietary drivers to try and fix the problem, and compiz quit working entirely. Thanks to compiz-check, i've gotten it back to where it was without the driver, but its still not perfect. here's what compiz-check shows now...Gathering information about your system...

    Code:
    Distribution:          Ubuntu 7.10
     Desktop environment:   GNOME
     Graphics chip:         ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]
     Driver in use:         fglrx
     Rendering method:      Xgl
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [SKIP]
     Checking for non power of two support...          [SKIP]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [ OK ]
    Thanks again for getting me this far, any tips on getting it the rest of the way would be well appreciated!

  3. #203
    Join Date
    Jul 2008
    Beans
    112

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by Scarlett View Post
    I just installed a new card (nvidia 280 gtx) and it broke my Ubuntu so I reinstalled. I've got most of it working ok now but I'm having some problems with the 3D acceleration. Basically, I have none. This is the output from compiz-check:

    Code:
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         nVidia Corporation Unknown device 05e1 (rev a1)
     Driver in use:         vesa
     Rendering method:      None
    
    Checking if it's possible to run Compiz on your system...  [SKIP]
    
    At least one check had to be skipped:
     Error: No rendering method in use (AIGLX, Xgl or Nvidia)
    And my xorg.conf:

    Code:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Boardname	"VESA driver (generic)"
    	Busid		"PCI:2:0:0"
    	Driver		"vesa"
    	Screen	0
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	Vendorname	"Generic LCD Display"
    	Modelname	"LCD Panel 1680x1050"
    	Horizsync	31.5-65.5
    	Vertrefresh	56.0 - 65.0
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
      modeline  "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
      modeline  "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
      modeline  "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
      modeline  "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
      modeline  "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1680	1050
    		Modes		"1680x1050@60"	"1600x1024@60"	"1440x900@60"	"1280x800@60"	"1280x720@60"	"1280x768@60"	"800x600@60"	"800x600@56"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"v4l"
    EndSection
    Section "ServerFlags"
    EndSection
    I'm not sure how the vesa driver got in there. Synaptic tells me I've installed the latest nvidia-glx drivers but they don't seem to be doing anything. I'm stuck.
    go to the synaptic package manager, and do a search for xgl. make sure you have xserver-xgl installed. hope this helps.

  4. #204
    Join Date
    Nov 2007
    Location
    india
    Beans
    485
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    here's what i get on my friend's PC on running the script :
    Code:
    :~$ compiz-check
    
    Gathering information about your system...
    
    Distribution: Ubuntu 8.04
    Desktop environment: GNOME
    Graphics chip: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
    Driver in use: intel
    Rendering method: AIGLX
    
    Checking if it's possible to run Compiz on your system...
    
    Checking for texture_from_pixmap... [FAIL]
    Checking for non power of two support... [FAIL]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [FAIL]
    Checking for hardware/setup problems.../usr/bin/compiz-check: line 396: [: 800: unary operator expected
    /usr/bin/compiz-check: line 396: [: 1280: unary operator expected
    [ OK ]
    what to do next ?

  5. #205
    Join Date
    Jul 2008
    Beans
    27

    Question Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I ran Compiz check, and this is what I got.

    crystal@crystal-laptop:~$ compiz-check

    Gathering information about your system...

    Distribution: Ubuntu 8.04
    Desktop environment: Xfce
    Graphics chip: nVidia Corporation NV34M [GeForce FX Go5200 64M] (rev a1)
    Driver in use: Unknown
    Rendering method: AIGLX

    Checking if it's possible to run Compiz on your system...

    Checking for texture_from_pixmap... [FAIL]
    Checking for non power of two support... [FAIL]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [FAIL]
    Checking for hardware/setup problems.../usr/bin/compiz-check: line 396: [: 800: unary operator expected
    /usr/bin/compiz-check: line 396: [: 1280: unary operator expected
    grep: /home/crystal/.config/xfce4/mcs_settings/wmtweaks.xml: No such file or directory
    [FAIL]

    There has been (at least) one error detected with your setup:
    Error: Detected driver is not on Compiz' whitelist.

    Would you like to know more? (Y/n) y

    Your driver is not known (most probably not able) to work with Compiz.
    See http://wiki.compiz-fusion.org/Hardware for details.

    Check if there's an alternate (proprietary) driver available? (Y/n) y
    crystal@crystal-laptop:~$

    I don't understand what's wrong; when it shows me an alternate driver, it's nvidia. I click on it to enable it and it won't install it.

  6. #206
    Join Date
    Nov 2007
    Location
    india
    Beans
    485
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    and here are some more of the output :
    By running the above in terminal its enabling the desktop effects but after rebooting unable to see desktop effects.
    Code:
    LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa compiz --replace
    /usr/bin/compiz: 79: 0: not found
    Checking for Xgl: not present. 
    WARNING: Failed to open config file /etc/modprobe.d/options.save: Permission denied
    Detected PCI ID for VGA: 00:02.0 0300: 8086:2a02 (rev 03) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
    Checking for nVidia: not present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.
    some more :
    Code:
    Distribution: Ubuntu 8.04
    Desktop environment: GNOME
    Graphics chip: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
    Driver in use: vesa
    Rendering method: AIGLX
    
    Checking if it's possible to run Compiz on your system... [SKIP]
    
    Checking for hardware/setup problems... [SKIP]
    
    At least one check had to be skipped:
    Error: vesa driver in use 
    
    Would you like to know more? (Y/n) y
    
    The vesa driver is not capable of running Compiz, you need to install the
    proper driver for your graphics card.

  7. #207
    Join Date
    Nov 2007
    Location
    india
    Beans
    485
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    sorry , duplicated the above post.

  8. #208
    Join Date
    Jul 2008
    Beans
    9

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Hi I used the compiz-check and got the following
    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         ATI Technologies Inc RS690M [Radeon X1200 Series]
     Driver in use:         fglrx
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [FAIL]
    
    There has been (at least) one error detected with your setup:
     Error: Fglrx driver not properly installed, you are using the Mesa driver.
    Compiz worked fine right after I first installed the restricted driver but then I installed my updates and it stopped and I had to change it in failsafe Gnome. I can turn on the visual effects but when I do th whole screen jsut goes white. Also if i look in my restricted drivers program the ATI driver is no longer listed. Please help me!

  9. #209
    Join Date
    Jul 2008
    Beans
    7

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.04
    
     Desktop environment:   GNOME
    
     Graphics chip:         nVidia Corporation NV18 [GeForce4 MX 4000] (rev c1)
    
     Driver in use:         nvidia
    
     Rendering method:      Nvidia
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
    
     Checking for non power of two support...          [ OK ]
    
     Checking for composite extension...               [ OK ]
    
     Checking for FBConfig...                          [ OK ]
    
     Checking for hardware/setup problems...           [FAIL]
    
    There has been (at least) one error detected with your setup:
    
     Error: Your current resolution is too high to run Compiz. 
    
    Would you like to know more? (Y/n) y
    
     Your resolution is 3360x1050 but the maximum 3D texture size that your graphics card is capable of is 2048x2048. Thus Compiz will not be able to run on this setup. You have to decrease the resolution first (in case you are using a dual-head setup, try disabling one monitor and run the script again).
    This is what I get from a compiz-check. I'm using nvidia with Twinview. I can use the compiz effects, but they only carry over one monitor and 1/4th of the 2nd monitor. I'm trying to figure out how to have Ubuntu recognize two desktops, even though it's 1 video card. Any help would be appreciated.

  10. #210
    Join Date
    Apr 2007
    Location
    Inside your computerrrrr!
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Hello,

    I'm having problem with the "Desktop effects could not be enabled" issue.
    I have ran compiz-check and got this:

    Code:
    jared@jared-laptop:~$ ./compiz-check
    
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]
     Driver in use:         radeon
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [ OK ]
    
    jared@jared-laptop:~$
    There was an error earlier with the "hardware/setup problems" where the driver was blacklisted for known issues. However, it asked if I wish to remove the blacklist for the driver and I did so. Nevertheless, I still get the error.

    Thanks,
    Jared

Page 21 of 81 FirstFirst ... 1119202122233171 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •