Results 1 to 10 of 10

Thread: Automount sata disk

  1. #1
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Automount sata disk

    Hi, i want to automount my windows sata disk on startup. at the moment it will mount when i double click on it in the file manager, but id rather not do this everytime i start up (i no im lazy) ive been editing my fstab with the values the file manager has given me for how it mounts my sata drive (as its ntfs and i can write to it i presume its ntfs-3g however ubuntu calls the filesystem fuseblk (tho i think thats the dudes who do ntfs-3g so it doesnt matter)

    This is my original fstab:
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda1	
    UUID=b03f4ea5-28f4-4a1e-a7da-7216ff0e618c /               ext3    relatime,errors=remount-ro 0       1
    # /dev/sda5
    UUID=4be91c65-bfb2-4060-9e6b-54d4c954d1b4 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    The drive is marked as sda1 and heres a screenshot of the file manager showing how it mounts the drive:


    Ive tried putting the options it shows into the /dev/sda1 bit of the fstab file, and at the bottom where the cd and floppy drives are shown but it has no effect. any help? perhaps if someone could edit it for me on here and i could just paste it in to the fstab file?
    Last edited by bergqvistjl; May 18th, 2008 at 12:20 PM.

  2. #2
    Join Date
    Oct 2007
    Location
    Athens, Greece
    Beans
    179
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Automount sata disk

    You could install ntft-config. It is in the repositories.
    It's a graphical user interface for auto-mount ntfs drives.
    Beware of he who would deny you access to information, for in his heart he dreams himself your master.

  3. #3
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Re: Automount sata disk

    thanks, tho i id rather just modify my fstab tbh, and your suggestion didnt work
    Last edited by bergqvistjl; May 18th, 2008 at 01:13 PM.

  4. #4
    Join Date
    Apr 2008
    Beans
    9

    Re: Automount sata disk

    Go to System>Preferences>Hardware Information.

    Find your disk under the "Computer" heading. Click on it, and then click on the Advanced tab on the right side. The last entry will be the UUID for your disk.

    Edit your /etc/fstab using this UUID. Reboot. Worked for me.

  5. #5
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Re: Automount sata disk

    i dont have a hardware information dialog in the system>preferences menu!

  6. #6
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Re: Automount sata disk

    ive got the uuid for my disk, where do i put it in the fstab file and do i need to put anyting else?

  7. #7
    Join Date
    May 2006
    Beans
    106
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Automount sata disk

    adding the line
    Code:
    UUID=<UUID of partition> /windows ntfs-3g defaults,utf8 0 0
    to your fstab should mount your windows parition on /windows in read-write mode.

    If you want read only

    Code:
    UUID=<UUID of partition> /windows ntfs-3g defaults,ro,utf8 0 0
    should do it.

  8. #8
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Re: Automount sata disk

    it hasnt worked, infact the disk has disappeared from nautilus altogether. ive deleted the line u told me to add and its come back
    Last edited by bergqvistjl; May 18th, 2008 at 02:43 PM.

  9. #9
    Join Date
    May 2006
    Beans
    106
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Automount sata disk

    Quote Originally Posted by bergqvistjl View Post
    it hasnt worked, infact the disk has disappeared from nautilus altogether. ive deleted the line u told me to add and its come back

    interesting. Did you create the directory for your mount point? If you did then can you check your system log for errors? The fact it disappeared from nautilus suggests that it tried to mount it and failed...

    try this:

    Code:
    UUID=<UUID of partition> /windows ntfs-3g defaults,noauto,utf8 0 0
    this way your partition will not auto mount.

    Then from the command line type
    Code:
    sudo mount /windows
    and put up the error please.

  10. #10
    Join Date
    May 2008
    Location
    UK
    Beans
    155
    Distro
    Ubuntu

    Re: Automount sata disk

    yeah the disk is mounted in /media/disk

    i replaced the /windows with /media/disk and it didnt automount, however it did show up in nautilus again.
    Last edited by bergqvistjl; May 18th, 2008 at 03:30 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •