Results 1 to 7 of 7

Thread: [SOLVED] dead keys not working

  1. #1
    Join Date
    Sep 2006
    Location
    Bogotá, Colombia
    Beans
    309

    [SOLVED] dead keys not working

    Hello,

    Since about yesterday, dead keys do not work on most (almost all) programs on my system. That is, if I type e.g. dead_acute + a it comes out as ´a, instead of á. The Compose key is ignored in the same fashion, so e.g. Compose+'+a produces 'a instead of á.
    The programs in which this problem appears include Firefox, Epiphany, Gnome Terminal, Gedit, and Tcl/Tk shell - in fact, the only program so far in which I've found the dead keys to work as they should is Mathematica.

    With respect to Gnome Terminal, there is a way to make dead keys work - namely, to switch the input method from "System" to "Simple". Unfortunately most apps do not have such an input method switcher, so I still cannot write accented characters on Firefox or aMSN (which is Tcl/Tk-based).

    Also, when running the same apps (exact same binary files) under a Hardy liveCD, dead keys work fine on all of them.

    Any help with this would be greatly appreciated.

    -Fibo

  2. #2
    Join Date
    Nov 2005
    Beans
    522
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: dead keys not working

    Have you tried resetting your keyboard preferences to use dead keys?

    System>Preferences>Keyboard>Layouts

    Add a layout using deadkeys if there is not already one there...

  3. #3
    Join Date
    Sep 2006
    Location
    Bogotá, Colombia
    Beans
    309

    Re: dead keys not working

    Quote Originally Posted by techstop View Post
    Have you tried resetting your keyboard preferences to use dead keys?

    System>Preferences>Keyboard>Layouts

    Add a layout using deadkeys if there is not already one there...
    Yes I have. In fact the layout I'm currently using does use dead keys - but they do not work.

  4. #4
    Join Date
    Sep 2006
    Location
    Bogotá, Colombia
    Beans
    309

    Re: dead keys not working

    Update: dead keys work fine for new user accounts, but are still not working on my account.

  5. #5
    Join Date
    Sep 2006
    Location
    Bogotá, Colombia
    Beans
    309

    Re: dead keys not working

    I finally solved it. It was all due to a symlink on ~/.xinput.d which pointed to /etc/X11/xinit/xinput.d/scim. I just removed it, and now dead keys work fine everywhere.

  6. #6

    Smile Re: dead keys not working

    Quote Originally Posted by Fibonacci View Post
    I finally solved it. It was all due to a symlink on ~/.xinput.d which pointed to /etc/X11/xinit/xinput.d/scim. I just removed it, and now dead keys work fine everywhere.
    YÓU ÁRĚ MÝ HÉRÓ!

    I've had this problem for ages, never knew why. I knew it was some hidden config file, as it worked for other users. Thank you, thank you, thank you!

  7. #7
    Join Date
    Aug 2009
    Location
    Skopje (MK), Cologne (DE)
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] dead keys not working

    my hero as well...

    a question. in folder /etc/X11/xinit/xinput.d/ I have the following files: all_ALL default-xim ja_JP lo-gtk none th_TH default ibus zh_CN zh_SG ko_KR lo_TH th-gtk th-xim zh_HK zh_TW. is it safe to delete all this?

    background: before i had by mistake installed scim (with all asian stuff...). after uninstalling it - the dead keys stoped working. i deleted first the "scim" file. nothing happened. then i deleted "scim-bridge" and "scim-immodule". then it worked!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •