Results 1 to 8 of 8

Thread: No GRUB after 8.04 install

  1. #1
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    No GRUB after 8.04 install

    Hey guys,
    I just did a fresh install of XP on its own partition, and am trying to dual boot it with Hardy Heron.

    I've got a 4gb partition (ntfs) for XP, and a 35gb ext3 for Ubuntu. I run the installer via live cd and everything seams to work; but GRUB does not appear to have installed. Windows XP boots, as if Ubuntu doesn't exist.

    I had no problems with 7.10...

    Thanks

  2. #2
    Join Date
    Aug 2005
    Location
    Philadelphia, PA, USA
    Beans
    2,774
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: No GRUB after 8.04 install

    Just to be clear, did you install XP first to a primary partition, and the install Ubuntu? If XP was installed last it will overwrite grub on the MBR. Assuming Ubuntu installed ok, then you just need to reinstall grub. To reinstall grub, boot up the live CD, open a terminal, and follow this:

    http://users.bigpond.net.au/hermanzo...b_with_Live_CD
    Registered Linux User #422464 http://linuxcounter.net/
    Use the search engine that respects your privacy rights: https://startpage.com/

  3. #3
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No GRUB after 8.04 install

    I installed Ubuntu AFTER Windows to prevent it overwriting the MBR.

    I'll try the above now.

  4. #4
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No GRUB after 8.04 install

    Thanks, I did the above and now GRUB is installed.

    The menu items are all named correct, and I can boot Winxp. However, If I try and run one of the Ubuntu items I get "Partition not found". That's rubbish; Ubuntu is installed on (hd1,1) where xp is on (hd1,0). So my setup is something like this:
    hd1,0 - NTFS - Winxp - 40gb
    hd1,1 - ext3 - Ubuntu 8.04 - 35gb
    linux-swap - 2gb
    free space - 1gb

    The menu.lst points to (hd1,1) for Ubuntu, but I get "Partition not found"... is there a tool I can run from the live-cd to 'suss it out' ?

  5. #5
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: No GRUB after 8.04 install

    Boot from the Ubuntu LiveCD. From your desktop, open the terminal and issue the command:

    sudo update-grub

    to re-create your /boot/grub/menu.lst
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  6. #6
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No GRUB after 8.04 install

    Searching for GRUB installation directory ...
    No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To install grub, install it manually or try the 'grub-install' command. ### Warning, grub-install is used to change your MBR. ###

    >D:

  7. #7
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: No GRUB after 8.04 install

    Follow this link to re-create your GRUB.
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  8. #8
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No GRUB after 8.04 install

    Ok; now I'm really screwed.

    I have no idea where GRUB is installed, I can't find stage1... how do I completely remove grub and install it to my Ubuntu partition?

    //edit
    I think it is trying to setup and update GRUB on "/" (live cd root) instead of "/media/disk-1/boot/grub"... I think I'm going to have to reinstall Ubuntu. Possible Windows as well and start from scratch... very disappointing; Ubuntu 7.10 worked a charm, Ubuntu 8.04 is a complete crock up for both me and my Dad.

    //edit
    Ok; here is what I did:
    sudo gparted
    unmount disk-1
    linuxswap off
    delete partition disk-1
    delete linuxswap

    Windows recovery console:
    fixmbr

    voila!

    I'll try again next week
    Last edited by Jungle-Cat; May 19th, 2008 at 10:44 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •