Results 1 to 7 of 7

Thread: Networking: Static mode not working under hardy

  1. #1
    Join Date
    Sep 2006
    Beans
    3

    Networking: Static mode not working under hardy

    Hello ubuntu world.

    I used to have my computer set up in static IP mode as my kids' ubuntu laptops used to use my computer to store files and access printers etc..

    I updated to hardy heron and this continued to work for a week or two, but suddenly my computer has ceased its ability to communicate on the network and internet in static mode. If I set it to roaming mode, everything is fine, with access to the internet and everything. However, the laptops then don't know where to find the printer and shared folders as the IP address keeps changing as it is allocated dynamically by the wireless router.

    Has anyone any ideas?

    Many thanks.

  2. #2
    Join Date
    Jul 2006
    Beans
    75

    Re: Networking: Static mode not working under hardy

    I've just installed Heron and have exactly the same problem - has anyone got any answers ?

  3. #3
    Join Date
    Dec 2006
    Beans
    1,133
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Networking: Static mode not working under hardy

    Perhaps the easiest solution is to configure your router to always give the same ip address to your computer. Your computer will still use DHCP to ask the router for an address, so it can be left in roaming mode.

    Most routers these days are configured by pointing a web browser at their IP address. Often the default is 192.168.2.1 but it can be changed. If you don't have documention for your router you can probably find it on the web.
    There are no dumb questions, just dumb answers.

  4. #4
    Join Date
    Jun 2006
    Location
    Rochester, New York, USA
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Networking: Static mode not working under hardy

    Quote Originally Posted by lswb View Post
    Perhaps the easiest solution is to configure your router to always give the same ip address to your computer. Your computer will still use DHCP to ask the router for an address, so it can be left in roaming mode.

    Most routers these days are configured by pointing a web browser at their IP address. Often the default is 192.168.2.1 but it can be changed. If you don't have documention for your router you can probably find it on the web.
    Not everybody has 'most routers'. I somehow used to before it died on us, but as I don't live on my own quite yet and my dad can't be arsed to do any research on anything he ever buys or ask me about it first, that situation's somewhat out of my control, and I'm stuck with my Linksys WRT54G. So, apparently the only way I could have set a static IP is on my computer... which isn't working.

  5. #5
    Join Date
    May 2006
    Location
    United Kingdom
    Beans
    469
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Networking: Static mode not working under hardy

    Quote Originally Posted by GrumpyOldMan View Post
    Hello ubuntu world.

    I used to have my computer set up in static IP mode as my kids' ubuntu laptops used to use my computer to store files and access printers etc..

    I updated to hardy heron and this continued to work for a week or two, but suddenly my computer has ceased its ability to communicate on the network and internet in static mode. If I set it to roaming mode, everything is fine, with access to the internet and everything. However, the laptops then don't know where to find the printer and shared folders as the IP address keeps changing as it is allocated dynamically by the wireless router..
    Which router do you have as it is possible for some to associate a MAC address to an IP address and thus dynamically allocate your 'static' address ,if you like?

  6. #6
    Join Date
    Dec 2006
    Beans
    1,133
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Networking: Static mode not working under hardy

    Xanatos, there are a lot worse routers to be stuck with. The WRT54G is one of the better consumer-grade routers as far as configurability is concerned. The OEM ip address for configuring this router is 192.168.2.1. IIRC, the OEM login is "admin" and the OEM password is also "admin" These all can be changed by the user. There is a reset button on the back that if pushed in for 30 seconds will reset all setting to the factory defaults, including the login and password; don't do this if you are not prepared, but it is likely that they have never been changed from the factory settings.

    You can find all the documentation you need for the WRT54G on the web, including a .pdf copy of the user manual at www.linksys.com. There were several revisions made to the firmware and hardware of this router over the years, you will need the version and model number to get the correct user manual for your specific router.

    Actually, the older models are more desireable than the newer ones, as they had more memory installed and ran a linux-based software that could be customized or fully replaced to give the unit a lot more features than the stock firmware.
    There are no dumb questions, just dumb answers.

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,983
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Networking: Static mode not working under hardy

    Do you have a DHCP conflict? That is, has one of the kids machines has received 192.168.1.105 via DHCP from the router? If you then boot your machine which asks for a static address, 192.168.1.105, you won't connect.

    Set up your router to give just 5 or 10 DHCP addresses and set your static at 192.168.1.115 or similar.

    In my network, using a Linksys WRT54G, the DHCP server is set to give 10 addresses from x.100 to x.109. My several static machines are set from x.115 on up.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •