Results 1 to 6 of 6

Thread: Do I need Sane as well as xSane?

  1. #1
    Join Date
    Dec 2006
    Location
    Alsace
    Beans
    1,057
    Distro
    Ubuntu 20.04 Focal Fossa

    Question Do I need Sane as well as xSane?

    Sorry for yet another dumb question!

    I am trying to follow (blindly) another thread to get my Epson V200 scanner working with Gutsy.

    Epson Japan tells me to make sure I have Sane package 1.0.3 or later, before attempting installing their drivers, which I have downloaded & md5-ed.

    Looking in Synaptic Package Manager, I see I have xSane installed, but not Sane.
    I did not choose either.
    I tried to understand what these are (visiting their websites, Googling & ploughing through this forum) but failed...

    Could some kind soul please explain (roughly) what Sane & xSane are and whether I need to have either or both installed before I try anything else?

    Many thanks in advance!
    Acer Aspire TC-100-007: Multi boot W10 / 20.04 / 18.04 LTS: Canon TS705: Epson V200: also Asus 1015PED: W7 / 18.04 Lubuntu

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Do I need Sane as well as xSane?

    I don't have an epson scanner but mine (an old artec) works fine with just xsane and sane-utils installed. I don't have sane installed.
    Last edited by drs305; May 17th, 2008 at 09:13 PM. Reason: spelling

  3. #3
    Join Date
    Oct 2005
    Location
    De Kwakel - Holland
    Beans
    3,657

    Re: Do I need Sane as well as xSane?

    Good question..
    My guess is that it's all about the sane library (libsane) and "xsane" and "sane" only provide frontends to this library, they neither support scanner on there own, it's libsane that does.
    Since both (sane and xsane) pull in libsane as a dependency my guess is that you can choose either one.
    Personally I love xsane, it provides a lot of goodies for scanning.

  4. #4
    Join Date
    Dec 2006
    Location
    Alsace
    Beans
    1,057
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Do I need Sane as well as xSane?

    Thanks for those 2 quick replies.

    I have xsane & libsane installed, but not sane or sane-utils.

    Sounds as though I don't need to install sane (right?).

    Do I need to install sane-utils?

    Can I do any harm or cause any confusion by installing them all?

    Anything else?

    Thanks again.
    Acer Aspire TC-100-007: Multi boot W10 / 20.04 / 18.04 LTS: Canon TS705: Epson V200: also Asus 1015PED: W7 / 18.04 Lubuntu

  5. #5
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Do I need Sane as well as xSane?

    You won't do any harm - synaptic will take care of you - but you don't need sane or sane-utils unless xsane installs them.

    By the way, we have mentioned dependencies. One way you can get that information is to look in synaptic. Highlight the app you have installed, click on Properties, and then Dependencies. It will tell you which libraries or other files are necessary to run the app. (Note: you can get the dependencies without installing an app but can't view the next tab over -- installed files).

  6. #6
    Join Date
    Jul 2006
    Beans
    353

    Re: Do I need Sane as well as xSane?

    Quote Originally Posted by 2CV67 View Post
    Thanks for those 2 quick replies.

    I have xsane & libsane installed, but not sane or sane-utils. Sounds as though I don't need to install sane (right?). Do I need to install sane-utils?...
    I have libsane, xsane, and xsane-common installed, and my Epson 3490 scans like a champ. Neither sane nor sane-utils are installed.

    The only issue I had with my scanner was copying over the scanner firmware and pointing the following file to the firmware:

    /etc/sane.d/snapscan.conf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •