Results 1 to 1 of 1

Thread: Nvidia doesn't appear in Hardware Drivers [with workaround]

  1. #1
    Join Date
    Aug 2006

    Nvidia doesn't appear in Hardware Drivers [with workaround]

    I tried to get the proprietary nvidia driver working, however when I went to Hardware Drivers it gave me an empty list window and told me "No Restriced Drivers are in Use."

    Well yeah. I know that. That's the problem!

    Anyway, you can get nvidia going the (new) 'old fashioned' way. First, make sure you have the appropriate nvidia package installed. I'm using nvidia-glx-new.

    Drop to a console by typing Ctrl Alt F1 and log in (your password is not echoed back to you.) These commands need to be run as root, so either preface each one with sudo or use 'sudo -s' to run a root shell.

    /etc/init.d/gdm stop
    X -configure
    X -config /home/USERNAME/
    that last command was to make sure X detected things properly -- if you get a cursor, it worked. get out of it with Ctrl Alt Backspace. If it didn't work, your problem likely won't be solved here. Oh and of course replace USERNAME with your user name ... moving on
    mv /home/USERNAME/ /etc/X11/xorg.conf
    /etc/init.d/gdm start
    That did it for me!

    bug report
    Last edited by decoherence; May 16th, 2008 at 03:41 PM. Reason: included bug report, clarity


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts