Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 60

Thread: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

  1. #21
    Join Date
    May 2008
    Location
    China
    Beans
    49

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Catching up on the reply ...

    Rigrig,
    Updated the additional in the main text.

    XekaLula,
    Perhaps check your gdm.conf to see if you have all the changes. Uncomment the line etc.

    cyboc,
    I have no idea about the error and have not try tightvnc. Would assume that tightvnc would be pretty similar.
    You don't have to remove vino. It is used for remote desktop for the user, a somewhat different purpose.

    dylansimpson,
    #20 should be the solution.
    Basically set wait = yes
    See man xinetd somewhere near the end about this.

    pumax84,
    Sorry don't quite understand the problem here.

  2. #22
    Join Date
    Apr 2006
    Beans
    14

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Im having a problems connecting with vnc after i followed this guide.

    In the first place i could not login with vns unless i logged in at the console first. This server is headless and has only power and ethernet connected. So I need to be able to log in with vnc after reboot without having to connect a monitor/keyboard/mouse.

    I followed this guide, but i was doing thorugh vns, and when i came to the point where i should restart GDM i lost the connection.
    I did the last steps through ssh, but still cant log in with vnc..

  3. #23
    Join Date
    May 2006
    Location
    United Kingdom
    Beans
    469
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    If you have an ethernet connection you will be able to setup autologin (System > Administration > Login Window > Security ; then tick "Enable automatic login" for your desired username. Test this before moving to location without kbd/mouse/screen.

    This may work with wireless connection but I found that the wireless key needed to be unlocked and hence a keyboard attached which defeats the whole idea.

    HTH

  4. #24
    Join Date
    Apr 2006
    Beans
    14

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by geezerone View Post
    If you have an ethernet connection you will be able to setup autologin (System > Administration > Login Window > Security ; then tick "Enable automatic login" for your desired username. Test this before moving to location without kbd/mouse/screen.

    This may work with wireless connection but I found that the wireless key needed to be unlocked and hence a keyboard attached which defeats the whole idea.

    HTH
    Is there a way to enable this through ssh?

  5. #25
    Join Date
    May 2006
    Location
    United Kingdom
    Beans
    469
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    You ssh first to create your secure tunnel and then vnc over this. You need to configure auto-login first with kbd/mouse attached and then test. Once configured, remove mouse/kdb and this should work ok.

  6. #26
    Join Date
    Apr 2006
    Beans
    14

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by geezerone View Post
    You ssh first to create your secure tunnel and then vnc over this. You need to configure auto-login first with kbd/mouse attached and then test. Once configured, remove mouse/kdb and this should work ok.
    I actually got it figured out.
    In /etc/gdm/gdm.conf i just replaced "autologin=false" with "autologin=true"
    Also entered my username in the line below, autologinuser=username
    then i restarted GDM.

    I can now connect with vnc. Didnt have to open a tunnel with ssh.

  7. #27
    Join Date
    May 2006
    Location
    United Kingdom
    Beans
    469
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Glad it is sorted. I understand the OP was setup with experience of servers in a workplace and using ssh is just a more secure way of moving data.

  8. #28
    Join Date
    Apr 2006
    Beans
    14

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by geezerone View Post
    Glad it is sorted. I understand the OP was setup with experience of servers in a workplace and using ssh is just a more secure way of moving data.
    Yeah i understood that, and I totally agree with that solution, it would also just require you to open up for ssh in firewall, you wouldnt need to open for 5900/5901.

    I just gave it a second try, i added the "only_from = localhost" in the /etc/xinetd.d/Xvnc, but im still able to log in with vnc without having a tunell in putty..

    will look more into this. maybe I need a restart.

    edit: figured it out, i wasnt using localhost in vnc.. i was still using my servers ip (knocks my head in table)

    Anyway forgot to mention, great guide! even me, a totally newbie got this up and working (yeah except for the vnc/ssh)
    now i can log into the box after powerloss etc.. without having to log on to the console first.
    Last edited by Pjukern; June 25th, 2008 at 09:44 PM.

  9. #29
    Join Date
    Jul 2006
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Is there a way to automatically disable all GNOME theming when connecting via VNC?

    Sometimes the GNOME theme just "crashes" anyway when using TightVNC and displays a very basic looking GNOME. This is better for me as it makes my desktop much faster to use over WAN.

  10. #30
    Join Date
    Oct 2007
    Beans
    55

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Great write up! I had to find a way to get my wifi card enabled without network manager (so it would have network access before login), here, at the bottom, and it works (but then it makes network manager worthless, which is fine with me).

    I also had to do some voodoo to get vnc4server to work properly (editing the font paths in /etc/vnc.conf), and I followed this HowTo to the T...but I still am having the problem XekaLula was having...all I get when I log into the other machine is a blank screen with an X. (I'm suprised I was able to forward the port to get the SSH tunneling to work...I tried it both with and without tunneling with no problems. I only discovered SSH and it's wonderful usefulness yesterday )

    I'm almost certain it's an XDMCP problem (and, yes, I did edit /etc/gdm/gdm.conf, removing the comment mark before "Remote Greeter=/usr/lib/gdm/gdmlogin" and changing Enable to "true" in the [xdmcp] section. Of course, I've restarted gdm and xinetd (on the server) about a thousand times trying to get all of the above to work, and even rebooted the server a few times, too, for good measure.

    By going to the gdm login window in the client machine, and attempting to use the GUI to login to the server machine with XDMCP results in a quit network search, with no xdmcp hosts found. Trying to type in either the IP address or the host name also doesn't work (yes, both machines are on the same LAN, both Wifi connections). I remember having trouble getting XDMCP to work in Gutsy, and I just gave up. Yes, Hardy is on both the client and the server, and the server still gives me the grey screen with the black X cursor, and nothing else (when it should be the XDMCP login screen). What am I doing wrong?
    Last edited by drewster1829; June 29th, 2008 at 06:07 AM. Reason: nevermind

Page 3 of 6 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •