Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: HomePna internet connection problem

  1. #11
    Join Date
    May 2008
    Location
    Finland
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HomePna internet connection problem

    Same reply again.

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,517
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HomePna internet connection problem

    Please do:
    Code:
    sudo modprobe pcnet32 homepna=1
    sudo lshw -C network
    and post the result.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #13
    Join Date
    May 2008
    Location
    Finland
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HomePna internet connection problem

    delzun@Gaidin:~$ sudo modprobe pcnet32 homepna=1
    [sudo] password for delzun:
    delzun@Gaidin:~$ sudo lshw -C network
    *-network
    description: Ethernet interface
    product: 79c978 [HomePNA]
    vendor: Advanced Micro Devices [AMD]
    physical id: 7
    bus info: pci@0000:04:07.0
    logical name: eth1
    version: 52
    serial: 00:08:54:d5:da:d5
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical
    configuration: broadcast=yes driver=pcnet32 driverversion=1.33 latency=32 link=no maxlatency=24 mingnt=24 module=pcnet32 multicast=yes
    This is what I got this time.

  4. #14
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,517
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HomePna internet connection problem

    That looks very healthy except:
    link=no
    Please:
    1. Make sure the phone line is connected to the device, the router, and, of course, the wall.
    2. Are there any lights on the card? On or off? One or two?
    3. No listing in sudo lshw -C network for any other devices?
    4. Can you please post the last 6-8 lines of:
    Code:
    sudo cat /var/log/messages | grep pcnet
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #15
    Join Date
    May 2008
    Location
    Finland
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HomePna internet connection problem

    1. Is connected
    2. There are two lights. While Windows is up one light is on all the time, other flashes. While Linux is up, they both stay dark.
    3. No
    4.
    May 14 22:16:28 Gaidin kernel: [ 42.149946] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 14 22:16:28 Gaidin kernel: [ 45.042694] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 14 22:16:28 Gaidin kernel: [ 45.042775] pcnet32: 1 cards_found.
    May 15 16:44:08 Gaidin kernel: [ 49.977381] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 15 16:44:08 Gaidin kernel: [ 52.876201] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 15 16:44:08 Gaidin kernel: [ 52.876283] pcnet32: 1 cards_found.
    May 18 14:21:23 Gaidin kernel: [ 40.012752] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 18 14:21:23 Gaidin kernel: [ 42.909277] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 18 14:21:23 Gaidin kernel: [ 42.909357] pcnet32: 1 cards_found.
    May 20 17:20:21 Gaidin kernel: [ 37.105718] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 20 17:20:21 Gaidin kernel: [ 40.004279] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 20 17:20:21 Gaidin kernel: [ 40.004358] pcnet32: 1 cards_found.
    May 20 21:16:29 Gaidin kernel: [ 36.895674] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 20 21:16:29 Gaidin kernel: [ 39.792135] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 20 21:16:29 Gaidin kernel: [ 39.792213] pcnet32: 1 cards_found.
    May 22 13:04:44 Gaidin kernel: [ 39.202098] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 22 13:04:44 Gaidin kernel: [ 42.100293] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 22 13:04:44 Gaidin kernel: [ 42.100376] pcnet32: 1 cards_found.
    May 22 13:15:56 Gaidin kernel: [ 39.638212] pcnet32.c:v1.33 27.Jun.2006 tsbogend@alpha.franken.de
    May 22 13:15:56 Gaidin kernel: [ 42.536221] pcnet32: PCnet/Home 79C978 at 0xbc00, 00 08 54 d5 da d5 assigned IRQ 20.
    May 22 13:15:56 Gaidin kernel: [ 42.536304] pcnet32: 1 cards_found.
    delzun@Gaidin:~$

  6. #16
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,517
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HomePna internet connection problem

    Please execute the following commands. Double check your typing, because each character and space is crucial:
    Code:
    sudo su
    Give your password.
    Code:
    echo 'options pcnet32 homepna=1' > /etc/modprobe.d/pcnet32
    gedit /etc/network/interfaces
    The text editor 'gedit' will pop up with a file ready to edit. Don't remove anything! Make sure there are lines in place like this:
    Code:
    auto eth1
    iface eth1 inet dhcp
    Add them if not. Save and close gedit. Reboot. Did the lights come on on the card? When you run:
    Code:
    ifconfig
    Did you get an IP address?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #17
    Join Date
    May 2008
    Location
    Finland
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HomePna internet connection problem

    auto lo
    iface lo inet loopback
    address 127.0.0.1
    netmask 255.0.0.0


    iface eth1 inet dhcp

    auto eth1

    iface eth0 inet dhcp
    This was what I had in text editor, before I did anyting to it.
    Should I change "iface eth0 inet dhcp" to "iface eth1 inet dhcp" or is ok now?
    Last edited by Sammel; May 22nd, 2008 at 01:42 PM.

  8. #18
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,517
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HomePna internet connection problem

    Since you have nothing in lshw that relates to eth0, I would comment it out. Also, I'd like to have the auto eth1 before the other eth1 stuff. Please make it look like this:
    Code:
    auto lo
    iface lo inet loopback
    address 127.0.0.1
    netmask 255.0.0.0
    
    auto eth1
    iface eth1 inet dhcp
    
    #iface eth0 inet dhcp
    As always, please double-check your work.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #19
    Join Date
    May 2008
    Location
    Finland
    Beans
    33
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HomePna internet connection problem

    I made those changes. But lights on networking card still stay dark. Rebooting didn't help.

  10. #20
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,517
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HomePna internet connection problem

    Please post:
    Code:
    cat /etc/modprobe.d/pcnet32
    ifconfig
    Let's see if we made any errors.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •