Page 1 of 9 123 ... LastLast
Results 1 to 10 of 82

Thread: Newbie can't get nVidia Geforce 5200 FX working!

  1. #1
    Join Date
    May 2008
    Beans
    18

    Unhappy Newbie can't get nVidia Geforce 5200 FX working!

    Massive newbie here, just made the journey from the territory of XP to the scary world of Ubuntu!

    On a clean install of Ubuntu 8.04, I cannot get my Geforce 5200 FX to run at my LCD's native res of 1024 x 768. It isn't on the list in "Screen Resolution".

    What do I need to do?

    Please: very simple terms; I know NOTHING about terminals, kernels and all the other scary stuff I've read in other threads here!

    I would be very grateful for any help.
    Last edited by Woodzo; May 12th, 2008 at 11:34 PM.

  2. #2
    Join Date
    Apr 2008
    Beans
    48

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    don't be afraid... you'll talking linux in no time.

    it's not as hard as it seems.

    first of all... when you first did a clean install of ubuntu, did it ask you to install the "restricted drivers" for your graphics card? i have nvidia card and it did that for me automatically. i jsut had to go and click on "install" for it to do it.

    if the drivers are already installed, then you need to install "nvidia-settings". this is how you do that:

    At the top file menu, click on Applications, then Accessories, then click on Terminal.

    This will open a little window with a white background and a cursor.

    copy and paste what is below. (ctr+c is to copy, ctr+shift+v is to paste into termianl)

    Code:
    sudo apt-get install nvidia-settings
    nevermind what all that mumbo jumbo means. in a nutshell, what this will do is download a tool that can manage your screen resolution and other things related to your graphics card.

    when it is done installing, all you have to do is click on System from the file menu, go to Administration, and look for the Nvidia Configuration Manager (i think that's what it's called)

    once you have that up and running, you should be able to change your settings to whatever you may need.

    hope it helps
    Gateway C140-X Tablet PC: Ubuntu 9.10 Karmic Koala
    Dual Boot with Windows XP Pro

    AMD Athlon 64 X2 3800+ w/Asus M2NPV-VM Mobo & ATI x1950: Ubuntu 9.10 Karmic Koala

  3. #3
    Join Date
    May 2008
    Beans
    18

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    Quote Originally Posted by dublued View Post
    first of all... when you first did a clean install of ubuntu, did it ask you to install the "restricted drivers" for your graphics card?
    Sorry, it didn't.

    How can I check if they're installed or not?
    Last edited by Woodzo; May 12th, 2008 at 11:42 PM.

  4. #4
    Join Date
    Oct 2007
    Location
    Kentucky
    Beans
    260
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    After following dubled's advice, or before, try going to system-administration-hardware drivers, and see if your driver is listed.

  5. #5
    Join Date
    Apr 2008
    Beans
    48

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    ^^ what he said
    Gateway C140-X Tablet PC: Ubuntu 9.10 Karmic Koala
    Dual Boot with Windows XP Pro

    AMD Athlon 64 X2 3800+ w/Asus M2NPV-VM Mobo & ATI x1950: Ubuntu 9.10 Karmic Koala

  6. #6
    Join Date
    Dec 2007
    Location
    Tampa, FL
    Beans
    1,087
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    Go to SYSTEM>ADMINISTRATION>HARDWARE DRIVERS and check to see if your Geforce is listed under devices. If so, enable, install, and restart, that's it.

    If it's not listed, then you'll need a piece of software called envy-ng (this will install the latest Nvidia driver)
    Code:
    sudo apt-get install envy-ng
    once installed, it will be listed under APPLICATIONS>SYSTEM TOOLS. Simply run it, select NVIDIA and install.

    Also, I'm assuming your card is AGP. If so, you might need to edit your xorg.conf file. In gutsy you had to, not so sure about hardy. If after the install you can't get it working (or boot to a black screen, let me know and I can help you with that)...

    Sometimes your card will be installed but you still can't get the proper resolution (this has happened to me before). If that's the case, you'll have to edit your xorg.conf as well. Again, let us know if this is the case...
    Last edited by Victormd; May 12th, 2008 at 11:53 PM.
    "There are 10 types of people: Those who read binary and those who don't"
    >>>"who is general failure and why is he reading my files"<<<
    The Ubuntu Counter Project - user number # 22367
    Howto automount NTFS - My wallpaper

  7. #7
    Join Date
    May 2008
    Beans
    18

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    The driver is installed and I've just enabled it, along with the settings manager dublued said about.

    Now the res is stuck at 640 x 480 and the only other option is 320 x 240! Reminds me of my Atari ST days...

    Any further advice?

    P.S. @Victormd: yep it's AGP.

  8. #8
    Join Date
    Dec 2007
    Location
    Tampa, FL
    Beans
    1,087
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    Quote Originally Posted by Woodzo View Post
    The driver is installed and I've just enabled it, along with the settings manager dublued said about.

    Now the res is stuck at 640 x 480 and the only other option is 320 x 240! Reminds me of my Atari ST days...

    Any further advice?

    P.S. @Victormd: yep it's AGP.
    Ok, so you're going to need to do some tweaking to your xorg.conf. First off, open a terminal window and type:
    Code:
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    this will backup your configuration file, then type:
    Code:
    sudo gedit /etc/X11/xorg.conf
    copy the contents and post them here
    "There are 10 types of people: Those who read binary and those who don't"
    >>>"who is general failure and why is he reading my files"<<<
    The Ubuntu Counter Project - user number # 22367
    Howto automount NTFS - My wallpaper

  9. #9
    Join Date
    May 2008
    Beans
    18

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    Quote Originally Posted by Victormd View Post
    copy the contents and post them here
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "gb"
    EndSection


    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection


    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    Defaultdepth 24
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    screen "Default Screen"
    EndSection
    Section "Module"
    Load "glx"
    EndSection

  10. #10
    Join Date
    Dec 2007
    Location
    Tampa, FL
    Beans
    1,087
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Newbie can't get nVidia Geforce 5200 FX working!

    Ok, I must say that xorg.conf has become much simpler in Hardy than it was in Gutsy... I guess that, for now, insert the line in red to your xorg.conf, under the Section "Screen" and reboot to see what happens. Earlier version of xorg.conf you could set the resolutions in the file, now apparently that has changed (I just recently upgraded from ubuntu 7.10 to 8.04), but if adding this line doesn't do the trick, we can try to "force" the resolutions manually.

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    Option "AddARGBGLXVisuals" "True"
    Defaultdepth 24
    EndSection
    NOTE: instead of space between the words, use TAB
    "There are 10 types of people: Those who read binary and those who don't"
    >>>"who is general failure and why is he reading my files"<<<
    The Ubuntu Counter Project - user number # 22367
    Howto automount NTFS - My wallpaper

Page 1 of 9 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •