Results 1 to 7 of 7

Thread: old games run too fast

  1. #1
    Join Date
    Sep 2006
    Location
    Saint-Petersburg, Russia
    Beans
    96
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    old games run too fast

    Hi all!
    Some old games run too fast?
    I have found nothing about it in wine's config
    What can I do?

  2. #2
    Join Date
    Sep 2005
    Location
    Indiana
    Beans
    130

    Re: old games run too fast

    What games are they?

    If they are DOS, I'd recommend using DOSBox over Wine.

  3. #3
    Join Date
    Sep 2006
    Location
    Saint-Petersburg, Russia
    Beans
    96
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: old games run too fast

    No, windows
    no SO old
    2000-2001-2002
    My PC is just quick (core2Duo, hi-end graphics and so on)

  4. #4
    Join Date
    Oct 2006
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: old games run too fast

    System > Administration > Services
    Disable "CPU Frequency Manager"

    This is an issue with old games not being designed for multi-core systems.
    Quote Originally Posted by danny_galaga View Post
    I prefer Call of Duty- World at War. For me there's nothing like gritty WWII action. None of this 'infrared this' and 'satellite that'. Just you, your trusty M1 and a big pair of balls

  5. #5
    Join Date
    Sep 2006
    Location
    Saint-Petersburg, Russia
    Beans
    96
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: old games run too fast

    Thank you
    But may be where is a way to turn off one of "cores" ?
    Temporary, of course

  6. #6
    Join Date
    May 2007
    Location
    the Netherlands
    Beans
    647
    Distro
    Ubuntu Development Release

    Re: old games run too fast

    - You can set cpu affinity for core 1 like this:

    taskset -c 1 wine program_name.exe

    - For more info, see:
    http://linux.die.net/man/1/taskset

    - Another thing you might try is enabling the OpenGL sync-to-vblank setting. In case you're using an nvidia card, run:

    nvidia-settings

    - Choose "OpenGL Settings" and tick the "Sync to VBlank" option.

  7. #7
    Join Date
    Sep 2006
    Location
    Saint-Petersburg, Russia
    Beans
    96
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: old games run too fast

    Thank you, it works

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •