Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] Negative colors

  1. #1
    DeMus is offline I Ubuntu, Therefore, I Am
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149

    [SOLVED] Negative colors

    Hi,
    I noticed while playing a .rm file, later also with .avi, that the colors are negative: red becomes green, etc.
    How can I change this? Do I need another codec, or another nVidia driver for my 8500GT card? If it is the driver could somebody please explain in simple terms how to install the driver since the explanation in the README file on the nVidia driver is way too complicated. I have no idea what to do and how to do it. I am relatively new to Linux and this is way out of my league.

    Thanks for your help,
    DeMus

  2. #2
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Beans
    222
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Negative colors

    Check this thread out: http://www.nvnews.net/vbulletin/show...ighlight=totem

    The crux of it is you can test for this bug using the following:
    Code:
    xvinfo | grep -A2 XV_HUE
    The XV_HUE should be 0... but for some reason it gets set to 178 when opening a movie in Totem using the GStreamer backend.

    You can fix it using the following (temporary!) fix. This will need to be run after every boot, so you might want to set it to run automatically when you login possibly...
    Code:
    xvattr -a XV_HUE -v 0
    NOTE: you'll need to install xvattr for this to work:
    Code:
    sudo apt-get install xvattr
    Last edited by peitschie; May 12th, 2008 at 06:30 AM.

  3. #3
    DeMus is offline I Ubuntu, Therefore, I Am
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149

    Re: Negative colors

    Quote Originally Posted by peitschie View Post
    Check this thread out: http://www.nvnews.net/vbulletin/show...ighlight=totem

    The crux of it is you can test for this bug using the following:
    Code:
    xvinfo | grep -A2 XV_HUE
    The XV_HUE should be 0... but for some reason it gets set to 178 when opening a movie in Totem using the GStreamer backend.

    You can fix it using the following (temporary!) fix. This will need to be run after every boot, so you might want to set it to run automatically when you login possibly...
    Code:
    xvattr -a XV_HUE -v 0
    NOTE: you'll need to install xvattr for this to work:
    Code:
    sudo apt-get install xvattr
    Thanks, it works great. Now the colors are normal again. Just one more question: how to set the code so it will start every time I boot?
    Thanks so much for your help. Realy appreciate it.

  4. #4
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Beans
    222
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Negative colors

    Hrmm.

    I've been playing with this myself (I have an identical issue to you) and it seems that you need to run it before you play any video or change brightness settings etc. so it is quite annoying. I'm still trying 2 figure out a good way of automating it or making it more permanent.

    Sorry I still don't have a total solution yet, so for now I would recommend you put a launcher on your gnome panel that you can click if the colour goes funny It's what I have and it isn't too annoying juuuust yet.

  5. #5
    DeMus is offline I Ubuntu, Therefore, I Am
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149

    Re: Negative colors

    Quote Originally Posted by peitschie View Post
    Hrmm.

    I've been playing with this myself (I have an identical issue to you) and it seems that you need to run it before you play any video or change brightness settings etc. so it is quite annoying. I'm still trying 2 figure out a good way of automating it or making it more permanent.

    Sorry I still don't have a total solution yet, so for now I would recommend you put a launcher on your gnome panel that you can click if the colour goes funny It's what I have and it isn't too annoying juuuust yet.
    Thanks again for your answer. I placed it on my desktop and can start it when I need to. At least the colors in the videos are perfect now.

    DeMus

  6. #6
    Join Date
    Apr 2007
    Location
    Melbourne, Australia
    Beans
    222
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Talking Re: Negative colors

    Hey!

    Just letting you know I have discovered another work-around that doesn't require you to manually set the hue every time you open a video

    To implement the workaround, do the following:

    1. Open gstreamer-properties (alt+f2, enter gstreamer-properties)
    2. Change to the video tab
    3. Change the default output plugin to "custom"
    4. Place the following command in the bottom box: videobalance hue=-1 ! autovideosink
    5. Close the box and enjoy your now correct colour

  7. #7
    Join Date
    Mar 2008
    Location
    Athens - Patissia
    Beans
    26
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Negative colors

    Quote Originally Posted by peitschie View Post
    Hey!

    Just letting you know I have discovered another work-around that doesn't require you to manually set the hue every time you open a video

    To implement the workaround, do the following:

    1. Open gstreamer-properties (alt+f2, enter gstreamer-properties)
    2. Change to the video tab
    3. Change the default output plugin to "custom"
    4. Place the following command in the bottom box: videobalance hue=-1 ! autovideosink
    5. Close the box and enjoy your now correct colour
    You saved my butt!!
    Unfortunatelly, I have the same problem for Kaffeine and VLC, too..
    Any solution..?

  8. #8
    Join Date
    May 2009
    Beans
    3

    Re: [SOLVED] Negative colors

    In VLC player, go to Tools -> preferences and select VIDEO. In the Video settings, look for "Output". Change it to something like "OpenGL video output" and click on save. Restart VLC player. It works like a charm. If it doesn't work, try changing the Output to other options available in the drop down.

    I'm using 9.10 and it worked perfectly for me.

    Thanks,
    Karthic

  9. #9
    Join Date
    Sep 2009
    Beans
    47

    Re: [SOLVED] Negative colors

    The above two posters are wonderful, wonderful people.

  10. #10
    Join Date
    Jan 2010
    Location
    No longer SoFl
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: [SOLVED] Negative colors

    Thanks, this problem would come and go on my machine and didn't know what caused it.



Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •