Results 1 to 1 of 1

Thread: USB audio device problems with swapping

  1. #1
    Join Date
    May 2008
    Beans
    58

    USB audio device problems with swapping

    I have real difficulties to set up my system so that I can hot-swap my USB audio card (Griffin iMic).

    Though my device manager immediately recognises when I plug the iMic in, I couldn't get any sound on it. The USB card shows up in the alsa mixer, but no sound.

    I followed this thread: http://seehuhn.de/pages/alsa and managed to get the iMic working as default device - but now I can't switch back to the internal soundcard. When I unplug the USB soundcard, I get playback errors.
    The strange thing that happened when I rebooted without the iMic plugged in, the welcome sound splash played half the way on my internal speakers (!!!) and then stopped. From that moment on I can only get sound through the iMic.

    I tried the
    Code:
    sudo asoundconf list
    and then choose my default card with
    Code:
    sudo asoundconf set-default-card
    , but no success.

    I looked at http://alsa.opensrc.org/index.php/Ho...evices_(Howto), but am simply not sure what to do with that information.

    Please can someone help me to create a setup that allows me to switch between internal and external soundcard.
    Last edited by fogelfink; May 12th, 2008 at 02:26 AM. Reason: weblink was falsley edited

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •