Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Wireless Network trouble in Ubuntu 8.04

  1. #11
    Join Date
    May 2008

    Talking Re: Wireless Network trouble in Ubuntu 8.04

    Alright, I re-installed Ubuntu successfully, and the first thing I did when I got on was try those steps again in terminal. Here is everything that happened in the Terminal:

    colbra@colbra-laptop:~$ cd
    colbra@colbra-laptop:~$ sudo dpkg -i b43-fwcutter_011-1_amd64.deb
    (Reading database ... 94962 files and directories currently installed.)
    Preparing to replace b43-fwcutter 1:011-1 (using b43-fwcutter_011-1_amd64.deb) ...
    Unpacking replacement b43-fwcutter ...
    Setting up b43-fwcutter (1:011-1) ...

    colbra@colbra-laptop:~$ cd
    colbra@colbra-laptop:~$ sudo b43-fwcutter -w /lib/firmware wl_apsta-
    This file is recognised as:
    ID : FW10
    filename : wl_apsta.o
    version : 295.14
    MD5 : e08665c5c5b66beb9c3b2dd54aa80cb3
    Extracting b43legacy/ucode2.fw
    Extracting b43legacy/ucode4.fw
    Extracting b43legacy/ucode5.fw
    Extracting b43legacy/ucode11.fw
    Extracting b43legacy/pcm4.fw
    Extracting b43legacy/pcm5.fw
    Extracting b43legacy/a0g0bsinitvals2.fw
    Extracting b43legacy/b0g0bsinitvals5.fw
    Extracting b43legacy/a0g0initvals5.fw
    Extracting b43legacy/a0g1bsinitvals5.fw
    Extracting b43legacy/a0g0initvals2.fw
    Extracting b43legacy/a0g1initvals5.fw
    Extracting b43legacy/b0g0bsinitvals2.fw
    Extracting b43legacy/b0g0initvals5.fw
    Extracting b43legacy/b0g0initvals2.fw
    Extracting b43legacy/a0g0bsinitvals5.fw
    colbra@colbra-laptop:~$ tar xfvj broadcom-wl-
    tar: broadcom-wl- Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    colbra@colbra-laptop:~$ sudo b43-fwcutter --unsupported -w /lib/firmware broadcom-wl-
    Cannot open input file broadcom-wl-
    colbra@colbra-laptop:~$ sudo chmod o+rx /lib/firmware/b43 /lib/firmware/b43legacy
    chmod: cannot access `/lib/firmware/b43': No such file or directory
    colbra@colbra-laptop:~$ sudo ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory

    I then tried to connect to my wireless network, no luck. Restarted my computer, and tried again... no luck. Did I do something wrong? I download all the neccessary files onto a flash drive, and copied them to the Home Directory in Ubuntu. But still nothing seems to work, there's always some kind of error. One thing I noticed though, was that when you said to give this command:

    tar xfvj broadcom-wl-
    The download link you provided linked to a file in ".tar" format, not ".bz2." Could that be the problem?


    I found a spare ethernet cable, and wanted to see what would happen if I connected my computer to my modem, and to my surprise, I was connected to the internet!!! I didn't know that was possible! Anyway, I still don't have wireless working, so if there are any better steps to take that require an internet connection, I am now able to follow those steps. I'm even writing this from Ubuntu right now, this is so cool!!!
    Last edited by cheeZ; May 9th, 2008 at 11:54 PM.

  2. #12
    Join Date
    Apr 2007
    Mount Horeb, WI
    Kubuntu Development Release

    Re: Wireless Network trouble in Ubuntu 8.04

    Quote Originally Posted by cheeZ View Post
    colbra@colbra-laptop:~$ tar xfvj broadcom-wl-
    tar: broadcom-wl- Cannot open: No such file or directory
    This is saying that the file is not in your home directory. Is that where you put the file? You need to be in the directory where that file is located and then it should extract just fine and you should be able to continue from that step.

    If it does not extract, please show the result of:
    ls -l broadcom-wl-*

  3. #13
    Join Date
    May 2008

    Thumbs up Re: Wireless Network trouble in Ubuntu 8.04

    After searching around I came across this thread. Since I was able to connect to the internet from my ethernet cable, I was able to successfully download everything I needed through the terminal following each step. And I can't believe it, it worked PERFECTLY. After restarting my computer, it actually saw my network and was able to connect to it perfectly. I'm sorry if I made you go to any trouble when there was already thread that had the answer I was looking for. Thank you though, I appreciate you taking the time to help point me in the right direction. You can't imagine how grateful I am to have wireless now, before I thought there was no hope at all! Thanks again,


Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts