Page 93 of 241 FirstFirst ... 43839192939495103143193 ... LastLast
Results 921 to 930 of 2402

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #921
    Join Date
    Jun 2007
    Beans
    16,778

    Re: HOWTO: Install and use the latest FFmpeg and x264

    but I guess amr support is still not included despite the free libraries now available?
    Yes and no...
    gstreamer now supports amr thru the ugly plugin, but due to the opencore libs being GPLv3 there's no ffmpeg support, and by extension no support for apps using ffmpeg libs.
    (even though 0.5.1 can support opencore, it can't atm (or ever..) be enabled in the ubuntu ffmpeg, though native amr in ffmpeg would probably be ok but it's not in 0.5.1


    ( the gst plugin is quite good - can be added to karmic by building or even better this ppa
    https://launchpad.net/~gstreamer-dev...s/+archive/ppa

  2. #922
    Join Date
    Jul 2007
    Beans
    13

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I get the following error when compiling
    ffmpeg:
    *
    libavcodec/pthread.c:136: error: no previous prototype for ?avcodec_thread_execute2?
    what do you suggest?

  3. #923
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Beans
    24
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Iv been trying to build on intrepid this morning and im getting the same error

    libavcodec/pthread.c:136: error: no previous prototype for 'avcodec_thread_execute2'
    make: *** [libavcodec/pthread.o] Error 1
    when i come to make ffmpeg aswell, i cant find anything on google about it hopefully someone here can help?
    Last edited by madmak; March 8th, 2010 at 01:01 PM.

  4. #924
    Join Date
    Feb 2010
    Location
    Kelantan, Malaysia
    Beans
    19

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yes, I using WinFF. If you know how, please taught one by one because I was beginner

  5. #925
    Join Date
    Jun 2008
    Location
    Glasgow, Scotland
    Beans
    24
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install and use the latest FFmpeg and x264

    i managed to get past the pthread error and build ffmpeg by using the snapshot of ffmpeg heres the link

    http://ffmpeg.mplayerhq.hu/releases/...apshot.tar.bz2

    im guessing it must be a temp problem with the svn version

  6. #926
    Join Date
    Dec 2009
    Beans
    Hidden!
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yep I am getting the libavcodec error1 as well on my Karmic x64. I tried upgrading today, hope its temporary.

    Update, its working now, just compiled it, must have been some error.
    Last edited by Linuxforall; March 8th, 2010 at 04:01 PM.
    The finding of unity in variety is really what we call knowledge..... Vivekananda.

  7. #927
    Join Date
    Jun 2007
    Beans
    16,778

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yes, I using WinFF
    Open up winff and go edit -> preferences -> linux
    You should edit the path for both ffmpeg and ffplay to where they are, if you used this guide exactly then make the paths - screen1
    /usr/local/bin/ffmpeg
    /usr/local/bin/ffplay

    or if you wish use the browse button on the right to select (filesystem -> usr -> local -> bin
    Attached Images Attached Images

  8. #928
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    "no previous prototype for 'avcodec_thread_execute2'" error fixed in svn.
    Freedom is neither exclusive nor unlimited.

  9. #929
    Join Date
    Dec 2005
    Location
    St. Petersburg, FL
    Beans
    550
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by mc4man View Post
    Yes and no...
    gstreamer now supports amr thru the ugly plugin, but due to the opencore libs being GPLv3 there's no ffmpeg support, and by extension no support for apps using ffmpeg libs.
    Could you explain this? There is that --enable-version3 parameter, and from http://ffmpeg.org/legal.html (emphasis mine), "FFmpeg is licensed under the GNU Lesser General Public License (LGPL) version 2.1 or later. However, FFmpeg incorporates several optional parts and optimizations that are covered by the GNU General Public License (GPL) version 2 or later. If those parts get used the GPL applies to all of FFmpeg.".

    From that it seems whether something is GPLv3 (or even GPLv2) doesn't matter. But as I mostly get confused by all the stipulations and directives within the GPL and LGPL, that's only what it looks like to me. I could be wrong.

  10. #930
    Join Date
    Jun 2007
    Beans
    16,778

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Could you explain this?
    Probably not too well, licensing stuff makes my head spin. My take on it is that the issue isn't ffmpeg per se but it's shared libraries and the packages that depend on it

    There are quite a number of bugs threads that you could read, this one may do the trick - skip down to post 47 or so (good luck ...

    https://bugs.launchpad.net/ubuntu/+s...yer/+bug/93849

Page 93 of 241 FirstFirst ... 43839192939495103143193 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •