Page 71 of 241 FirstFirst ... 2161697071727381121171 ... LastLast
Results 701 to 710 of 2402

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #701
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi Bachstelze,

    Had done exactly the same thing last night without the error occuring, the only difference being --disable-asm was not used tonight.


    Quote Originally Posted by n.hinton View Post

    Its OK removed libtheora_1.1.1-1 then x264 installed.

    Odd, first time I've encountered that, and have rebuilt and installed recently with libtheora_1.1.1-1 installed. Surely couldn't have anything to do with last previous build including x264 with ./configure --disable-asm, Could it ?

  2. #702
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by n.hinton View Post
    Hi Bachstelze,

    Had done exactly the same thing last night without the error occuring, the only difference being --disable-asm was not used tonight.
    Nope, doesn't have anything to do with it. The problem is in your libtheora package, since it installs files it obviously should not, not in your x264 one.
    「明後日の夕方には帰ってるからね。」


  3. #703

    Re: HOWTO: Install and use the latest FFmpeg and x264

    n.hinton -
    while i'm not inclined to try out is there any possibility that when you were building x264 at some point you used the the checkinstall command for libtheroa...?

    If you still have your libtheroa deb r. click on it -> open with archive manager and click thru to see what files are inside

  4. #704
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yes but have done approximately 7 or so rebuilds since libtheora package was installed, why has that error waited till now to occur?

  5. #705
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yes, checkinstall command for libtheroa is what FakeOutdoorsman says use in this HOWTO.

  6. #706
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi mc4man,

    Sorry for delay answering, didn't want to open package manager while ffmpeg was building.

    The attached screensot shows all listed included files at /usr/local/include/

    x264.h is not in the entire list.

    Whoops:

    Did that wrong didn't I, have just used archive manager as you said in post 703 and no x264.h there either.
    Attached Images Attached Images
    Last edited by n.hinton; November 30th, 2009 at 12:18 AM. Reason: whoops

  7. #707
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Got lastnights x264 command lines from bash_history:

    sudo apt-get remove ffmpeg x264 libx264-dev
    cd x264
    make distclean
    git pull
    ./configure --disable-asm
    make
    sudo checkinstall --pkgname=x264 --pkgversion "1:0.svn`date +%Y%m%d`" --backup=no --default
    cd

    Can't understand what went wrong, all seemed to work fine. But when ran sudo apt-get remove ffmpeg x264 libx264-dev tonight it said x264 was not installed.

  8. #708
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Have updated again and everything is as it should be, mystery to me what went wrong.

    PS the presets issue, was a red herring, being caused by not building x264 with ./configure --disable-asm, required for my CPU, all winff presets now work perfectly.

  9. #709
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by mocha View Post
    the hq preset file should be in your ~/.ffmpeg directory.
    If I remember correctly, when the libx264 presets were first introduced they were installed in ~/.ffmpeg, but the current installation directory is /usr/share/ffmpeg. I think ~/.ffmpeg takes priority, so if you have outdated presets in there they may cause issues.


    Quote Originally Posted by n.hinton View Post
    Thanks FakeOutdoorsman,

    The SSE thing was bugging me. Please see attached presets.tar.gz, I hope that format of archive is acceptable.

    PS
    FakeOutdoorsman, your remarkably diplomatic with me (I don't think I'd have your patience)
    Now you're going to have to be patient with me because I'm not going to be able to take a look at your presets until later in the week.

  10. #710
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,721
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Anyway to rig this homecooked ffmpeg compiled version into Handbrake? Ive got the handbrake sources, however I think the handbrake configure script goes ahead and downloads ffmpeg.

Page 71 of 241 FirstFirst ... 2161697071727381121171 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •