Page 36 of 241 FirstFirst ... 2634353637384686136 ... LastLast
Results 351 to 360 of 2402

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #351
    Join Date
    Sep 2008
    Location
    Cancun
    Beans
    6
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Yay! This is still up and running good I have a nice Ubuntu 64 installed on my new c2d machine and I will need to compile ffmpeg on it. Good work and thx!

  2. #352
    Join Date
    Jul 2008
    Beans
    130

    Re: HOWTO: Install and use the latest FFmpeg and x264

    anyone notice that like -artist and -title options are now gone from SVN? Anyone know if that is a bug or if it is supposed to be coming back?

    -HR

  3. #353
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by HolyRoses View Post
    anyone notice that like -artist and -title options are now gone from SVN? Anyone know if that is a bug or if it is supposed to be coming back?

    -HR
    Looks like there is a new metadata API and the old one has been depreciated:
    Code:
    $ ffmpeg -h | grep metadata
    -metadata string=string  add metadata

  4. #354
    Join Date
    Jul 2008
    Beans
    130

    Re: HOWTO: Install and use the latest FFmpeg and x264

    hmmmm, fun.

    Got a list of accepted metadata? Wonder if you can do iPod tagging with it now.

  5. #355
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by HolyRoses View Post
    hmmmm, fun.

    Got a list of accepted metadata? Wonder if you can do iPod tagging with it now.
    I'm not sure what is accepted with the new API. I never used the old metadata API. I use AtomicParsley to add iTunes style tags for iPod.

  6. #356
    Join Date
    Mar 2009
    Beans
    2

    Re: HOWTO: Install and use the latest FFmpeg and x264

    hi @ all ...

    thank' s a lot for thise fine how-to.
    but i' ve a problem. i wanna install the Xine-Lib 1.2 CVS with VDPAU Patch, but i get a error in "make" ...
    Code:
    ../../contrib/libxdg-basedir/.libs/libxdg-basedir.a -Wl,--no-whole-archive  -ldl -lz -lm -lrt -lresolv -lnsl -L/usr/local/lib -lavutil  -Wl,--gc-sections -pthread   -pthread -Wl,-soname -Wl,libxine.so.2 -o .libs/libxine.so.2.0.0
    /usr/bin/ld: /usr/local/lib/libavutil.a(base64.o): relocation R_X86_64_32S against `a local symbol' can not be used when making a shared object; recompile with -fPIC
    /usr/local/lib/libavutil.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make[2]: *** [libxine.la] Fehler 1
    make[2]: Verlasse Verzeichnis '/home/smiley/ffmpeg/xine-lib-1.2/src/xine-engine'
    make[1]: *** [../src/xine-engine/libxine.la] Fehler 2
    make[1]: Verlasse Verzeichnis '/home/smiley/ffmpeg/xine-lib-1.2/misc'
    make: *** [all-recursive] Fehler 1
    smiley@pc-1:~/ffmpeg/xine-lib-1.2$
    "Fehler" means ERROR

    anyone some ideas, what i can do?

    further ... before i begun to install xine-lib-1.2 i' ve installed succesfully ffmpeg.

    hope somebody can help me. .... thank' s ... smiley

  7. #357
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by smiley_27 View Post
    hi @ all ...

    thank' s a lot for thise fine how-to.
    but i' ve a problem. i wanna install the Xine-Lib 1.2 CVS with VDPAU Patch, but i get a error in "make" ...
    Code:
    ../../contrib/libxdg-basedir/.libs/libxdg-basedir.a -Wl,--no-whole-archive  -ldl -lz -lm -lrt -lresolv -lnsl -L/usr/local/lib -lavutil  -Wl,--gc-sections -pthread   -pthread -Wl,-soname -Wl,libxine.so.2 -o .libs/libxine.so.2.0.0
    /usr/bin/ld: /usr/local/lib/libavutil.a(base64.o): relocation R_X86_64_32S against `a local symbol' can not be used when making a shared object; recompile with -fPIC
    /usr/local/lib/libavutil.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make[2]: *** [libxine.la] Fehler 1
    make[2]: Verlasse Verzeichnis '/home/smiley/ffmpeg/xine-lib-1.2/src/xine-engine'
    make[1]: *** [../src/xine-engine/libxine.la] Fehler 2
    make[1]: Verlasse Verzeichnis '/home/smiley/ffmpeg/xine-lib-1.2/misc'
    make: *** [all-recursive] Fehler 1
    smiley@pc-1:~/ffmpeg/xine-lib-1.2$
    "Fehler" means ERROR

    anyone some ideas, what i can do?

    further ... before i begun to install xine-lib-1.2 i' ve installed succesfully ffmpeg.

    hope somebody can help me. .... thank' s ... smiley
    I wish I could help you, but I know nothing of Xine or VDPAU. Hopefully someone with some experience in these areas will be able to help.

  8. #358
    Join Date
    Dec 2006
    Beans
    7,317

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi,

    I have a small suggest that may have a place in your guide. I recently installed Hardy Heron again, using VirtualBox, and installed the svn MPlayer / x264 + yasm. I used checkinstall for yasm and in a step that may not be totally necessary I used:

    Code:
    --pkgversion "0.7.2"
    which was designed to defeat the repository version of 0.5.xxxxx in Hardy. I did not test if an unlabelled yasm 0.7.2 would necessarily be overwritten by the older repository version though.

    Good to see that moth-eaten heron on my desktop again though .

    Andrew

  9. #359
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by andrew.46 View Post
    Hi,

    I have a small suggest that may have a place in your guide. I recently installed Hardy Heron again, using VirtualBox, and installed the svn MPlayer / x264 + yasm. I used checkinstall for yasm and in a step that may not be totally necessary I used:

    Code:
    --pkgversion "0.7.2"
    which was designed to defeat the repository version of 0.5.xxxxx in Hardy. I did not test if an unlabelled yasm 0.7.2 would necessarily be overwritten by the older repository version though.

    Good to see that moth-eaten heron on my desktop again though .

    Andrew
    Hi Andrew,

    I don't remember the compiled yasm being replaced by repository yasm in my tests, but it's been a while now. I added "pkgversion" anyway because it's nice to see what version it is in the package manager.

    I'm working on the Jaunty FFmpeg guide now. It seems as if "--fstrans=no" and "--install=yes" are no longer required in checkinstall for Jaunty. So far that seems to be the only difference between the two Ubuntu releases. I'll probably just leave these options to have one guide for both, but what do you think?

  10. #360
    Join Date
    Sep 2006
    Beans
    3,713

    Install FFmpeg and x264 on Ubuntu Hardy Heron 8.04 LTS

    This guide has moved to the official FFmpeg wiki:

    How to Compile FFmpeg and x264 on Ubuntu Hardy Heron 8.04
    Last edited by FakeOutdoorsman; May 16th, 2012 at 12:37 AM.

Page 36 of 241 FirstFirst ... 2634353637384686136 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •