Page 139 of 241 FirstFirst ... 3989129137138139140141149189239 ... LastLast
Results 1,381 to 1,390 of 2402

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #1381
    Join Date
    Sep 2008
    Beans
    76

    Re: Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    Hi. When I run make i'm getting this error.

    Code:
    make: *** No rule to make target `libavcodec/x86/dsputil_h264_template_mmx.c', needed by `libavcodec/x86/dsputil_mmx.o'.  Stop.
    Any ideas?

  2. #1382
    Join Date
    Sep 2006
    Beans
    3,713

    Re: Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    I can't duplicate this error and everything compiled without issue for me on Ubuntu 10.10 64-bit. I need more information:

    • What Ubuntu version are you using?
    • Are you installing FFmpeg from a clean source, or are you attempting to upgrade a previous compiled FFmpeg?
    • Did you follow the guide word-for-word, or did you modify anything?
    • Do you know what FFmpeg revision you were attempting to compile?


    You can find out the revision of your source with:
    Code:
    cd ~/ffmpeg
    LANG=C svn info | grep Revision | awk '{ print $NF }'

  3. #1383
    Join Date
    Jun 2005
    Beans
    23

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I recently had problems converting flv files after following these instructions. If you have any troubles when using the --enable-shared options, try running `sudo ldconfig` which will make sure the proper libraries get loaded.

  4. #1384
    Join Date
    Aug 2007
    Beans
    15

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks for the guide. When I run:

    Code:
    sudo checkinstall --pkgname=qt-faststart --pkgversion "4:SVN-r`LANG=C svn info | \
        grep Revision | awk '{ print $NF }'`" --backup=no --deldoc=yes --fstrans=no \ 
        --default install -D -m755 tools/qt-faststart /usr/local/bin/qt-faststart
    I got the following error:

    Code:
    Installing with  ...
    
    ========================= Installation results ===========================
    /var/tmp/tmp.FJOuykVcii/installscript.sh: 4:  : not found
    
    ****  Installation failed. Aborting package creation.
    
    Cleaning up...OK
    Any idea what's going wrong?

    Bye.

  5. #1385
    Join Date
    Jun 2007
    Beans
    16,421

    Re: HOWTO: Install and use the latest FFmpeg and x264

    I got the following error: .....
    Try it like this, it appears the code box in post one has an errant space

    Code:
    sudo checkinstall --pkgname=qt-faststart --pkgversion "4:SVN-r`LANG=C svn info | \
        grep Revision | awk '{ print $NF }'`" --backup=no --deldoc=yes --fstrans=no \
    --default install -D -m755 tools/qt-faststart /usr/local/bin/qt-faststart
    (otherwise you don't particularly need to 'install' qt-faststart, make executable and place in a bin in path (~/bin would be fine

  6. #1386
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by mc4man View Post
    Try it like this, it appears the code box in post one has an errant space
    Thanks for noticing. Command updated.

  7. #1387
    Join Date
    Aug 2009
    Location
    Beachside, Florida
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by FakeOutdoorsman View Post
    Thanks for noticing. Command updated.
    Thanks! I was able to get faststart installed without errors!
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Creating a Custom Maintenance Free GRUB2 Screen on Arch Linux
    Intel Core2 Quad Q9550 2.84 GHz, NVIDIA GeForce 9800 GT, Mobo: MSI model: G31M3-L V2(MS-7529)

  8. #1388
    Join Date
    Nov 2010
    Beans
    2

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Hi FakeOutdoorsman.
    I have almost completed the installation of ffmpeg and x264 following your instruction for Ubuntu 10.04, as my machine is running Ubuntu 10.04.1.
    However, in the final stage of installing ffmpeg, the command line "hash x264 ffmpeg ffplay" failed, since "hash" command is not installed in my ubuntu. I double checked with "which hash" and "whereis hash". This hash process is not vital, I believe. But problem is ffmpeg is not installed. "whereis ffmpeg" returns nothing. The rest of the products, lame qt-faststart vpxdec vpxenc x264 have been installed in /usr/local/bin.

    ------------- the process I followed for ffmpeg ------------------
    svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
    cd ffmpeg
    ./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc \
    --enable-libfaac --enable-libopencore-amrnb --enable-libopencore-amrwb \
    --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid \
    --enable-x11grab
    make
    sudo checkinstall --pkgname=ffmpeg --pkgversion "4:SVN-r`LANG=C svn info | \
    grep Revision | awk '{ print $NF }'`" --backup=no --default --deldoc=yes
    hash x264 ffmpeg ffplay
    --------------------------------------------------------------------

    Should I execute "make install" in the ffmpeg source directory?
    I wonder I have done something strange, as no one seems to have this problem.
    Also how can I get "hash" command for Ubuntu? Do you have any idea why my Ubuntu does not have one? I am running the default shell, which is I think bash.
    Thank you for your detailed guide.

  9. #1389
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Sorry for the late reply. I was out of town for a week with no computer access.

    Quote Originally Posted by powersaver View Post
    However, in the final stage of installing ffmpeg, the command line "hash x264 ffmpeg ffplay" failed, since "hash" command is not installed in my ubuntu. I double checked with "which hash" and "whereis hash". This hash process is not vital, I believe.
    hash shouldn't require any additional tasks by the user to enable it because it is included in the bash shell, and by default, Ubuntu should be using the bash shell. Can you make sure you're using bash?
    Code:
    $ echo $SHELL
    /bin/bash
    Quote Originally Posted by powersaver View Post
    But problem is ffmpeg is not installed. "whereis ffmpeg" returns nothing. The rest of the products, lame qt-faststart vpxdec vpxenc x264 have been installed in /usr/local/bin.
    Did you encounter any errors or useful messages during installation?

  10. #1390
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Here's a handy tip - if you haven't followed this howto and just have good old ordinary ffmpeg, and need to extract 5.1 (6) channel AAC audio to 2 channel audio from an mkv file. Most howtos about doing this expect compilation from source!

    Install faad from the repositories

    Identify the track number of the audio you want:

    Code:
    mkvmerge -i input.mkv
    (in this case "2")

    then extract the audio using mkvextract:

    Code:
    mkvextract tracks input.mkv 2:input.aac (was ac3)
    then run it on the aac (was ac3) file as follows:

    Code:
    faad -d -o output.wav input.aac (was ac3)
    You can now encode the resultant wav file to you desired format, and then stick it back into the mkv if you want: e.g.
    Code:
    mkvmerge -o output.mkv input.mkv stereo.mp3
    Last edited by Jose Catre-Vandis; December 13th, 2010 at 02:54 PM. Reason: In recognition of the two following posts about ac3/aac - point is, it works regardless of the audio file extension
    No longer participating......

Page 139 of 241 FirstFirst ... 3989129137138139140141149189239 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •