Page 219 of 241 FirstFirst ... 119169209217218219220221229 ... LastLast
Results 2,181 to 2,190 of 2402

Thread: HOWTO: Install and use the latest FFmpeg and x264

  1. #2181

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Quote Originally Posted by ron999 View Post
    Hi mc4man

    I've done some experiments.
    It seems that now with Pangolin...

    Code:
    IF x264 is not installed
        THEN MEncoder is happy to build with libx264-dev
            ELSE
                IF x264 is installed
                    THEN MEncoder won't build with libx264-dev
    Maybe it's possible to force the compiler to ignore a static x264 and allow MEncoder to build with libx264-dev.
    In the meantime, I've compiled x264 'shared' and removed libx264-dev.
    Any which way you go should be ok. As far as using the x264 build as typical to this how-to for a mplayer/mencoder build with gcc > 4.4 -
    If you add this to your mplayer configure then should go ok w/ the static only x264 -

    Code:
    --extra-libs-mencoder=-lx264
    Though as mentioned see no real reason against building x264 as shared

  2. #2182
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Thanks mc4man but "--extra-libs-mencoder=-lx264" has not solved the issue.

    When x264 static is installed the MPlayer config message still shows:-
    Code:
    Checking for x264 ... no (in FFmpeg: no)
    Last edited by ron999; May 15th, 2012 at 03:00 PM.

  3. #2183

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Ron - you're right - I was on a 12.10 install but then switched to 12.04 & forgot that I'd installed x264 as shared yesterday to ck.

    (There are a couple of people frequenting the compiling forum that know the gcc changes fairly well if you are curious to pursue

  4. #2184
    Join Date
    Mar 2012
    Beans
    21

    Re: HOWTO: Install and use the latest FFmpeg and x264

    can anyone tell me the difference between make and make fprofiled ?
    +what is the advantage from --enable-win32thread ? (i know it is for windows)
    thanx

  5. #2185
    Join Date
    Jan 2008
    Beans
    26

    Re: HOWTO: Install and use the latest FFmpeg and x264

    Where is the usage part of this guide? Need to look up something on audio offsets.

  6. #2186
    Join Date
    Sep 2006
    Beans
    3,713

    Re: HOWTO: Install and use the latest FFmpeg and x264

    There was a small usage section of the guide but I removed it. It didn't address audio offsets though. I do plan on adding a new usage section, but it's low priority right now. So for now just consider this thread an interactive usage section or refer to "ffmpeg -h" or "man ffmpeg".

  7. #2187
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: HOWTO: Install and use the latest FFmpeg and x264

    +1 for a usage guide, with all the changes to syntax recently I have got lost
    No longer participating......

  8. #2188
    Join Date
    Mar 2006
    Beans
    1,107

    Re: Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    It appears that this file may have been moved:

    Code:
    :~$ git clone --depth 1 http://git.chromium.org/webm/libvpx.git
    Initialized empty Git repository in /opt/ffmpeg/libvpx/.git/
    error: The requested URL returned error: 501 while accessing http://git.chromium.org/webm/libvpx.git/info/refs
    
    fatal: HTTP request failed
    Linux Hardware Boycott!
    How Many People Have you Converted To Linux?
    HD-DVD code:I cant tell you because I got an infraction for posting it here.

  9. #2189
    Join Date
    Mar 2006
    Beans
    Hidden!

    Re: Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    Quote Originally Posted by cantormath View Post
    It appears that this file may have been moved:

    Code:
    :~$ git clone --depth 1 http://git.chromium.org/webm/libvpx.git
    Initialized empty Git repository in /opt/ffmpeg/libvpx/.git/
    error: The requested URL returned error: 501 while accessing http://git.chromium.org/webm/libvpx.git/info/refs
    
    fatal: HTTP request failed
    You seem to have snuck a "--depth 1" in there - not in the tut ?

    Code:
    git clone http://git.chromium.org/webm/libvpx.git
    No longer participating......

  10. #2190
    Join Date
    Sep 2006
    Beans
    3,713

    Re: Install FFmpeg and x264 on Ubuntu Lucid Lynx 10.04

    Works for me:

    Code:
    $ git clone --depth 1 http://git.chromium.org/webm/libvpx.git
    Cloning into 'libvpx'...
    remote: Counting objects: 5011, done.
    remote: Compressing objects: 100% (2386/2386), done.
    remote: Total 5011 (delta 3626), reused 3710 (delta 2501)
    Receiving objects: 100% (5011/5011), 3.89 MiB | 355 KiB/s, done.
    Resolving deltas: 100% (3626/3626), done.
    Perhaps it is a temporary error with the server? What Ubuntu version are you using? The libvpx site shows the same repository address.

Page 219 of 241 FirstFirst ... 119169209217218219220221229 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •