Page 1 of 8 123 ... LastLast
Results 1 to 10 of 77

Thread: weather screenlet not working

  1. #1
    Join Date
    Nov 2007
    Beans
    6
    Distro
    Ubuntu 8.10 Intrepid Ibex

    weather screenlet not working

    My weather screenlets aren't working this morning. No matter which weather screenlet I try to run, they are unable to connect to weather.com. I can connect to weather.com with my browser, and my weather widgets are working when I boot into windows. Is anyone else having trouble?

  2. #2
    Join Date
    Apr 2007
    Location
    Antioch, IL
    Beans
    43
    Distro
    Ubuntu Development Release

    Re: weather screenlet not working

    Nothing works for me either!

  3. #3
    Join Date
    Jan 2008
    Location
    Colorado
    Beans
    45
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: weather screenlet not working

    yup, same here. I guess either weather.com's XML feed is dead or one of the updates intalled in the last day broke the desklet.

    (I'm running Hardy and using the hardy-proposed repositories)

  4. #4
    Join Date
    Apr 2008
    Location
    Pennsylvania
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: weather screenlet not working

    Looking at the WeatherScreenlet.py file, the URL it's trying to load is "http://xoap.weather.com/weather/local/17068?cc=*&dayf=10&prod=xoap&par=1003666583&key=41 28909340a9b2fc&unit=s&hbhf=12" If I go to that URL, I get
    "<?xml version="1.0" encoding="ISO-8859-1"?>
    <error>
    <err type="8">Bad or missing query parameters in request.</err>
    </error>"

    Looks like either updates broke the screenlets or weather.com has changed required parameters.

  5. #5
    Join Date
    Apr 2008
    Location
    Pennsylvania
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: weather screenlet not working

    OK, figured it out ... you need to edit the weatherscreenlet.py file and add "&link=xoap" to the xoap.weather.com URL. Looks like there's a new required parameter on Weather.com's xoap interface. So, The above URL becomes ""http://xoap.weather.com/weather/local/17068?cc=*&dayf=10&prod=xoap&link=xoap&par=1003666583&key=41 28909340a9b2fc&unit=s&hbhf=12"

  6. #6
    Join Date
    Oct 2007
    Location
    Dark side of the moon
    Beans
    144
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: weather screenlet not working

    That fix did nothing on my weather screenlet. Did it work to anybody here?

  7. #7
    Join Date
    Nov 2007
    Beans
    6
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: weather screenlet not working

    That worked for me! I had to reboot after editing the file. Thanks, Mullens!

  8. #8
    Join Date
    Apr 2005
    Location
    C A N A DA
    Beans
    268
    Distro
    Ubuntu

    Re: weather screenlet not working

    I received an email from weather.com stating they were updating their code for feeds. Stuff will break if they aren't updated.
    Running: Ubuntu 10.10 & Windows 7 Pro
    Registered Linux User #373810
    Become a Registered Linux User Here.

  9. #9
    Join Date
    Apr 2007
    Location
    Antioch, IL
    Beans
    43
    Distro
    Ubuntu Development Release

    Re: weather screenlet not working

    I added the parameter and it works. my problem was actually with the AWN Weather applet. The fix works for both.
    The parameter you need to add is:

    xoap&link=

    Just insert it after prod=

  10. #10
    Join Date
    Jan 2008
    Location
    New York
    Beans
    154
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: weather screenlet not working

    You made a little mistake when marking what had to be added... The URL should look like this...

    Code:
    http://xoap.weather.com/weather/local/17068?cc=*&dayf=10&prod=xoap&link=xoap&par=1003666583&key=41 28909340a9b2fc&unit=s&hbhf=12
    Thanks!!
    Last edited by Grone1985; May 6th, 2008 at 08:28 PM.

Page 1 of 8 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •