Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: HOWTO fix rt2500 in Hardy (bug #190515)

  1. #1
    Join Date
    May 2008
    Beans
    5

    HOWTO fix rt2500 in Hardy using serialmonkey drivers (bug #190515)

    I installed Ubuntu 8.04 and the wireless connection was working but extremely slow.
    After a lot of time looking for information and solving problems (including the deactivation of IPv6) I ended up in the bug #190515

    I succeeded in installing working drivers and I have again fast internet.

    Thanks a lot mainly to SirYes for his answers, it was the basis for this solution and most of the text below is coming from him.

    I would suggest you to do a local copy of this procedure (and the links content at the very end), so in case you dont have internet it'll be still fixable

    Here's the procedure I followed to make it work:

    0. Open a console and enter in root mode:
    Code:
    sudo -i
    [enter your password if requested]

    1. Install build-essential package
    Code:
    apt-get install build-essential
    apt-get install linux-headers
    apt-get install module-assistant
    run module assistant:
    Code:
    module-assistant
    select "Configure the system to compile modules" and press ok

    NOTE: I think installing module-assistant and selectig the option "Configure the system to compile modules" all the previous steps are done as well, but its just what I did...

    2. Go and download the "Last beta release" of the rt2500 (PCI/PCMCIA) from serialmonkey
    UPDATE: Is better installing the lastest CVS version of the serialmonkey drivers, instead of the latest beta version. For some people the beta version is not compiling, I don't know why.
    The last version is the serialmonkey download section, under CVS hourly tarball: rt2500-CVS

    Remember to save the file in your home directory! (see step 3.2)

    3.
    3.1. Create a temporary working dir:
    Code:
    mkdir /root/source
    cd /root/source
    3.2. Unpack the downloaded source code (I will assume here that the file
    is named rt2500-1.1.0-b4.tar.gz and is placed in your home directory):
    Code:
    tar xvzf /home/yourlogin/rt2500-1.1.0-b4.tar.gz
    4. This step has to be done only once: open the following file in editor:
    4.1.
    Code:
    gedit /etc/modprobe.d/blacklist
    4.2. At the end of this file add the following lines, then save the file:
    Code:
    blacklist rt2x00lib
    blacklist rt2x00pci
    blacklist rt2500pci
    5. The following steps are required every time new kernel is installed, because
    the driver (module in Linux terminology) will be available only for kernels
    against which it would be compiled:
    5.1.
    Code:
    cd /root/source/rt2500-1.1.0-b4/Module
    5.2.
    Code:
    make clean ; make ; make install
    5.3. Make the kernel use your preferred modules:
    Code:
    dpkg-reconfigure usplash
    (usplash here is another story, but the above command generates initial
    ramdisk used at boot time, and puts all modules in it - as required)

    5.4. Reboot your system so the old modules will not be used, but
    instead only the freshly compiled rt2500 module.

    6.A If the Network Monitor is not working, you'll have to configure the
    connection manually.
    Open the System > Administration > Network or left-click on the
    Network Manager icon and select 'Manual configuration'.
    Unlock the configuration window using your password.
    Open the properties window of your wireless network interface.
    First disable the roaming mode. Then provide all the details you need,
    typically it's enough to select 'Automatic configuration (DHCP)', type
    in the ESSID and a key.
    Close the properties window and make sure the connection box is
    'checked', so it's automatically started upon system boot.

    6.B If your connection still doesn't work, you can also edit relevant file manually:

    6.B.0 edit the interfaces file
    Code:
    sudo gedit /etc/network/interfaces
    6.B.1 Append these lines:
    Code:
    auto ra0
     
    iface ra0 inet dhcp
    pre-up ifconfig ra0 up
    pre-up ifconfig ra0 down
    pre-up ifconfig ra0 up
    pre-up ifconfig ra0 down
    pre-up iwconfig ra0 essid "******"
    pre-up iwconfig ra0 mode Managed
    pre-up iwpriv ra0 set AuthMode=WPAPSK
    pre-up iwpriv ra0 set EncrypType=TKIP
    pre-up iwpriv ra0 set WPAPSK="*********"
    pre-up ifconfig ra0 up
    6.2 Substitue the ***** by your ESSID and Pre Shared Key

    6.3 save

    6.4. Restart the networking service and hope for the best. This has

    the additional benefit that you'll be able to watch exact progress and
    see what happens:
    Code:
    sudo /etc/init.d/networking restart
    Should something go wrong and you didn't have even the flaky and slow
    old net connection, remove the lines you added in
    /etc/modprobe.d/blacklist at step 4.2, regenerate initrd using the command
    from step 5.3 and reboot.


    Remember (now here's the catch) to repeat all steps from point 5 after
    your Ubuntu upgrades its kernel. Otherwise the new kernel will not use
    the blacklisted modules *AND* will not contain the compiled rt2500
    module as well. You can guess what would be the result



    More information:

    compile the latest drivers and edit the /etc/network/interfaces
    https://help.ubuntu.com/community/Wi...r/RalinkRT2500

    edit the /etc/network/interfaces
    http://ubuntuforums.org/showthread.php?t=241565
    Last edited by aykito; May 14th, 2008 at 10:08 AM. Reason: Improving the written procedure

  2. #2
    Join Date
    Jun 2006
    Beans
    1

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    I followed your instructions closely, but I got this:

    Code:
    root@sushi:~/source/rt2500-1.1.0-b4/Module# make clean ; make ; make install
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
      CC [M]  /root/source/rt2500-1.1.0-b4/Module/rtmp_main.o
    In file included from /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:50:
    /root/source/rt2500-1.1.0-b4/Module/rt_config.h:58:40: error: linux/config.h: No such file or directory
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_probe’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:203: error: implicit declaration of function ‘SET_MODULE_OWNER’
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_open’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: ‘SA_SHIRQ’ undeclared (first use in this function)
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: (Each undeclared identifier is reported only once
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: for each function it appears in.)
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘rt2500_init_module’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:1009: error: implicit declaration of function ‘pci_module_init’
    make[2]: *** [/root/source/rt2500-1.1.0-b4/Module/rtmp_main.o] Error 1
    make[1]: *** [_module_/root/source/rt2500-1.1.0-b4/Module] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
    rt2500.ko failed to build!
    make: *** [module] Error 1
    echo "2.6 module install"
    2.6 module install
    make -C /lib/modules/2.6.24-16-generic/build SUBDIRS=/root/source/rt2500-1.1.0-b4/Module  modules_install
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
      DEPMOD  2.6.24-16-generic
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
    /sbin/depmod -a
    grep: /etc/modprobe.conf: No such file or directory
    append 'alias ra0 rt2500' to /etc/modprobe.conf
    Edit 1: Note that even after symlinking config.h to autoconf.h, errors exist.

    Edit 2: Current CVS tarball works, stay tuned for results after reboot.
    Last edited by samadhi; May 8th, 2008 at 09:54 PM. Reason: Infos

  3. #3
    Join Date
    May 2008
    Beans
    1

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    Quote Originally Posted by samadhi View Post
    I followed your instructions closely, but I got this:

    Code:
    root@sushi:~/source/rt2500-1.1.0-b4/Module# make clean ; make ; make install
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
      CC [M]  /root/source/rt2500-1.1.0-b4/Module/rtmp_main.o
    In file included from /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:50:
    /root/source/rt2500-1.1.0-b4/Module/rt_config.h:58:40: error: linux/config.h: No such file or directory
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_probe’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:203: error: implicit declaration of function ‘SET_MODULE_OWNER’
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘RT2500_open’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: ‘SA_SHIRQ’ undeclared (first use in this function)
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: (Each undeclared identifier is reported only once
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: error: for each function it appears in.)
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:343: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c: In function ‘rt2500_init_module’:
    /root/source/rt2500-1.1.0-b4/Module/rtmp_main.c:1009: error: implicit declaration of function ‘pci_module_init’
    make[2]: *** [/root/source/rt2500-1.1.0-b4/Module/rtmp_main.o] Error 1
    make[1]: *** [_module_/root/source/rt2500-1.1.0-b4/Module] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
    rt2500.ko failed to build!
    make: *** [module] Error 1
    echo "2.6 module install"
    2.6 module install
    make -C /lib/modules/2.6.24-16-generic/build SUBDIRS=/root/source/rt2500-1.1.0-b4/Module  modules_install
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
      DEPMOD  2.6.24-16-generic
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
    /sbin/depmod -a
    grep: /etc/modprobe.conf: No such file or directory
    append 'alias ra0 rt2500' to /etc/modprobe.conf
    Edit 1: Note that even after symlinking config.h to autoconf.h, errors exist.

    Edit 2: Current CVS tarball works, stay tuned for results after reboot.
    I have the same error, and am having trouble making the CVS tarball to work, when i try to 'make clean ; make ; make install' (for the CVS tarball) it says 'no rule to make target". Help?

  4. #4
    Join Date
    May 2008
    Beans
    5

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    Hi, I would try the lastest CVS version of the serialmonkey drivers, instead of the latest beta version. For some people the beta version is not compiling, I don't know why.

    The last version is the serialmonkey download section, under CVS hourly tarball: rt2500-CVS

    The problems with the headers is in theory solved:
    - installing the build-essential and module-assistant packages
    - executing the module-assistant application (running "Configure the system to compile modules" from the GUI)
    ... as described in the procedure, but I know some people had anyway that problem, trying to compile the last beta relase.

    Conclussion: try the CVS hourly tarball. If somehow the last CVS version is broken, I can send you the gz I used for me.

    Greetings!

  5. #5
    Join Date
    Sep 2005
    Location
    Pinehurst, NC
    Beans
    19

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    The beta version of the serialmonkey drivers more than likely only compile against the latest kernel release. The beta version is IVD's development tree. This version uses the kernel's cfg80211 and mac80211 modules which are still developing and their headers and API change from release to release. By kernel .26 release hopefully they will be stable.

    The daily cvs version is the original ralink code updated with bug fixes. It should compile against any kernel as it is a self contained driver. While it functions well it does not work with network manager so manual configuration is a must.

    In 8.04 with the stock driver I just do 'sudo iwconfig wlan0 rate 11M' in a terminal after a boot and this sets the uplink rate at 11M instead of the 1M that is set by default. For some setting it to 54M worked. A speed test on my machine show the same performance using this technique as using the legacy drivers.

  6. #6
    Join Date
    Jul 2007
    Location
    Upstate NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Wink Re: HOWTO fix rt2500 in Hardy (bug #190515)

    Hi All,

    I had the same issue and eventually loaded up the SerialMonkey Drivers. During this I had been adding/making changes to my sysctl.conf and rc.local file. I was able to get a faster throughput but not what I was seeing in Windows. THEN I ran into a problem while loading/compiling some software to the point where I had to reload my system but I made backups of my sysctl.conf and rc.local file. After reloading Ubuntu I installed my backup files and VIOLA, my Internet Speed was the same as how it was under Windows. I will post the contents of my files tonight.

  7. #7
    Join Date
    May 2008
    Beans
    5

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    Well I have to say I was very disappointed with Ubuntu because of this WLAN isue (and some other I had to address).
    Nevertheless once it is solved, I have to admit (after 4 years running windows in the same hardware) it has NEVER been so fast and stable as now, with Ubuntu and the serialmonkey drivers.
    I did a internet speed test right after the problem was fixed and it was the first time I had slighly more speed than the contracted (6000 mbps) with my ISP.

  8. #8
    Join Date
    Jul 2007
    Location
    Upstate NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    I have the dreaded rt2500 card WMP54G.

    After a fresh install I applied these files only and got the Internet Speed out of my system I was used to seeing with Windows.

    Paste applicable contents from each file.

    My additions to the sysctl.conf

    To open for editing "sudo gedit /etc/sysctl.conf"

    #increase TCP maximum buffer size
    net.core.rmem_max = 16777216
    net.core.wmem_max = 16777216

    # increase linux autotuning TCP buffer limits
    net.ipv4.tcp_rmem = 4096 87380 16777216
    net.ipv4.tcp_wmem = 4096 65536 16777216

    # don't cache ssthresh from previous connection
    net.ipv4.tcp_no_metrics_save = 1

    # recommended to increase this for 1000 BT or higher
    net.core.netdev_max_backlog = 2500
    net.ipv4.tcp_timestamps=0
    net.ipv4.tcp_moderate_rcvbuf=0
    net.ipv4.tcp_window_scaling=0

    to apply immediately after editing "sudo sysctl -p"

    Good source of info here. http://www-didc.lbl.gov/TCP-tuning/TCP-tuning.html


    Nice Info here.......http://www.extremetech.com/article2/...2114124,00.asp

    Info on sysctl.conf parameters..http://frankmash.blogspot.com/2005/1...imization.html

    check your parameters by dumping the sysctl info to a file.
    sudo sysctl -A > ~/Desktop/sysctl_settings

    rc.local has some redundancy to syctl.conf

    paste before the exit 0 at the bottom

    /sbin/iwconfig wlan0 rate 11M

    echo 256960 > /proc/sys/net/core/rmem_default
    echo 256960 > /proc/sys/net/core/rmem_max
    echo 256960 > /proc/sys/net/core/wmem_default
    echo 256960 > /proc/sys/net/core/wmem_max

    echo 0 > /proc/sys/net/ipv4/tcp_timestamps
    echo 1 > /proc/sys/net/ipv4/tcp_sack
    echo 1 > /proc/sys/net/ipv4/tcp_window_scaling

    "11M" worked fine for my connection. Play with that rate till you find your sweet spot (because not every place has the same basic speed nor does everyone pay for more speed like Business Class)

    Most people say make a backup of the original but I say make a backup of your edited file as well!

    SIN

  9. #9
    Join Date
    May 2007
    Location
    Melbourne, Australia
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO fix rt2500 in Hardy (bug #190515)

    Thanks aykito. I have the rt2500 chip set and the card was broken when i upgraded to Hardy. I followed your instructions step 1 to 5.4. Problem solved

    Cheers!

  10. #10
    Join Date
    May 2005
    Beans
    214
    Distro
    Ubuntu

    Re: HOWTO fix rt2500 in Hardy using serialmonkey drivers (bug #190515)

    My network speed is back to normal now.

    Thank you!

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •