Results 1 to 10 of 13

Thread: [SOLVED] No sound from headphone in Hardy?

Threaded View

  1. #1
    Join Date
    Sep 2007

    [SOLVED] No sound from headphone in Hardy?

    Hey everyone!

    I have a Toshiba Satellite P105 S9337 and have just fresh installed Xubuntu 8.04 on it.
    I was really excited to realize that 8.04 improved so much compared to 7.10! Back under Ubuntu 7.10, I have to compile my own kernel to fix problems caused by bad DSDT info, such as GPU is too hot, no sound, can not be suspended, etc. But under Xubuntu 8.04, boom, everything just works out of box! GPU stays cool with nvidia-glx-new, sound is OK, suspend works great...

    Till now, everything is just OK except one thing, no sound after I plug in my headphone.
    I also have a Vista installed on the laptop. Under Vista, when I plug in my headphone, the internal speaker is muted and sounds get emitted from the headphone, which is as anyone would expect. But under Xubuntu 8.04, when I plug in the same headphone, the internal speaker get muted as expected, but there is no sound coming out from the headphone neither. The same laptop, the same headphone, used to be OK under both 7.04 (with custom DSDT file) and 7.10 (with custom compile kernel). Isn't it strange?
    PS. I've tried different headphones and I don't think it is the headphone's problem.

    After times of trying, I found there IS *some* sound coming out from the headphone. When I plug in the headphone, I have to carefully pull it out a little bit, and if I'm lucky enough (it is really sensitive), I can hear *some* sound from the headphone. I emphasize the word "some" is just because the sound I hear is not all the channels the source contains. When I was watching a movie, I can hear the background sound (like musics) but no conversations. If I unplug the headphone, sound is perfect with the internal speaker. It feels like the headphone shoe is waiting for some multi-channel (more than 2) headphone.

    I'm not sure if I describe everything clear. I don't know what I can do to fix the problem.

    Any idea?
    Last edited by worc; May 5th, 2008 at 03:42 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts