Results 1 to 7 of 7

Thread: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

  1. #1
    Join Date
    Jan 2005
    Beans
    27

    Angry 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    Sigh, I just purchased a brand spakin new 8800GT today hoping it would boost my WoW FPS. Seems like Ubuntu likes my old 7600 better!

    Here's what I did (as i can remember it), and what happened at each step:

    1) Remove old drivers with Envy, install latest NVidia Drivers
    2) Ubuntu loads up, but I get a black screen
    3) Loadup in recovery mode, change my boot options to nosplash and noapic per one forum post, restart
    4) no luck, same issue
    5) Loadup in recovery mode, uninstall Envy drivers, download nvidia drivers directly and install, run nvidia-xconfig
    6) System boots, but loads in low-res mode (800x600)
    7) Change xorg.conf to "force" 1280x1024 and reboot
    8) system flickers between text login and xserver 3 times, then defaults to low res mode again, boots in 1280x1024 mode, but no 3d accel.
    9) Login under low-res mode and try to install drivers from Ubuntu 8.04 restricted libs
    10) see #8

    So here's where I'm at: Unable to use Nvidia drivers, have approximately 15 versions of xorg.conf in my /X11 directory, and still no further progress. I'm afraid to do a re-install since I've read posts where install won't start under 8800 GT.

    Getting myself confused and frustrated, figured it would be a good time to ask for help. Where do I go from here? Is there a way to "clean slate" my xorf.conf file (is it needed)? Would love to use my shiny new card, but if all else fails I'll put the old one back in and return the new card .

  2. #2
    Join Date
    Jan 2008
    Location
    Wherever
    Beans
    298
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    to fix your xorg file and bring it to default type
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    in a terminal.

    not sure about the 8800 gt I'm still running something that's pretty old and has it's own host of issues.

    you might for confusion sake just want to navigate to your X11 file and delete all the extra copies just don't delete all of them you'll need at least one. if I remember right you'll need to navigate to it as root or just use sudo from the terminal
    Asus M70vm-C1 intel 5100 abgn nvidia 9600GS intel 2.53gig centrino2

  3. #3
    Join Date
    Jan 2005
    Beans
    27

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    Thanks for the quick reply! any ideas on how to fix my card issue?

    EDIT: Re-installed nvidia 69.12 drivers via Envy, same issue as above, but now I don't even show the card under Ubuntu restricted drivers. Not really sure where to turn....
    Last edited by oldweasel; May 5th, 2008 at 02:36 AM.

  4. #4
    Join Date
    Jan 2005
    Beans
    27

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    Sorry for the spamming, here's my current xorg.conf:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Feb 14 18:20:37 PST 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Generic Keyboard" "CoreKeyboard"
        InputDevice    "Configured Mouse"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024"
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection
    
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"v4l"
    EndSection
    and my menu.lst:

    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not use 'savedefault' or your
    # array will desync and will not let you boot your system.
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		10
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    #hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ##      kopt_2_6_8=root=/dev/hdc1 ro
    ##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=UUID=01cd9591-2264-474e-b5c6-f1eb0e2b0c8e ro
    
    ## Setup crashdump menu entries
    ## e.g. crashdump=1
    # crashdump=0
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,4)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    
    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ##      lockold=true
    # lockold=false
    
    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=
    
    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery) single
    # altoptions=(recovery mode) single
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    
    ## should update-grub add savedefault to the default options
    ## can be true or false
    # savedefault=false
    
    ## ## End Default Options ##
    
    title		Ubuntu 8.04, kernel 2.6.24-16-generic
    root		(hd0,4)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=01cd9591-2264-474e-b5c6-f1eb0e2b0c8e ro quiet nosplash noapic
    initrd		/boot/initrd.img-2.6.24-16-generic
    quiet
    
    title		Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
    root		(hd0,4)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=01cd9591-2264-474e-b5c6-f1eb0e2b0c8e ro single
    initrd		/boot/initrd.img-2.6.24-16-generic
    
    title		Ubuntu 8.04, memtest86+
    root		(hd0,4)
    kernel		/boot/memtest86+.bin
    quiet
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title		Other operating systems:
    root
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/sda1
    title		Microsoft Windows XP Professional
    root		(hd0,0)
    savedefault
    makeactive
    chainloader	+1

  5. #5
    Join Date
    May 2005
    Beans
    10

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    Try the following:

    1.) Download the correct Linux drivers from the NVIDIA web site.
    2.) Press CTRL+ALT+F2
    3.) Login
    4.) Type in: "sudo su"
    5.) Type in your user password
    6.) Type in: "/etc/init.d/gdm stop"
    7.) Type in: "apt-get install build-essential"
    8.) Goto the location where you downloaded the NVIDIA driver
    9.) Type in: "sh NVIDIA_DRIVER_FILE_NAME"
    10.) Go through the prompts, (let it remove any old drivers) say no to search for kernel module... it will compile and what not.. then say yes to let it overwrite your xorg.conf file.
    11.) Once the install is done, type in: "/etc/init.d/gdm start"
    12.) You should see the NVIDIA logo when it starts up
    13.) Now, open up a terminal within gnome (applications > accessories > terminal)
    14.) Type in: "sudo nvidia-settings"
    15.) Type in your password if prompted
    16.) Expand the window that pops up, it always shows up as a small little box for me... make it as large as you can
    17.) Now you can use the NVIDIA settings program to make changes to resolution, multi-monitors, etc...

    Note that anytime you update your kernel, you'll have to do this because the driver is tied to the kernel... I think.

  6. #6
    Join Date
    Dec 2007
    Location
    Tampa, FL
    Beans
    1,087
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    Quote Originally Posted by oldweasel View Post
    So here's where I'm at: Unable to use Nvidia drivers, have approximately 15 versions of xorg.conf in my /X11 directory, and still no further progress. I'm afraid to do a re-install since I've read posts where install won't start under 8800 GT.
    I have an 8800GT as well and I ran into problems when upgrading from gutsy to hardy. Wouldn't work for anything in this world so I just reinstalled... works like a charm!!!
    Installed a clean Hardy (don't recall having to use safe graphics mode), before any attempt to install the graphics card, select all sources in the repositories (system>administration>software sources) then reload (or type sudo apt-get update in the terminal) and reboot. This will "fix" the restricted drivers issue (initially the driver is marked but not in use - at least in my case) and you'll be able to select and install from there with no problem at all!! This worked for me. Later, I broke ubuntu again (different issue) and gave it a shot using envy-ng and it worked just as good. Search for envyng and 3 options should come up. If you're using Ubuntu, install the envyng-gtk. If you're using Kubuntu, install the envyng-qt. Once installed, the program will show under Applications>System Tools.
    Run the program and it should install the driver properly.
    "There are 10 types of people: Those who read binary and those who don't"
    >>>"who is general failure and why is he reading my files"<<<
    The Ubuntu Counter Project - user number # 22367
    Howto automount NTFS - My wallpaper

  7. #7
    Join Date
    Jan 2006
    Beans
    60

    Re: 8.04 LTS - 8800GT, tried everything, now xorg all messed up!

    I tried to install driver for different nvidia cards and the success was guaranted in Hardy with the procedures:
    1. Enable canonical repositories
    2. go to consol (Alt+Ctrl+F2)
    3. sudo /etc/init.d/gdm stop
    4. sudo apt-get install libc6 libc6-dev make gcc
    5. sudo uname-r (tp find the linux kernel version)
    6. sudo apt-get install linux-headers-(result from the previous command)
    7. sudo apt-get install pkg-config
    8. sudo apt-get install xserver-xorg-dev
    9. sudo dpkg --purge nvidia-glx
    10. sudo rm /etc/init.d/nvidia-glx
    11. sudo rm /etc/init.d/nvidia-kernel
    12. 10. sudo vim /etc/default linux-restricted-modules
    (or linux-restricted-modules-common
    and write in: DISABLED_MODULES="nv nvidia_new"
    13. sudo rm /lib/linux-restricted-modules/.nvidia_new_installed
    14. sh /../nvidiainstaller from the nvidia site
    14. sudo reboot

    that's all.
    Last edited by Tibor60; May 7th, 2008 at 09:49 PM. Reason: missed row

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •