Results 1 to 3 of 3

Thread: Jack problem in Hardy

  1. #1
    Join Date
    Jan 2008

    Jack problem in Hardy

    Hi all! I'm having a lot of problems with jack. Under Gutsy I had a lot of trouble starting the application, but after some experiments it worked fine and i was able to use Ardour.
    I recently upgraded to Hardy, always with Ubuntustudio, and jack starts without any problem, but the audio quality is horrible. With ardour the quality is horrible even if I try to play the files recorded under Gutsy. I tried to change some options, but the only thing that change the quality is the Frames/Period option: it is on 1024, if i try less the things get worse, if i try a higher value jack simply doesn't start.
    Could someone help me, please?

    Thanks for reading!

    EDIT: I found out that my jack tray icon turns red every time. I read that that is an XRUN signal, and if it occurs I have to try to disable realtime and increase the Frames/Period value, but, as I said before, I can't go over 1024...
    Last edited by Elphizo; May 3rd, 2008 at 01:36 PM.

  2. #2
    Join Date
    Apr 2007
    Lubuntu 14.04 Trusty Tahr

    Re: Jack problem in Hardy

    1. Could you post the output of grep audio /etc/security/limits.conf
      Here's mine
      grep audio /etc/security/limits.conf 
      @audio          -       memlock         250000
      @audio          -       nice            -10
      @audio 		- 	rtprio 		99
    2. Have you got the realtime kernel (linux-rt) installed ?

  3. #3
    Join Date
    Jan 2008

    Re: Jack problem in Hardy

    This is my output:
    @audio          -       rtprio          99
    @audio - rtprio 99
    @audio - memlock 250000
    @audio - nice -10
    and yes, i have the real time kernel, which is auto installed with ubuntustudio.
    Anyway, I don't know why but now it works correctly. I was trying some settings and the sound disappeared totally. After a reboot, with the same settings as before(realtime on, frames/period:128,sample rate: 48000), jack worked properly.
    Thanks for the help!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts