Results 1 to 10 of 37

Thread: SPDIF in Hardy

Threaded View

  1. #1
    Join Date
    Oct 2007

    SPDIF in Hardy

    I'm a pretty new member to these forums but I've been searching on them for a while now. I just installed Hardy on my desktop on Sunday and I've had tons of problems (and four reinstalls later, here I am). One of the big issues I've had is getting SPDIF out of my sound card. Well, here is what I did:

    1) type "aplay -l" in a terminal minus the quotes.
    2) if you have a sound card (onboard or otherwise) which can do digital audio output, you should hopefully see it listed. For example, mine looks as such:
    card 0: SB [HDA ATI SB], device 0: ALC882 Analog [ALC882 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC882 Digital [ALC882 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    3) take note of which one is the digital. In my case, it is card 0, device 1.
    4) type "sudo nautilus" into the terminal without the quotes and navigate to "/etc/pulse/" and open "".
    5) add a line at the very bottom like this:
     load-module module-alsa-sink device=hw:0,1
    where the part "hw:0,1" is hardware card 0, device 1 (use the ones you got from step 3).
    6) save and exit this file
    7) type in these commands to reset PulseAudio:
      pulseaudio -k
            pulseaudio -D
    8) verify using pavucontrol (type "sudo apt-get install pavucontrol" to install it, and once installed, just type "pavucontrol" in the terminal. You should be able to look in the next tab and see both your standard analog device, as well as the one we added in. Right click the new one and choose make default (if that is what you desire).

    It seems this helps a lot of people, but I needed a few more steps (you may need them as well, so follow these if the above still doesn't work.

    9) double click the speaker icon in the notification area (upper right corner near shut down button).
    10) make sure that under "file/change device", you see the device that corresponds to the one you found in step two (ex- mine is "SB [HDA ATI SB]"). If it isn't the right one, select the right one.
    11) go to "edit/preferences" and with the little menu that pops up, just go ahead and put a check mark next to everything. Now, close the pop up, as well as the volume control menu.
    12) reopen the volume control menu by clicking on the speaker in the upper right again.
    13) in the tab labeled "switches", make sure to uncheck the headphone option and to have checked iec958 and iec958 capture (important, although I'm not sure why).
    14) in the original tab (playback), make sure that master volume is at a good volume (and not muted).

    Hopefully that should do it for you. I have no idea why one has to go through all this nonsense (especially notifying PulseAudio of the digital device in What is even worse is that on both my desktop and my laptop, I can't even play an mp3 using VLC with PulseAudio without getting serious sound artifacts every few seconds in VLC, so I have to change the output module to ALSA (perhaps just a VLC issue as Totem seems to not have the same problem).

    Anyways, I'm using a Gigabyte 790FX motherboard with an ALC889A sound card. For whatever reason, it is recognized as an ALC882 (as you can see above). Is there anyway to get DTS:Connect to work in Linux? I've tried using the Realtek drivers twice, and on both occasions, they completely hosed my install, forcing me to reinstall.

    Thanks to this person for helping me out.
    Last edited by devguy; May 1st, 2008 at 08:12 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts