Page 5 of 5 FirstFirst ... 345
Results 41 to 45 of 45

Thread: Canon iP2600....anyone?

  1. #41
    Join Date
    Jul 2010
    Ubuntu 10.04 Lucid Lynx

    Re: Canon iP2600....anyone?

    Quote Originally Posted by lubeck View Post
    DRIVERS for the CANON Pixma iP2600 are indeed located at: as "naildeca" says.

    Couple Notes, FYI:
    This install took about 5 minutes... easy for a noob like me.

    In addition to the two .deb files (the drivers) mentioned by "naildeca" above at this site (the drivers appear when you select the Injet, Pixma, iP2680 printer, Downloads), are the VERY USEFUL Linux install instructions (Ubuntu included) listed if you then select "Manuals":

    "IJ Printer Driver Ver. 2.90 for Linux (Operation guide [Explanation of the iP2600series operation (html file)]"

    With this wonderful documentation the installation went a bit easier... since there is one install step one must take before installing the .debs.

    Noteworthy in these instructions, CANON recommends the following command at the Terminal before installing the .debs, to ready the system to "receive" them. I found this necessary and fundamental:

    sudo aa-complain cupsd

    Final Notes:
    The install instructions include a step called "Register the Printer to the Spooler." A sample command is shown, so this is easy to do. However, part of the command needs two things that are peculiar to your computer after you install the .debs.
    Printer name and the URI may be easily found at System, Administration, Printing ... and your iP2600 PPD can be found using "locate *.ppd" at the command line.

    If it helps, mine was located in /usr/share/ppd/canonip2600.ppd, and after the Registration command, in /etc/cups/ppd/canonip2600.ppd

    Some applications need to be told the Printer "PPD" to allow them to understand how to talk to the iP2600, so you may want to save this location in a text file--for later recall or copy & paste.
    Thanks to those who forged the path and helped me find the drivers.
    Best wishes.
    I finally got it to work thanks!!

    i found that i needed to remove and reinstall the cnijfilter-common2 package before i got it to work.
    Last edited by stovie87; July 25th, 2010 at 08:57 AM. Reason: misspelling

  2. #42
    Join Date
    Jul 2010
    Ubuntu 10.04 Lucid Lynx

    Re: Canon iP2600....anyone?

    If you tried installing the Asian drivers but you're getting a dependencies error try these. The dependencies were changed using a tutorial on the web. Worked for me.

  3. #43
    Join Date
    May 2012

    Canon Pixma iP2600 for Ubuntu 12.04 32-bit

    Okay after a ridiculous amount of hassle, I have found a method to make an iP2600 work in Ubuntu 12.04
    First download the two customized drivers from this thread
    These are drivers that have been altered to enable the driver to play nicely with the new libcups2 package.

    Next, open the terminal.
    type: sudo aa-complain cupsd
    This prepares the system for the driver, also move your downloaded files to your Home folder out of downloads.

    Next, in the terminal, type: sudo dpkg -i cnijfilter-common_2.90-1_i386_1004customized.deb

    Then follow that up with: sudo dpkg -i cnijfilter-ip2600series_2.90-1_i386_1004customized.deb

    These should now be installed but there will be a filter issue. You resolve this with two commands:
    sudo chown root /usr/lib/cups/filter/pstocanonij
    sudo chmod 755 /usr/lib/cups/filter/pstocanonij

    Now the printer should be able to be added through the control menu at the top right -printers... and if needed, Add...

    Hope it helps!

    Acknowledgements: Thank you to MillDaKill, China_Jobs, and for the info and files, since this is but an application and compilation of your work.
    Tested on: Ubuntu 12.04 LTS Precise Pangolin 32-bit
    Last edited by murpter; May 18th, 2012 at 10:27 PM.

  4. #44
    Join Date
    Dec 2012

    Another Way to Install Canon IP2600 Driver

    I know, I'm very late, but...

    Please view this tutorial, it contains very easy instruction for terminal user and shell script user.

  5. #45
    Join Date
    Aug 2013

    Re: Canon iP2600....anyone?

    An even later response, but those who are running 12.04 LTS and above 64bit will like this one!
    The second answer worked perfectly for me on an AMD dual core running 64bit. In case the link above should stop working, here's the meat of it:
    After updating to Ubuntu 13.04 (64-bit), I got my Canon ip2600 printer to work with the canon-trunk repository:
    sudo add-apt-repository ppa:michael-gruz/canon-trunk
    sudo apt-get update
    sudo apt-get install cnijfilter-ip2600series
    Hope that helps someone else

Page 5 of 5 FirstFirst ... 345


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts